LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Using Linux on Surface Pro to study Networking with GNS3 (https://www.linuxquestions.org/questions/linux-newbie-8/using-linux-on-surface-pro-to-study-networking-with-gns3-4175602200/)

Cytota 03-20-2017 12:44 PM

Using Linux on Surface Pro to study Networking with GNS3
 
Hey ya'll,

I got my hands on an i7 8 GB Surfhttp://docs.gns3.com/1QXVIihk7dsOL7Xr7Bmz4zRzTsJ02wklfImGuHwTlaA4/ace Pro 3 to study for a Cisco CCNA cert. Apparently one of the best way to emulate Switches is to use GNS3 in a Linux environment. Well, I've been trying for a week to use Linux in this way on my Surface.

I'm at my wits end. I don't know what I'm doing and following detailed tutorials has sent me down rabbit holes with no way out.

I've tried Ubuntu, Manjaro and now Fedora. The last two supposedly having SP3 support built in. Maybe my problem is that I have a Type Cover 4. Fedora 25 boots and works with my roommate's Type Cover 3, so I'd like to figure out how to update Fedora to work with the newer cover if possible.

But then I look at GNS3's installation guide:
http://docs.gns3.com/1QXVIihk7dsOL7X...lfImGuHwTlaA4/

and see that Fedora's installation is broken?

I am frustrated and at a loss how to proceed. I don't understand the terminal, or where to find step-by-step guides to entering commands.

Maybe I shouldn't use Linux to study, I've just read that there are emulation issues using VMWare in Windows - which I also have no idea how to use. I'm not interested in mastering terminal use -right now- my main goal is to get a Cisco cert to improve my income, I'm happy to learn Linux more later.


tl;dr:
Following tutorials for some reason keeps me from getting Linux flavors operating properly on my Surface & I don't have a clue how to install GNS3 for full functionality.

Any resources and tips ya'll can share would be appreciated!

Add Edit:

So, I try this on Manjaro:

https://parlotti.wordpress.com/2013/...manjaro-linux/

I'll type into Terminal:
sudo yaourt S-gns3
result:
target not found: gns3

So, I'm ignorant on how this could be, trying to work through that.

jefro 03-21-2017 04:32 PM

I think I'd run a free virtual machine. It is a windows program that like any will allow you to run it in a window and move from window to window. The sourceforge https://sourceforge.net/projects/gns-3/files/ has a number of images that can be imported. What is on those images, I can't tell. Might run under windows if you had python installed.

Maybe someone else has a better solution. You'd think someone would have this package already configured.

It is the learning curve I'm most concerned about. If there is a easy way to get windows to run this then that would be best.

You really could run this on something like susestudio.com if you make up an appliance. then you could run it from any web browser.

Rickkkk 03-21-2017 04:47 PM

Hey Cytota.

One of the machines on which I dual-boot Windows and linux (Arch) is a Surface Pro 3 - been using it that way for about 18 months now.

That said, it's a bit of a complicated job to get it set up that way and certain features are still not 100% supported (type-cover multitouch ... hope is that kernel 4.11 will address this ...).

If you're unfamiliar with linux to begin with, I would definitely recommend going the virtual machine route. I use Virtualbox and can confirm that it works well under Windows 10 on the Surface Pro 3. As a matter of fact, I started out using linux on the SP3 in this manner before deciding to install it natively and dual boot.

As a preview of what to expect, dual-booting on the SP3 involves :

- taking a backup of the system before making changes

- ... (at least temporarily) disabling Secure Boot

- manipulating the ESP (EFI System Partition)

- installing a 3rd-party boot loader (I use rEFInd), with or without a shim and MOK manager (depending on your intention to use Secure Boot or not)

- repartitioning the SP3's SSD drive

- ... and then installing your linux distro ...

- .. depending on your distro of choice, you may or may not need to patch your kernel to have 100% support for all of the SP3's hardware.


So ... if all that seems daunting (... and, not to be discouraging, .. it CAN be ...), then rejoice in the fact that in a Virtualbox VM, it just works. For learning purposes, I would DEFINITELY start this way.

As to GNS3, I'll let someone else here chime in - I have no idea what that is.

Hope this helps - cheers.

Ztcoracat 03-21-2017 10:45 PM

Looking here at the Fedora commands:
http://docs.gns3.com/1QXVIihk7dsOL7X...lfImGuHwTlaA4/

Your right it's broken. That stinks:-Sorry, Wayland in Fedora 25 seem to be not-
Developers are still working on Wayland.

Maybe try Arch or Sabyon. If it were me I'd try Debian first.
In which both have their own package management system.

https://www.virtualbox.org/wiki/Downloads

Quote:

I'm at my wits end. I don't know what I'm doing and following detailed tutorials has sent me down rabbit holes with no way out.
I hear you:- BTDT

I downloaded GNS3.
Using a simulator to design and configure virtual networks seems really cool!

I'll play with it and if I can figure it out I'll enlighten you on the configuration.

Ztcoracat 03-21-2017 11:07 PM

Here's how to install on a Windows machine:

https://www.youtube.com/watch?v=ey3fEybZ5zw

Install Config and Setup:
https://www.youtube.com/watch?v=HzFi4E42fHU

I don't have any Windows machines so I'll try with Linux and see what happens.
Notice I said "try".


All times are GMT -5. The time now is 10:11 AM.