LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   "Users and Groups" User Interface (https://www.linuxquestions.org/questions/linux-newbie-8/users-and-groups-user-interface-332132/)

septhar 06-10-2005 05:15 AM

"Users and Groups" User Interface not working
 
Hi,

I have a RedHat LInux 9 installation and it was working well. I've added users using the "Users and Groups" user interface. Recently, I noticed that the Users and Groups interface is not working. It does not show up at all.

Please suggest a solution to this.

Thanks and Regards,
Septhar

hardcorelinux 06-10-2005 06:34 AM

Use useradd and groupadd commands from your console, that is better than normal graphical way's.

More more options about this commands type take the man pages of respective commands

man useradd

man groupadd

septhar 06-10-2005 06:37 AM

i did try useradd before i posted this request.

the following message was displayed ...........

"bash: useradd: command not found"

hardcorelinux 06-10-2005 07:05 AM

Try

/usr/sbin/useradd <username>


/usr/sbin/groupadd <groupname>

septhar 06-10-2005 07:09 AM

no use, i still get the same error .. please see below

[root@bugzilla sbin]# pwd
/usr/sbin

[root@bugzilla sbin]# useradd shaji
bash: useradd: command not found
[root@bugzilla sbin]#

hardcorelinux 06-10-2005 07:29 AM

locate useradd

locate groupadd

check whether command is there or not,if not there u want to install corresponding rpm.



Are u trying to do this as a normal user or as a root user , u should logged it as root then it will work .

septhar 06-10-2005 07:52 AM

done. i am logged in as root. the useradd command is available and it worked from the console.

i'm not sure but, probably it didnt work earlier since i had logged in from a remote machine using telnet. the useradd worked from the console on the machine on which rh9 is installed. thank you.

my actual problem is that i'm not able to use the graphical user interface to add or modify users and groups.

hardcorelinux 06-10-2005 08:03 AM

Ok switch to graphical mode now(as root) try again that also .

septhar 06-10-2005 08:22 AM

i always login as root and i'm logged in as root at the moment.

the interface is not displayed when i click the RH Main Menu > System Settings > Users and Groups

that is i am unable to view the interface as mentioned on this link http://www.redhat.com/docs/manuals/l...fig-users.html

hardcorelinux 06-11-2005 12:32 AM

Which desktop env you are using,in that redhat manual they are explaining GNOME based desktop.

Check whether Gui userconfiguration tool is installed or not.

rpm -qa|grep redhat-config-users

if it is installed type the command redhat-config-users at a shell prompt (for example, in an XTerm or a GNOME terminal).

septhar 06-13-2005 06:10 AM

i'm using GNOME environment

i executed the command you gave on an XTerminal, the following was displayed -

[root@bugzilla root]# rpm -qa|grep redhat-config-users
redhat-config-users-1.1.5-7
[root@bugzilla root]#


All times are GMT -5. The time now is 12:52 AM.