LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   User can't startx (https://www.linuxquestions.org/questions/linux-newbie-8/user-cant-startx-400876/)

sr_25 01-08-2006 11:45 AM

User can't startx
 
In Slackware 10.2 root can startx(KDE) but user can't. As a user I get the following:
Xauthority timeout in locking
Authority file /home/jon/Xauthority
Then I get a white screen and a MessageBox:
No write access to home directory.

I did a search on this board and came up with some similar problems. One said to delete ymessenger and .xinitrc file from user account home directory, but neither of these exist. Another said to look at .xsession-errors in home directory, but is doesn't exist.

So what should I do? Sorry, if this has been already covered but I could not find it.

halvy 01-08-2006 12:40 PM

have you tried deleting the user, then creating him under root?

did this just occur outa the blue.. or were you working on somthing recently that might have changed things (like installing software).

is this a new install.. if so maybe you didn't follow slackwares protocol for making new 'users'.

i am not familiar with slack enuff to know these protocols.

good luck.

sr_25 01-08-2006 02:01 PM

I tried to delete the user:
'userdel -r jon' and I received an error:
/home/jon not owned by jon, not removing.

So do I need to change permissions on the folder? If so how?

currently under Konqueror permissions are listed as: 'rwx------'.

sr_25 01-08-2006 04:38 PM

Okay, I got it working I deleted the user then recreated the user and this time when it asked to: 'chown /home/jon' I made sure to say yes. Eveything works now.


All times are GMT -5. The time now is 11:13 AM.