-   Linux - Newbie (
-   -   User can't login with Gnome or KDE (

jason 07-10-2002 09:43 PM

User can't login with Gnome or KDE
My Red Hat Linux box shut down abnormally due to an electrical storm that came out of nowhere. Now, I'm having trouble logging back in as "jason", the user I was logged in as when the computer shut down. I can still log in as other users, including root.

When I try to log in from the graphical login prompt, the screen goes black and then comes back up with the graphical login prompt. Every other user can log in.

I was, however, able to login as user "jason" using the failsafe option under Session.

I've read a few posts on login trouble, and I have tried a few suggestions. I deleted the .gnome* files in /home/jason. When that didn't work, I removed jason (userdel jason), but kept jason's home directory. I then recreated the user jason. However, I still can't login. I also made sure that there is plenty of space on the disk.

I am also not able to login using KDE, but the login gets a little further before failing.

Any suggestions?


jason 07-11-2002 11:42 AM

I've checked thru some of the logs in /var/log. I can see that a session is opened for jason, and then that session is closed after a couple of seconds. What would cause the session to be closed so quickly?

Also, I've noticed a couple of suspicious lines during bootup, indicating that /poweroff and /shutdown could not be removed (input/output error). Is this related to my problem? :confused:

jetblackz 07-11-2002 07:29 PM

Post the lines here please.

You know the other day I didn't notice a power blackout until my computer complained about my printer was off. Granted, there's an UPS under the desk.

My guess would be that some KDE/Gnome dependent files were screwed. The easy way is to log in as root, go to menu> system> user man, edit "jason" name & login to something else, then add a "jason" user with a new directory. Copy your favorites/files to there. Do NOT copy any .* files or scripts or profiles, etc. That would be what the culprit is.

Oh and I have had messed up an account that resulted in a similar scenario.

Note: you should log into the new account once before copying files. The login will produce proper directory structures.

benjaminrtz 07-11-2002 11:31 PM

Sometimes it works this way . Delete the user jason without deleting his home dir .And then create the jason again. CHange the onwership and group onwership bach jo jason .
Just check it out . Sometimes it works ;-)

jason 07-12-2002 09:42 AM

Thanks for your suggestions. :) I was hoping I wouldn't have to delete the user. I ended up backing up all of the non-hidden files in /home/jason, removing jason, adding jason back, and restoring the non-hidden files. It worked well enough.

For fun, I restored the hidden files. Sure enough, the problem resurfaced. If it happens again, maybe I will try to find the hidden file(s) that caused the problem.

As far as the /poweroff problem, I booted up the computer with the pre-compiled Red Hat 7.2 kernel, and then re-booted the computer with the kernel I compiled, and the problem went away.

Maybe it's time to get a UPS?

Thanks again,
jason :)

jetblackz 07-12-2002 02:26 PM

You're welcome.

I got my UPS for real cheap when there was a sale. Half the regular price. I missed another sale of APC beige box for about the same price. Mine is grey, BTW. It lasts for 6+ mins on battery. I think all modern power supplies should come standard with UPS built-in. 10 mins is a good start. Like most laptops.

benjaminrtz 07-14-2002 11:42 PM

Well Jason ,
U don't have to worry about backing up the non-hidden files in ur home dir unless you choose to delete a user's home dir while removing a user .
Eg:- userdel -r jason will delete jason and his home . DO u wanna lose ur home !!! :-)

All times are GMT -5. The time now is 06:16 AM.