-   Linux - Newbie (
-   -   Used Acronis to resize a partition now the system won't boot (

high_hopes 07-11-2004 09:59 PM

Used Acronis to resize a partition now the system won't boot
I am running the following configuration on a Dell Laptop: Windows XP Pro on one harddrive and Slackware 9.1 on another one. The Slack hard drive is split up into the swap partition, the main partiition and a small partition that I have never used or mounted.
I wanted to increase the size of this last one in order to move the home partition on it and I used Acronis from Windows. Everything seemed fine untill I tried to boot the system. LILO doesn't even come up and the error I receive is that the partition is not bootable.
Any experiences with this?

rylan76 07-12-2004 12:27 AM

No experience, but what went wrong as far as I know is that "Acronis" (strange name) has overwritten your boot sector. If you have a Suse recovery floppy (RedHat 9's install created one for me - don't know if Suse does too) try to boot from that - it should give you access to the HDD with Suse on it. Then, google for "lilo reinstall" - there are lots of guys who have ran into this problem before, you should quickly find specific info on how to reinstall lilo so you can once again choose to either boot XP or Suse on system startup. I vaguely remember (I use GRUB these days) that you need to run "lilo" as root and then type one or two commands to reinstall Lilo into the primary HDD's MBR (master boot record) in order for it to start once more when you reboot your system.

high_hopes 07-12-2004 01:19 PM

Thanks for the reply. I did use the Slackware installation CD 1 to boot and to run "setup" in order to reinstall LILO on the boot partition. Fortunatelly it worked without any loss of information. I did lose the old lilo.config and had to redo it but I thought that was minimum casualty. Overall I am pretty impressed by Acronis who was able to see, resize and format (reiserfs) linux partitions from a windows instalation. I hate the boot manager though.
Anyway, thanks. Can anyone offer any help on how to move the home directory from one partion to another?
Thank you,

high_hopes 07-12-2004 01:33 PM

Nevermind, I found some great links about how to move the /home directory onto another partion already posted by motub at
Thak you all.

All times are GMT -5. The time now is 03:47 PM.