-   Linux - Newbie (
-   -   USBstick problems! (

chansen0421 01-13-2005 07:01 PM

USBstick problems!
I am using Fedora Core 2 distro which does not have usbstick support.
I added the line:
/dev/sda /mnt/usbstick vfat noauto,owner,rw 0 0 0
I also tried:
/dev/sda1 /mnt/usbstick vfat noauto,owner,rw 0 0 0

the error message that I get when I try mounting the usbstick is:
mount: can't find usbstick in /etc/fstab or /etc/mtab

I have added the /mnt/usbstick dir
any suggestions would be helpfull


shep 01-13-2005 07:38 PM

Have you tried to mount the drive manually?

mount -t vfat /dev/hda1 /mnt/usbstick

Is the drive partitioned? BTW, /dev/sda is the drive, /dev/sda1 is the first partition on the drive. Also, be aware that if you have more than one usb storage device, the usb stick may be /dev/sdb.

Tinkster 01-13-2005 07:39 PM

What does the mount-command look like?

And what do you get from
fdisk -l
with the stick plugged-in?


chansen0421 01-15-2005 12:57 PM

Thanks for the options.
with the

:mount -t vfat /dev/hda1 /mnt/usbstick

command I receaved this message:

:mount: wrong fs type, bad option, bad superblock on /dev/hda1,
or too many mounted file systems

then with the fdisk -l
it gives me this message:

Disk /dev/sda: 262 MB, 262144000 bytes
32 heads, 33 sectors/track, 484 cylinders
Units = cylinders of 1056 * 512 = 540672 bytes

Device Boot Start End Blocks Id System
/dev/sda1 * 1 485 255984 6 FAT16
Partition 1 has different physical/logical beginnings (non-Linux?):
phys=(0, 1, 1) logical=(0, 0, 33)
Partition 1 has different physical/logical endings:
phys=(254, 31, 33) logical=(484, 27, 5)

I am so new at this, I have very little clue as to what this is telling me.

any more suggestions?

Tinkster 01-15-2005 01:40 PM


Originally posted by chansen0421
[B]:mount -t vfat /dev/hda1 /mnt/usbstick

/dev/sda1 * 1 485 255984 6 FAT16
Instead of hda1 you need to use sda1 ...

You still didn't tell me how you originally tried to
mount it, because the fstab line actually matches
the physical device ... maybe your problem with
the original attempt was that you were trying
something like
mount usbstick
but weren't actually sitting in /mnt but rather
in ~ or something along those lines.


All times are GMT -5. The time now is 08:59 AM.