LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   USB Scanner problem (https://www.linuxquestions.org/questions/linux-newbie-8/usb-scanner-problem-517385/)

arindom 01-08-2007 06:35 AM

USB Scanner problem
 
While Fedora 6 is booting up and my Acer (benq 4300) scanner is connected via USB port I am getting the following error.

"USB 1:1 read/all error -71" and then the device is going power off. I am sure that the scanner is Ok because from Windows it is working perfectly from the same port. Even in Fedora 6 the scanner is correctly recognized when I am trying to swich it on when the system is up, but then also Xsane is giving the following error -

"Failed to open device 'snapscan:libusb:001:005':-Invalid argument"

Please help.

Simon Bridge 01-10-2007 05:49 AM

sane gives "good" support via snapscan:
http://www.sane-project.org/man/sane-snapscan.5.html

This may be a problem with the configuration file.
If you are using libusb (likely), then check that the configuration file doesn't have a device line (i.e. no line like /dev/usb/scanner0).

arindom 01-10-2007 08:22 AM

I have not found the configuration file. I checked /usr/local/etc. But there is no sane.d file.

While I issued the command
# sane-find-scanner

the output is

found USB scanner (vendor=0x04a5 [Color], product=0x20b0 [ FlatbedScanner 22]) at libusb:002:002

Which means the scanner is detected. But it seems the configuration file is missing. Please suggest futher action. I have seen the link also.

Simon Bridge 01-10-2007 08:16 PM

$ locate sane.d
or
$ locate snapscan

The config file is /etc/sane.d/snapscan.conf on my system. It is already set to autoscan usb via libusb (but that is for me.)

I notice the scanner is found at libusb:002:002 but the error message mentions libusb:001:005 ... you could try using scanimage on the commandline and explicitly specify the device found by sane-find-scanner.

try

scanimage -d snapscan:libusb:002:002 image.pnm

(example only - i.e. explicitly state your device to use on the commandline)

And, of course, read man sane-usb

arindom 01-10-2007 10:20 PM

Thanks Simon, I found the configuration file. It's there in the same place : /etc/sane.d/snapscan.conf

I checked the file and found my scanner up there .

# Benq/Acer/Vuego 4300
usb 0x04a5 0x20de


Also the line /dev/usb/scanner0 is already commented in the file as follows.
-----------------------------------------
# For USB scanners also specify bus=usb, e.g.
# /dev/usb/scanner0 bus=usb

-----------------------------------------
Regarding the error message I have put in the cable in my USB 2 port from USB 5 port. So that is ok. Now the error message is showing "snapscan:libusb:002:002"

I should also mention here that when I am loading XSane, it is showin a list of devices it has found. One is /dev/video0 (TV Card) and the next one is my scanner ACer Flatbed Scanner 22.

Moreover at the prompt this time I found an error message
----------------------------------
Cannot open firmware file /usr/share/sane/snapscan/your-firmwarefile.bin.
----------------------------------
If I am correct then I believe I have to replace the firmware line with the actual location of my driver file which is u222v067.bin which is the correct driver for the scanner.

I searched the file
$ locate u222v067.bin
No result.

Please advise what to do now? Thanks for you help friend. You have shown some light for me at the end of the tunnel.

Simon Bridge 01-10-2007 10:43 PM

When you purchased the scanner, you got a disk with it. Firmware is on the disk - fingers crossed - otherwise you need to check the manufacturers website.

It may be that firmware is not needed - in which case you can try commenting out the "firmware" line in snapscan.conf ...

arindom 01-11-2007 04:39 AM

I tried commenting the firmware line, not working. I think now I have to find that .bin file and load it.

Thanks for your help friend.

arindom 03-07-2007 07:35 PM

Hello again,

Finally I have been able to get the bin file. In the meantime I am now working in OpenSuse10.2.

Now the scanner is recognized by sane-find-scanner tool.

"found USB scanner (vendor=0x04a5, product=0x20b0) at libusb:002:002"

But when I am trying to use the scanner through XSane it is saying no scanner. Scanimage -L is also say "No scanner is identified"

I have also tried setting up the scanner through YAST. Though the scanner is found by YAST but the message coming is, scanner not configured.

Please suggest.

Simon Bridge 03-08-2007 12:48 AM

man sane-snapscan

make sure that snapscan.conf is correct for your setup.

arindom 03-08-2007 02:19 AM

Thanks Simon for being so supportive and helpful.

I have checked the /etc/sane.d/snapscan.conf. I didn't found any enty having this "vendor=0x04a5, product=0x20b0". So I have added that and then once I reboot I would report you the result.

Thanks again. It seems I am near to a solution.

------------
EDIT
------------
No not even after reboot the situation changed. Still Device Not Found.


All times are GMT -5. The time now is 05:57 AM.