LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
 
Search this Thread
Old 05-14-2009, 03:02 AM   #1
Ayyappan
LQ Newbie
 
Registered: May 2009
Posts: 4

Rep: Reputation: 0
Unhappy USB Pen Drive not detected in Linux (suse & Ubuntu) working fine in windows XP


USB Pen Drive not detected in Linux (suse & Ubuntu) but working fine in windows XP.

Please find the output of basic commands (as root)

linux-p8ic:~ # lsusb
Bus 001 Device 002: ID 064e:a103 Suyin Corp.
Bus 001 Device 001: ID 0000:0000
Bus 007 Device 001: ID 0000:0000
Bus 004 Device 001: ID 0000:0000
Bus 006 Device 002: ID 192f:0416
Bus 006 Device 001: ID 0000:0000
Bus 002 Device 001: ID 0000:0000
Bus 003 Device 001: ID 0000:0000
Bus 005 Device 001: ID 0000:0000


linux-p8ic:~ # fdisk -l

Disk /dev/sda: 320.0 GB, 320072933376 bytes
255 heads, 63 sectors/track, 38913 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/sda1 1 13055 104864256 83 Linux
/dev/sda2 13056 26110 104864287+ 83 Linux
/dev/sda3 * 26111 26241 1052257+ 83 Linux
/dev/sda4 26242 38913 101787840 f W95 Ext'd (LBA)
/dev/sda5 26242 26764 4200966 82 Linux swap / Solaris
/dev/sda6 26765 31985 41937651 c W95 FAT32 (LBA)
/dev/sda7 31986 35632 29294496 83 Linux
/dev/sda8 35633 38913 26354601 83 Linux

linux-p8ic:~ # dmesg | tail
usb 7-1: new high speed USB device using ehci_hcd and address 63
usb 7-1: new high speed USB device using ehci_hcd and address 65
usb 7-1: new high speed USB device using ehci_hcd and address 66
usb 7-1: new high speed USB device using ehci_hcd and address 68
usb 7-1: new high speed USB device using ehci_hcd and address 69
usb 7-1: new high speed USB device using ehci_hcd and address 70
usb 7-1: new high speed USB device using ehci_hcd and address 71
usb 7-1: new high speed USB device using ehci_hcd and address 72
usb 7-1: new high speed USB device using ehci_hcd and address 74
usb 7-1: new high speed USB device using ehci_hcd and address 76

linux-p8ic:~ # dmesg | tail -100
usb 7-1: new high speed USB device using ehci_hcd and address 33
usb 7-1: new high speed USB device using ehci_hcd and address 35
usb 7-1: new high speed USB device using ehci_hcd and address 36
hub 7-0:1.0: Cannot enable port 1. Maybe the USB cable is bad?
usb 7-1: new high speed USB device using ehci_hcd and address 39
usb 7-1: new high speed USB device using ehci_hcd and address 40
usb 7-1: new high speed USB device using ehci_hcd and address 41
usb 7-1: new high speed USB device using ehci_hcd and address 44
usb 7-1: new high speed USB device using ehci_hcd and address 46
usb 7-1: new high speed USB device using ehci_hcd and address 47
hub 7-0:1.0: Cannot enable port 1. Maybe the USB cable is bad?
usb 7-1: new high speed USB device using ehci_hcd and address 49
usb 7-1: new high speed USB device using ehci_hcd and address 52
usb 7-1: new high speed USB device using ehci_hcd and address 55
usb 7-1: new high speed USB device using ehci_hcd and address 56
usb 7-1: new high speed USB device using ehci_hcd and address 58
usb 7-1: new high speed USB device using ehci_hcd and address 62
usb 7-1: new high speed USB device using ehci_hcd and address 64
usb 7-1: new high speed USB device using ehci_hcd and address 65
usb 7-1: new high speed USB device using ehci_hcd and address 66
usb 7-1: new high speed USB device using ehci_hcd and address 67
usb 7-1: new high speed USB device using ehci_hcd and address 69
usb 7-1: new high speed USB device using ehci_hcd and address 71
usb 7-1: new high speed USB device using ehci_hcd and address 72
usb 7-1: new high speed USB device using ehci_hcd and address 75
usb 7-1: new high speed USB device using ehci_hcd and address 79
usb 7-1: new high speed USB device using ehci_hcd and address 80
usb 7-1: new high speed USB device using ehci_hcd and address 81
usb 7-1: new high speed USB device using ehci_hcd and address 82
usb 7-1: new high speed USB device using ehci_hcd and address 83
usb 7-1: new high speed USB device using ehci_hcd and address 87
usb 7-1: new high speed USB device using ehci_hcd and address 90
usb 7-1: new high speed USB device using ehci_hcd and address 91
usb 7-1: new high speed USB device using ehci_hcd and address 92
usb 7-1: new high speed USB device using ehci_hcd and address 93
usb 7-1: new high speed USB device using ehci_hcd and address 95
usb 7-1: new high speed USB device using ehci_hcd and address 96
usb 7-1: new high speed USB device using ehci_hcd and address 98
usb 7-1: new high speed USB device using ehci_hcd and address 99
usb 7-1: new high speed USB device using ehci_hcd and address 101
hub 7-0:1.0: Cannot enable port 1. Maybe the USB cable is bad?
usb 7-1: new high speed USB device using ehci_hcd and address 102
usb 7-1: new high speed USB device using ehci_hcd and address 103
usb 7-1: new high speed USB device using ehci_hcd and address 105
usb 7-1: new high speed USB device using ehci_hcd and address 106
usb 7-1: new high speed USB device using ehci_hcd and address 108
usb 7-1: new high speed USB device using ehci_hcd and address 109
usb 7-1: new high speed USB device using ehci_hcd and address 110
usb 7-1: new high speed USB device using ehci_hcd and address 113
usb 7-1: new high speed USB device using ehci_hcd and address 115
usb 7-1: new high speed USB device using ehci_hcd and address 116
usb 7-1: new high speed USB device using ehci_hcd and address 117
usb 7-1: new high speed USB device using ehci_hcd and address 118
usb 7-1: new high speed USB device using ehci_hcd and address 121
ehci_hcd 0000:00:1d.7: port 1 reset error -110
hub 7-0:1.0: hub_port_status failed (err = -32)
usb 7-1: new high speed USB device using ehci_hcd and address 124
usb 7-1: new high speed USB device using ehci_hcd and address 125
usb 7-1: new high speed USB device using ehci_hcd and address 126
usb 7-1: new high speed USB device using ehci_hcd and address 127
usb 7-1: new high speed USB device using ehci_hcd and address 3
hub 7-0:1.0: Cannot enable port 1. Maybe the USB cable is bad?
usb 7-1: new high speed USB device using ehci_hcd and address 6
usb 7-1: new high speed USB device using ehci_hcd and address 8
usb 7-1: new high speed USB device using ehci_hcd and address 10
usb 7-1: new high speed USB device using ehci_hcd and address 14
usb 7-1: new high speed USB device using ehci_hcd and address 15
usb 7-1: new high speed USB device using ehci_hcd and address 18
usb 7-1: new high speed USB device using ehci_hcd and address 19
usb 7-1: new high speed USB device using ehci_hcd and address 22
usb 7-1: new high speed USB device using ehci_hcd and address 25
usb 7-1: new high speed USB device using ehci_hcd and address 26
usb 7-1: new high speed USB device using ehci_hcd and address 27
usb 7-1: new high speed USB device using ehci_hcd and address 30
usb 7-1: new high speed USB device using ehci_hcd and address 31
usb 7-1: new high speed USB device using ehci_hcd and address 34
usb 7-1: new high speed USB device using ehci_hcd and address 35
usb 7-1: new high speed USB device using ehci_hcd and address 36
usb 7-1: new high speed USB device using ehci_hcd and address 37
usb 7-1: new high speed USB device using ehci_hcd and address 39
usb 7-1: new high speed USB device using ehci_hcd and address 41
usb 7-1: new high speed USB device using ehci_hcd and address 42
usb 7-1: new high speed USB device using ehci_hcd and address 45
usb 7-1: new high speed USB device using ehci_hcd and address 48
hub 7-0:1.0: Cannot enable port 1. Maybe the USB cable is bad?
usb 7-1: new high speed USB device using ehci_hcd and address 51
usb 7-1: new high speed USB device using ehci_hcd and address 54
usb 7-1: new high speed USB device using ehci_hcd and address 57
usb 7-1: new high speed USB device using ehci_hcd and address 60
usb 7-1: new high speed USB device using ehci_hcd and address 61
usb 7-1: new high speed USB device using ehci_hcd and address 63
usb 7-1: new high speed USB device using ehci_hcd and address 65
usb 7-1: new high speed USB device using ehci_hcd and address 66
usb 7-1: new high speed USB device using ehci_hcd and address 68
usb 7-1: new high speed USB device using ehci_hcd and address 69
usb 7-1: new high speed USB device using ehci_hcd and address 70
usb 7-1: new high speed USB device using ehci_hcd and address 71
usb 7-1: new high speed USB device using ehci_hcd and address 72
usb 7-1: new high speed USB device using ehci_hcd and address 74
usb 7-1: new high speed USB device using ehci_hcd and address 76
linux-p8ic:~ #

Kindly help me in resolving this issue.

Thanks,
Ayyappan.
 
Old 05-14-2009, 04:53 AM   #2
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,020
Blog Entries: 11

Rep: Reputation: 907Reputation: 907Reputation: 907Reputation: 907Reputation: 907Reputation: 907Reputation: 907Reputation: 907
Hi, welcome to LQ!

Quote:
Originally Posted by Ayyappan View Post
USB Pen Drive not detected in Linux (suse & Ubuntu) but working fine in windows XP.

Is that on the same computer? Or is windows on a
different machine?



Cheers,
Tink
 
Old 05-14-2009, 06:23 AM   #3
Ayyappan
LQ Newbie
 
Registered: May 2009
Posts: 4

Original Poster
Rep: Reputation: 0
Windows is on a seperate machine.
 
Old 05-14-2009, 01:36 PM   #4
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,020
Blog Entries: 11

Rep: Reputation: 907Reputation: 907Reputation: 907Reputation: 907Reputation: 907Reputation: 907Reputation: 907Reputation: 907
So how do you know it's Linux fault, and not your hardware?
 
Old 05-14-2009, 02:27 PM   #5
NeddySeagoon
Gentoo support team
 
Registered: May 2009
Location: 56N 3W
Distribution: Gentoo
Posts: 178

Rep: Reputation: 40
Ayyappan,

What other USB devices are connected at the same time as the USB drive ?

Your USB drive is recognised as a USB2 device, as linux is trying to use the ehci driver. Cheap, old, USB extension cables will not aways support USB2 data rates, so if you are using a USB extension, please try the drive connected directly to the PC.
 
Old 05-14-2009, 11:25 PM   #6
Ayyappan
LQ Newbie
 
Registered: May 2009
Posts: 4

Original Poster
Rep: Reputation: 0
Hi,

I am using USB mouse and it works fine. (hence i dont think of any problem in the USB drive)

and i am not using any usb extention cables i have directly connected my pendrive in usb port.

Kindly help

Regards,
Ayyappan
 
Old 05-15-2009, 01:34 AM   #7
sonypeter
LQ Newbie
 
Registered: May 2009
Posts: 13

Rep: Reputation: 0
fdisk -l shows your usb mounted as sda6 rt?.
usb should be automatically mounted. try formatting usb or see if its mounting on other distros. both on windows and ubuntu on some other pc.
definitely, its not fault of ubuntu. try a different usb too.

are you having any display problems?. your video driver properly installed?.
 
Old 05-15-2009, 03:10 AM   #8
Ayyappan
LQ Newbie
 
Registered: May 2009
Posts: 4

Original Poster
Rep: Reputation: 0
Hi,

sda6 is a windows partion in my system.

Even after removing the pendrive , fdisk -l shows the same message.

I formated the USB in windows (FAT32) even still it is not getting detected in linux.

There is no display problem in my system.

Kindly help for solving this issue.

Regards,
Ayyappan
 
Old 05-17-2009, 12:29 PM   #9
NeddySeagoon
Gentoo support team
 
Registered: May 2009
Location: 56N 3W
Distribution: Gentoo
Posts: 178

Rep: Reputation: 40
Ayyappan,

Does it ever appear in /proc/bus/usb/devices ?
It may be an over current trip causing the port to keep resetting and the device to be redeteced then tripped before it can ever be mounted.

Can you try using a PS/2 mouse to make sure the USB subsystem is not overloaded.
 
Old 02-22-2012, 09:43 AM   #10
Argo Gee
LQ Newbie
 
Registered: Feb 2012
Posts: 1

Rep: Reputation: Disabled
Unhappy

I have same issue as the fisrt post.
I cannot use my USB pen drive, size 1G, at ubuntu-11.04, but work at winXP.
My machine is acer TravelMate 4220, a notebook about 6 years.

[ 111.732181] usb 1-2: new high speed USB device using ehci_hcd and address 3
related lsusb message is
Bus 001 Device 003: ID 0000:0000
This is a 1G USB pen, cannot be seen in /dev/

[ 133.124189] usb 1-8: new high speed USB device using ehci_hcd and address 4
related lsusb message is
Bus 001 Device 004: ID 1f75:0902
This is a 16G USB pen, seen as /dev/sdc
(This works after I mount it manually.)

I use a USB harddisk sdb to boot. // sda is built-in ide harddisk.
=====================================================================================
following is the log of dmesg, lsusb, ls -al /dev/sd*
=====================================================================================
[ 33.520038] eth0: no IPv6 routers present
[ 111.732181] usb 1-2: new high speed USB device using ehci_hcd and address 3
[ 111.872311] scsi3 : usb-storage 1-2:1.0
[ 113.036171] usb 1-2: reset high speed USB device using ehci_hcd and address 3

[ 113.288176] usb 1-2: reset high speed USB device using ehci_hcd and address 3
[ 113.540177] usb 1-2: reset high speed USB device using ehci_hcd and address 3
[ 113.792095] usb 1-2: reset high speed USB device using ehci_hcd and address 3
[ 133.124189] usb 1-8: new high speed USB device using ehci_hcd and address 4
[ 133.262936] scsi4 : usb-storage 1-8:1.0
[ 134.261255] scsi 4:0:0:0: Direct-Access UDISK PDI01_16G C1J3.0 1.00 PQ: 0 ANSI: 5
[ 134.262717] sd 4:0:0:0: Attached scsi generic sg3 type 0
[ 134.265875] sd 4:0:0:0: [sdc] 31551488 512-byte logical blocks: (16.1 GB/15.0 GiB)
[ 134.266236] sd 4:0:0:0: [sdc] Write Protect is off
[ 134.266244] sd 4:0:0:0: [sdc] Mode Sense: 03 00 00 00
[ 134.266986] sd 4:0:0:0: [sdc] No Caching mode page present
[ 134.266994] sd 4:0:0:0: [sdc] Assuming drive cache: write through
[ 134.269754] sd 4:0:0:0: [sdc] No Caching mode page present
[ 134.269762] sd 4:0:0:0: [sdc] Assuming drive cache: write through
[ 134.272266] sdc: unknown partition table
[ 134.274495] sd 4:0:0:0: [sdc] No Caching mode page present
[ 134.274504] sd 4:0:0:0: [sdc] Assuming drive cache: write through
[ 134.274510] sd 4:0:0:0: [sdc] Attached SCSI removable disk
$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 11.04
Release: 11.04
Codename: natty
$ lsusb
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 004: ID 1f75:0902
Bus 001 Device 003: ID 0000:0000
Bus 001 Device 002: ID 0840:0084 Argosy Research, Inc.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
$
$ ls -al /dev/sd*
brw-rw---- 1 root disk 8, 0 2012-02-22 22:45 /dev/sda
brw-rw---- 1 root disk 8, 1 2012-02-22 22:45 /dev/sda1
brw-rw---- 1 root disk 8, 2 2012-02-22 22:45 /dev/sda2
brw-rw---- 1 root disk 8, 16 2012-02-22 22:45 /dev/sdb
brw-rw---- 1 root disk 8, 17 2012-02-22 22:45 /dev/sdb1
brw-rw---- 1 root disk 8, 18 2012-02-22 22:45 /dev/sdb2
brw-rw---- 1 root disk 8, 21 2012-02-22 22:45 /dev/sdb5
brw-rw---- 1 root disk 8, 32 2012-02-22 22:46 /dev/sdc
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Pen drive not detected ubuntu gauravdott Debian 10 05-11-2009 02:35 AM
Usb stick not detected in suse10 but fine in windows Morph69 Linux - Hardware 1 07-20-2006 09:41 AM
Vtec V-Drive USB 2.0 Flash Pen not working in Ubuntu 5.10 qwerty Linux - Hardware 0 02-16-2006 06:54 PM
automatic USB pen drive working fakie_flip Ubuntu 2 09-29-2005 08:29 AM
FreeBSD 5.1 & USB Pen Drive Crito *BSD 5 12-27-2003 12:08 AM


All times are GMT -5. The time now is 09:32 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration