LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-30-2011, 09:19 PM   #1
darthpinguim
Member
 
Registered: Feb 2011
Location: Belo Horizonte - MG - Brasil
Distribution: Ubuntu 12.04 / Debian 6
Posts: 32

Rep: Reputation: 0
USB mouse and keyboard interference in booting


Hi there!
I came across a curious problem these days. I bought a USB mouse and keyboard to replace my old serial port ones. The very first days I had them installed the system worked well. Then recently the problem appeared. After selecting the system to boot, in the GRUB list, the computer restarted as many times you wanted to boot. Then I tried to disable the serial ports on the BIOS and do some other minor changes, but it didn't help. Then I tried using the old keyboard and mouse again and the system booted normally.
Is there anything I can do?
Thanks in advance.
Best regards
darthpinguim
P.S.: Happy New Year!!!
 
Old 01-01-2012, 08:07 AM   #2
aus9
LQ Addict
 
Registered: Oct 2003
Location: Australia
Distribution: MX 16
Posts: 5,291

Rep: Reputation: Disabled
while your serial keyboard is booting up...go into bios and enable
usb legacy

save and reboot ....even if that does not solve your problem ....it will let you get into your bios using an usb k/b.

2) are you using grub legacy or grub2?

maybe you need to mod your grub2 to include

insmod usb
insmod usb_keyboard

leaping ahead....use root powers to edit your /boot/grub/grub.cfg but do not run update-grub
reboot to test

if it solves the issue report back and we need to mod an /etc/grub.d file
 
Old 01-01-2012, 01:56 PM   #3
darthpinguim
Member
 
Registered: Feb 2011
Location: Belo Horizonte - MG - Brasil
Distribution: Ubuntu 12.04 / Debian 6
Posts: 32

Original Poster
Rep: Reputation: 0
Hi aus9, thanks for the reply and happy new year!
USB legacy was already enabled in the BIOS.
Now concerning the modification on the grub file, where should I include those lines in the grub.cfg file?
 
Old 01-06-2012, 05:53 AM   #4
aus9
LQ Addict
 
Registered: Oct 2003
Location: Australia
Distribution: MX 16
Posts: 5,291

Rep: Reputation: Disabled
sorry been away

in the gap

#
# DO NOT EDIT THIS FILE
#
# It is automatically generated by /usr/sbin/grub-mkconfig using templates
# from /etc/grub.d and settings from /etc/default/grub
#

### BEGIN /etc/grub.d/00_header ###

remember do not run update-grub at this stage please ....you are testing to see if usb works at grub screen

report your results pls

2) I assume you have a live cd and so can easily re-edit if my advice is bad?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
booting without mouse and keyboard dereko Linux - General 2 03-07-2005 07:29 AM
FC3 - no mouse or keyboard on booting Steve Riley Fedora - Installation 0 02-01-2005 12:09 PM
logitech wireless mouse interference TMHero Linux - Hardware 0 10-22-2003 09:45 AM
USB mouse, keyboard, hid, console mouse problems jqcaducifer Linux - General 1 08-05-2003 09:43 AM
booting without mouse, keyboard, monitor jonfa Linux - General 1 05-27-2001 12:49 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 04:13 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration