-   Linux - Newbie (
-   -   USB flash drive folder not appearing (

chris24300 08-20-2009 09:04 AM

USB flash drive folder not appearing
Hi, I'm trying to backup files onto my USB flash drive but the folder that once appeared no longer does. The device is detected though, heres the output of lsusb


[root@Marv ~]# lsusb
Bus 001 Device 005: ID 187c:0511 
Bus 001 Device 001: ID 0000:0000 
Bus 001 Device 007: ID 187c:0511 
Bus 002 Device 010: ID 0781:5406 SanDisk Corp. Cruzer Micro 1/2/4GB Flash Drive
Bus 002 Device 004: ID 0403:6001 Future Technology Devices International, Ltd FT232 USB-Serial (UART) IC
Bus 002 Device 001: ID 0000:0000 
Bus 002 Device 003: ID 046d:c223 Logitech, Inc. G15 Keyboard / USB Hub
Bus 002 Device 006: ID 046d:c226 Logitech, Inc.
Bus 002 Device 002: ID 0d9f:0002 Powercom Co., Ltd
Bus 002 Device 005: ID 1532:0007 Razer USA, Ltd DeathAdder Mouse
Bus 002 Device 007: ID 046d:c227 Logitech, Inc.


MS3FGX 08-20-2009 09:25 AM

If you created the folder from a Linux machine, did you make sure to properly unmount the volume before removing the drive? You have to be very careful with removable media on Linux, as the OS doesn't immediately write to the physical device.

You can make a folder, and even see it on the drive in your file manager, but that doesn't necessarily mean anything has happened yet. It could be several seconds to a few minutes (depending on many factors) before the folder is actually written out to the drive itself.

chris24300 08-20-2009 09:44 AM

I've never created a folder, my mistake. What used to appear was the removable volume icon and then I was brought to the flash drive directory. I've been using the flash drive between a linux machines and I've never had to mount or unmount the drive. I plugged it in the first time and the removable volume appeared on desktop so I thought it was plug n play, never gave me any issues. Also, I just plugged it into a different machine and the removable volume appeared on that desktop... I have no idea what I did

schneidz 08-20-2009 10:15 AM

^are you able to mount it manually -e.g:

mkdir temp; sudo mount /dev/sdx1 temp
try running sudo tail -f /var/log/messages before plugging it in to see if it gives any error messages.

chris24300 08-20-2009 10:27 AM

I have sdc devices... Here's the messages


[root@Marvin Desktop]# tail -f /var/log/messages
Aug 20 10:57:07 Marv kernel: sdc: Write Protect is off
Aug 20 10:57:07 Marv kernel: sdc: assuming drive cache: write through
Aug 20 10:57:07 Marv kernel:  sdc: sdc1
Aug 20 10:57:07 Marv kernel: sd 598:0:0:0: Attached scsi removable disk sdc
Aug 20 10:57:07 Marv kernel: sd 598:0:0:0: Attached scsi generic sg3 type 0
Aug 20 10:57:07 Marv kernel:  Vendor: SanDisk  Model: U3 Cruzer Micro  Rev: 2.18
Aug 20 10:57:07 Marv kernel:  Type:  CD-ROM                            ANSI SCSI revision: 02
Aug 20 10:57:07 Marv kernel: sr1: scsi3-mmc drive: 8x/40x writer xa/form2 cdda tray
Aug 20 10:57:07 Marv kernel: sr 598:0:0:1: Attached scsi generic sg4 type 5
Aug 20 11:06:14 Marv kernel: usb 2-5.2: USB disconnect, address 11

Also, I'm using CentOS,

schneidz 08-20-2009 10:35 AM

does mounting manually propose a problem ?

i think udev is the guy that automounts stuff. maybe there is a rule that is broken ?

my fedora machine automounts stuff in /media/disk0 .

chris24300 08-20-2009 11:33 AM

I followed manual mounting instructions and the messages mount returned were like [whatever name] is busy or already mounted. I recall one message saying it was already mounted through /proc/bus/usb... I've tried so many different things. Maybe I'll try to update again and see if that'll fix anything.

vlsd 08-20-2009 03:26 PM

What does your /etc/fstab look like?

In my understanding udev attaches a device file to the actual USB device, so in my Debian system a usb drive gets attached to /dev/sdb. Your log file seems to indicate your drive was attached to /dev/sg3 or /dev/sg4 (most likely the first is the actual disk, the second the partition on it). Try umounting and remounting it by hand, to see if it works:

# umount /dev/sg4
# mount /dev/sg4 /mnt/usb

If you get that the device is busy when umounting, you can try using something like lsof to figure out which processes are using /dev/sg4, kill them, and try again. If this works, check to see you that have a line corresponding to your device in /etc/fstab and possibly take a look at how your distro handles auto-mounting.

I prefer to keep the "noauto" option in fstab for my usb drives and mount them every time by hand. That way I remember to also umount them when I'm done, before unplugging them (it is pretty data dangerous, especially for ntfs usb hard drives, to unplug them while they're still mounted).

Also, is the last line of your log file related to your device and did it happen because you actually disconnected it? I used to have a problem where my motherboard couldn't give enough power to spin a usb hard drive thorough the usb port, and the logs would show multiple connects and disconnects in a row.

All times are GMT -5. The time now is 09:47 PM.