LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   USB data got corrupt- How to retrieve? (https://www.linuxquestions.org/questions/linux-newbie-8/usb-data-got-corrupt-how-to-retrieve-922811/)

babi 01-09-2012 01:48 AM

USB data got corrupt- How to retrieve?
 
Hi, I searched in lot of forums but didn't get any problem related to mine..therefore I have joined this forum and posting it here. please help me..its kind of urgent.

All the files in my pendrive has got corrupt.The folders are still there but names and matter inside file is showing some junk file names (something like: "┼8┴τ Есќ.┘^("). I have kind of vague guess that it happend due to removing pendrive before kernel has finished with it. Also, Now I cannot copy or write anything in that pendrive, showing permission denied.

Please help me get back my data. This same problem happend with my phone memory card also, when I tried coping some stuff in it. The stuff got copied but with this junk file names (corrupted ones), instead of original.

Thanks in advance..

rodrifra 01-09-2012 02:23 AM

Try with testdisk or photorec.

babi 01-09-2012 04:41 AM

Thanks for the reply

Code:

        Try with testdisk or photorec.
I tried both but its showing error:


bash: testdisk: command not found

bash: photorec: command not found

what to do now?? :( :(

rodrifra 01-09-2012 08:54 AM

If your distro is Debian based:

Code:

sudo apt-get install testdisk
Otherwise look for the way to install testdisk in your distro.


All times are GMT -5. The time now is 06:37 AM.