LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-29-2015, 02:47 PM   #1
Pip Mac
LQ Newbie
 
Registered: Oct 2015
Location: UK
Distribution: Linux mint
Posts: 2

Rep: Reputation: Disabled
usb DAC not working after first shutdown


linux mint 64bit on sony VGN-N31Z laptop. not recognising Arcam irDAC (usb2 setting on DAC) after FIRST complete shutdown. Works fine until shutdown and again after complete re install. This site is sort of on that thread

https://help.ubuntu.com/community/Ub...sbAudioDevices

- so it seems there is corrupt USB settings on shutdown. Most odd as the previous rDAC worked perfectly

If this is any help

pip@pip-VGN-N31Z-W ~ $ cat /proc/asound/cards
0 [Intel ]: HDA-Intel - HDA Intel
HDA Intel at 0xdc240000 irq 44
1 [A20 ]: USB-Audio - ARCAM USB Audio 2.0
ARCAM ARCAM USB Audio 2.0 at usb-0000:00:1d.7-1, high spee


Help please!
 
Old 02-14-2016, 12:51 PM   #2
stevenhy
LQ Newbie
 
Registered: Feb 2016
Posts: 1

Rep: Reputation: Disabled
Smile HI

Today I have the same problem here, but i know how to fix it.
i know i am late but if you still waiting the answer , Email me: stevenhy2.0@gmail.com

Last edited by stevenhy; 02-14-2016 at 12:52 PM.
 
Old 02-22-2016, 06:51 AM   #3
Pip Mac
LQ Newbie
 
Registered: Oct 2015
Location: UK
Distribution: Linux mint
Posts: 2

Original Poster
Rep: Reputation: Disabled
Smile Arcam irDAC not recognised by Linux mint

problem solved by steven _ a huge thank you. this was his email....

As i know this a Ubuntu bugs, After reboot, Ubuntu will mute your usb dac without changing the GUI settings once.
so, you need to change it by yourself at the CLI

First,open your terminal than type : alsamixer
return"

Then you will see the sound setting of your default sound card,
After that, press the F6 key, select you usb dac device
after that , you will see that your sound device has muted (showing "mm")
Use your arrow key to move your selection ,then press "m" to un-mute them.

So you will see that the mm was replaced by "00"
OK, All done, press the esc key to exit, reboot.

YES!
 
Old 10-20-2017, 01:19 PM   #4
kevinthecat
LQ Newbie
 
Registered: Oct 2017
Posts: 1

Rep: Reputation: Disabled
I've been scratching parts of my anatomy for over a week after my irDac stopped working in a Linux Mint system for no apparent reason. Steven's solution works perfectly. I never even knew there was an alsamixer.... I used to think Windows 10 was bad but now... Good job it's cheap!

Thanks for posting the solution

Mike

Last edited by kevinthecat; 10-20-2017 at 01:20 PM.
 
Old 10-21-2017, 10:03 AM   #5
Mike_Walsh
Member
 
Registered: Jul 2017
Location: King's Lynn, UK
Distribution: Nowt but Puppies....
Posts: 542

Rep: Reputation: 287Reputation: 287Reputation: 287
Actually, this appears to be standard behaviour across the board in Linux.

I run mostly Puppy, and occasionally AntiX. I've got a 15-yr old Dell Inspiron lappie, where the headphone socket is completely worn-out. Since my soldering skills are, um, shall we say 'non-existent' , I decided to try the external sound card route, since I have available USB ports, and that would give me new headphone and microphone sockets.

The sound card works fine, but I, too, had to go into 'alsamixer' and unmute it first, followed by fine-tuning the remaining settings. Pup doesn't use PulseAudio, incidentally, so ALSA is standard fare anyway.....but you still need to select the correct card before the ball starts rolling!

So, it appears this business of 'automuting' would seem to be standard implementation in Linux, when using anything other than the built-in, originally-configured hardware.


Mike.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Usb dac alienDog Linux - Hardware 3 11-17-2011 11:20 AM
change MPD output to recognized USB DAC florenceit Linux - Software 1 07-25-2010 10:59 AM
USB mouse and USB DAC can't be used simultaneously Ben2210 Linux - Hardware 6 03-29-2010 08:53 AM
fubar USB II DAC location? tfrei Slackware 1 08-04-2008 03:00 PM
Can I use both a USB DAC and a USB soundcard ? spiug53 Linux - General 0 03-12-2006 01:41 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 03:56 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration