Help answer threads with 0 replies.
Go Back > Forums > Linux Forums > Linux - Newbie
User Name
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!


  Search this Thread
Old 01-02-2004, 05:36 PM   #1
Registered: Jan 2004
Posts: 83

Rep: Reputation: 15
URGENT!: vsftpd chroot config wont take changes. Major business depends on this. Help

When I read a couple of FAQ's it told me I need to enable chroot on vsftp. I did that in the config, here is my config with chroot enabled:

#Here is my config:
#Example config file /etc/vsftpd.conf
# The default compiled in settings are fairly paranoid. This sample file
# loosens things up a bit, to make the ftp daemon more usable.
# Please see vsftpd.conf.5 for all compiled in defaults.
# READ THIS: This example file is NOT an exhaustive list of vsftpd options.
# Please read the vsftpd.conf.5 manual page to get a full idea of vsftpd's
# capabilities.
# Allow anonymous FTP? (Beware - allowed by default if you comment this out).
# Uncomment this to allow local users to log in.
# Uncomment this to enable any form of FTP write command.
# Default umask for local users is 077. You may wish to change this to 022,
# if your users expect that (022 is used by most other ftpd's)
# Uncomment this to allow the anonymous FTP user to upload files. This only
# has an effect if the above global write enable is activated. Also, you will
# obviously need to create a directory writable by the FTP user.
# Uncomment this if you want the anonymous FTP user to be able to create
# new directories.
# Activate directory messages - messages given to remote users when they
# go into a certain directory.
# Activate logging of uploads/downloads.
# Make sure PORT transfer connections originate from port 20 (ftp-data).
# If you want, you can arrange for uploaded anonymous files to be owned by
# a different user. Note! Using "root" for uploaded files is not
# recommended!
# You may override where the log file goes if you like. The default is shown
# below.
# If you want, you can have your log file in standard ftpd xferlog format
# You may change the default value for timing out an idle session.
# You may change the default value for timing out a data connection.
# It is recommended that you define on your system a unique user which the
# ftp server can use as a totally isolated and unprivileged user.
# Enable this and the server will recognise asynchronous ABOR requests. Not
# recommended for security (the code is non-trivial). Not enabling it,
# however, may confuse older FTP clients.
# By default the server will pretend to allow ASCII mode but in fact ignore
# the request. Turn on the below options to have the server actually do ASCII
# mangling on files when in ASCII mode.
# Beware that turning on ascii_download_enable enables malicious remote parties
# to consume your I/O resources, by issuing the command "SIZE /big/file" in
# ASCII mode.
# These ASCII options are split into upload and download because you may wish
# to enable ASCII uploads (to prevent uploaded scripts etc. from breaking),
# without the DoS risk of SIZE and ASCII downloads. ASCII mangling should be
# on the client anyway..
# You may fully customise the login banner string:
#ftpd_banner=Welcome to blah FTP service.
# You may specify a file of disallowed anonymous e-mail addresses. Apparently
# useful for combatting certain DoS attacks.
# (default follows)
# You may specify an explicit list of local users to chroot() to their home
# directory. If chroot_local_user is YES, then this list becomes a list of
# users to NOT chroot().
# (default follows)
# You may activate the "-R" option to the builtin ls. This is disabled by
# default to avoid remote users being able to cause excessive I/O on large
# sites. However, some broken FTP clients such as "ncftp" and "mirror" assume
# the presence of the "-R" option, so there is a strong case for enabling it.
#enable for standalone mode

#Here is my chroot config:
#List of users to lock in their home directory.

When ever I run vsftpd, it cant start. It says vsftp dead, but subsys locked. I can fix that by deleting the lock file and changing back the confi to its default form, without the chroot modifications. Am I doing something wrong? Please help. RedHat 9.0

I've even tried changing the banner option and it still freezes. Its like it gets stuck when I try to cahnge the config.
Old 01-02-2004, 05:40 PM   #2
Registered: Jan 2004
Posts: 83

Original Poster
Rep: Reputation: 15
Ok, I just verified. Any changes made in teh config will cause it to crash when I issue a restart command on vsftpd. I tried disabling anonymous, adding a banner, and doing chroot. They all made it crash. Please help. No one has helped and I posted 3 times about this.
Old 01-02-2004, 06:13 PM   #3
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1982Reputation: 1982Reputation: 1982Reputation: 1982Reputation: 1982Reputation: 1982Reputation: 1982Reputation: 1982Reputation: 1982Reputation: 1982Reputation: 1982
please do not use words like "urgent" in your thread titles, if anything people will actively ignore it... and how can you possibly have posted 3 times about this when you've only ever made 3 posts, 2 of which are here....
Old 01-02-2004, 06:37 PM   #4
Registered: Jul 2003
Distribution: FreeBSD 8.2 RELEASE
Posts: 607

Rep: Reputation: 32
<totally unhelpful post>
If you have "major business" depending on this, you should probably be paying someone for quality tech support or admin, rather than relying on to do it for you. :P
</totally unhelpful post>
Old 01-02-2004, 08:06 PM   #5
Lost Penguin
Registered: Feb 2003
Location: Orlando, FL
Distribution: 2.6.1-1.131smp on Fedora Core 1
Posts: 31

Rep: Reputation: 15
I m a slacker

I always use webmin with the vsftp add-on.
the add-on

I am not good with long text files......
Webmin allows a web based administration of about everything in Linux.

One pointer:
set webmin to NOT load at startup, only start webmin when you need to change something.
su to root>
/usr/bin/service webmin start
Log into webmin via Mozilla (local box port 10000)
make the changes
/usr/bin/service webmin stop

This way you get the best of both:
ease of use with webmin, and the security of NOT running webmin constantly.
Old 01-02-2004, 08:27 PM   #6
Registered: Jan 2004
Posts: 83

Original Poster
Rep: Reputation: 15
THANKS! LostPenguin. Nice try Kovacs


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
vsftpd.conf/chroot/vsftpd.chroot_list issue Jerman Linux - Security 2 06-01-2007 08:24 PM
vsftpd and chroot bstempi Linux - Security 10 11-08-2005 03:56 PM
vsftpd and chroot gbj Linux - Networking 3 03-08-2005 03:47 AM
VSFTPD Config and CHROOT REDHAT 8 SteveT Linux - Newbie 10 10-17-2003 03:25 AM
Another vsftpd/chroot question mattsavigear Linux - Security 9 12-15-2002 04:39 PM > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 11:34 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration