LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-29-2004, 10:16 PM   #1
sharpie
Member
 
Registered: Jan 2004
Location: California
Distribution: Slackware 10.1
Posts: 190

Rep: Reputation: 30
Upon booting error message about bad superblock on ext2 device


It tells me to either run e2fsck, which didn't seem to help, or use a diff superblock address. I tried e2fsck -b 8193 (I think this is the example number they gave me) but didn't help.

What causes this error and what can be done to fix it?
 
Old 01-29-2004, 10:18 PM   #2
frob23
Senior Member
 
Registered: Jan 2004
Location: Roughly 29.467N / 81.206W
Distribution: OpenBSD, Ubuntu, FreeBSD
Posts: 1,449

Rep: Reputation: 48
What is supposed to be on the partition... and did you try e2fsck /dev/partition without any options?
 
Old 01-29-2004, 10:20 PM   #3
sharpie
Member
 
Registered: Jan 2004
Location: California
Distribution: Slackware 10.1
Posts: 190

Original Poster
Rep: Reputation: 30
This is the root partition. I tried e2fsck -p -v, so I wouldn't have to answer yes or no.
 
Old 01-30-2004, 01:44 AM   #4
sharpie
Member
 
Registered: Jan 2004
Location: California
Distribution: Slackware 10.1
Posts: 190

Original Poster
Rep: Reputation: 30
I tried e2fsck /dev/hda8 without options. Also tried e2fsck -b -31987 (the number was somewhere around this) which is I believe to restore a backup superblock for a filestystem whose blocks are 4096 (again not exact number). I'm not too sure what a superblock is, but upon reboot I get the same message.
 
Old 01-30-2004, 02:10 AM   #5
sharpie
Member
 
Registered: Jan 2004
Location: California
Distribution: Slackware 10.1
Posts: 190

Original Poster
Rep: Reputation: 30
I realize under /etc/fstab I have my root as /dev/hda10 instead of /dev/hda8. I tried editing by typing vi /etc/fstab, but It says no such session, or something like that.
 
Old 01-30-2004, 02:29 AM   #6
frob23
Senior Member
 
Registered: Jan 2004
Location: Roughly 29.467N / 81.206W
Distribution: OpenBSD, Ubuntu, FreeBSD
Posts: 1,449

Rep: Reputation: 48
I am not exactly sure what is going on. It is hard unless I can see the errors you are getting when you run fsck. I don't know if the fstab would affect it, but that is possible.
 
Old 01-30-2004, 02:34 AM   #7
sharpie
Member
 
Registered: Jan 2004
Location: California
Distribution: Slackware 10.1
Posts: 190

Original Poster
Rep: Reputation: 30
I am 99% sure fstab is the problem, because fsck is trying to run on a partition that isn't there. The only problem I have now is trying to edit it, do you know why it's saying "no such session" or something along those lines when I try and edit it in vi?
 
Old 01-30-2004, 02:39 AM   #8
frob23
Senior Member
 
Registered: Jan 2004
Location: Roughly 29.467N / 81.206W
Distribution: OpenBSD, Ubuntu, FreeBSD
Posts: 1,449

Rep: Reputation: 48
Have you defined $term? Vi has trouble opening without it... define it to something like cons25 (which is pretty generic). If that still doesn't work maybe `ed` will but that requires real good knowledge about that editor and unless you have used it it will just confuse you.

One of my favorite comments about the editor is that it, "Let's you know you made a mistake with the very explainatory '?' error. Based on the error you made you should know what to do to fix it." ;-) Not really user friendly. But that is what the command mode of vi is based on. Anyway, try defining term... or maybe it can't find /etc/fstab ???
 
Old 01-30-2004, 02:42 AM   #9
sharpie
Member
 
Registered: Jan 2004
Location: California
Distribution: Slackware 10.1
Posts: 190

Original Poster
Rep: Reputation: 30
I'll try those, have to reboot just thought I'd let you know that I could cat /etc/fstab, so it is there.
 
Old 01-30-2004, 03:06 AM   #10
sharpie
Member
 
Registered: Jan 2004
Location: California
Distribution: Slackware 10.1
Posts: 190

Original Poster
Rep: Reputation: 30
I tried defining $term, but wasn't too sure of the syntax so tried ed. I couldn't even use this, it was saying it was a read only file system. I scrolled up to where I get the error message and it said I'm on /dev/console, which would explain why I couldn't write or why certain applications weren't available. I ran Knoppix and edited my /etc/fstab from there. All is well, thanks for the help.
 
Old 01-30-2004, 03:11 AM   #11
frob23
Senior Member
 
Registered: Jan 2004
Location: Roughly 29.467N / 81.206W
Distribution: OpenBSD, Ubuntu, FreeBSD
Posts: 1,449

Rep: Reputation: 48
Good to know all went well... even if I didn't have anything to do with it. :-) At least I gave it a shot. Yeah, I forgot that it would have to be r/o if it wasn't clean...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
ERROR AT MOUNTING USB :mount: wrong fs type, bad option, bad superblock on /dev/sda1, saiket Linux - Hardware 3 04-12-2008 01:07 AM
ext2 Superblock Error elamigo2004 Linux - Software 6 11-26-2005 01:07 PM
getting grub error ; bad superblock linuxbh Linux From Scratch 3 04-09-2005 09:40 AM
trouble mounting drive, bad superblock error mattuc Linux - Hardware 3 05-27-2004 11:05 AM
mount: wrong fs type, bad option, bad superblock on /dev/sdb1 pmoreira Linux - Hardware 5 02-26-2004 11:31 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 06:16 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration