-   Linux - Newbie (
-   -   upgraded to xfree86 4.3 and lost my GUI!! (

kinghari 10-14-2003 04:14 AM

upgraded to xfree86 4.3 and lost my GUI!!
Im a newbie and I was playing around trying to install mplayer on my RedHat 8.SInce it said I needed xlib-dev..I downloaded the files necessary for xfree86 4.3 and ran the Xinstall shell script.AFter that it was all HELL!!

Now Im getting a gray background with a terminal window repeatedly saying 'console log for mylocalhostname'.So I do ctrl-alt-fn to get to the console and when I try X or startx it says display already in use..Fatal error.What should I do now? I have backed up my old X11 directories as instructed by the Xinstall shell script.PLEASE HELP...I have many important files stored on my machine and dont want anything big to hit me now!!


guygriffiths 10-14-2003 05:53 AM

Whats your GUI? If it's KDE, try clicking on the gray background and selecting exit. Then run 'startkde' from the console.
If that works, then type
echo "exec startkde" > ~/.xinitrc
echo "exec startkde" > /etc/X11/xinit/xinitrc (I think this is the location of the file. Have a look and try and find it first. It'll be something called xinitrc or .xinitrc in a similar location)

If you use gnome, follow the above instructions, but use "gnome-session" everywhere where "startkde" occurs.
Hope that helps

kilgoretrout 10-14-2003 08:51 AM

After doing Ctrl-Alt-Fn, log in and run:

$ startkde -- :1

You need to do the above to run a second X session. Alt-F7 returns you to the first X session(grey screen) and Alt-F8 takes you back to the second one. If kde comes up, do what guygriffiths says re editing your xinitrc file.

kinghari 10-14-2003 02:33 PM

Thanks for the info.Just got back to my department machine(problem prone now!!) Shall try all that was suggested and get back to you.Mine is Gnome.Thanks...shall get back with results


kinghari 10-14-2003 02:50 PM

okay I tried 'gnome-session -- :1' at the commandline and its says--->

Gtk -WARNING **: Cannot Open Display:

I tracked the xinitrc file and looked into it.But its all greek and latin to me!! So which is the file that initially specifies what to load at startup? Is there anyway I can edit such a file so that I dont get the terminal window with a gray background? And why am I not able to input anything in that terminal? It keeps saying 'console log for localhost' forever!!

Rewinding back to where it all started...when I read the instruction to install Xfree86 4.3, they mentioned that I should not be running an X session at installation time and the Xinstall shell script gave me a warning messages a couple of times when I tried running it from a terminal inside of my GUI.So I pressed ctrl-alt-fn and ran it again and it gave me no warning.I assumed that I had closed my X session and come to a commanline only mode.But looks like I did not actually??!! And also as Xfree86 4.3 was getting installed it prompted me a yes/no to change some links and I answered yes to all.So thats more detail of what actually happened if that helps.

Desperately looking forward to your expertise..........


init 10-25-2003 10:35 AM

Im in the same boat.. anyone ??
These ATI drivers are killing me.

I installed XFree4.3 in single-user mode (init 1) and I still have a terminal window repeatedly saying 'console log for mylocalhostname' but my GDM starts up and I can log in. However I can not start a gnome session no matter what session i pick it loads some other session..

All times are GMT -5. The time now is 08:48 PM.