LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-15-2005, 11:14 AM   #1
Paul7
Member
 
Registered: Aug 2005
Location: Thailand
Distribution: Suse 10.2 / Win XP Home
Posts: 172

Rep: Reputation: 30
upgrade suse 9.0 to 10.0 and grub


hello, who can Help me ?
I start the installation and I say upgrade.
The installaion disk work.
At the end, the system inform that the second diisk is rquierd bur it will create
the first boot environment. (with grub etc)
After reboot, the bootloader shows nothing and starts windows XP.
With the rescue system I look at ......../menu.lst and it look not so fine.
I tried to repair it, but there is nothing to see during the bootprocedure
I checked /etc/grub.conf there I find something like this
....
installl ---stage2=/boot/grub/stage2 .... etc

I try to reset grub
wih
grub < /mnt/etc/grub.conf

Bur his dos't help

Do you have any idea?
Paul
 
Old 08-15-2005, 03:44 PM   #2
AlanQ
Member
 
Registered: Jul 2004
Posts: 41

Rep: Reputation: 15
Hi Paul7

Strange that an 'upgrade' would do this.

Ed B. Park provides an excellent guide to dual-booting Windows/Linux
at http://www.geocities.com/epark/linux...w2k-HOWTO.html

Follow it carefully to see where the error might be.

Are you sure the XP bootloader is still pointing to grub stage 1 ?
Perhaps grub used to be in /boot and the upgrade put it in /
(or the other way round).

Hope this helps.
Alan
 
Old 08-16-2005, 04:42 AM   #3
Paul7
Member
 
Registered: Aug 2005
Location: Thailand
Distribution: Suse 10.2 / Win XP Home
Posts: 172

Original Poster
Rep: Reputation: 30
Hallo Alan,
I have 2 disks 1. winnt 2. suselinux
I interupt the realtek bootagent with many spaces.
there I find only profile1.
inside the boot.ini on XP level
I don't find anything about linux or grub or stage2
Paul
 
Old 08-17-2005, 09:04 AM   #4
Paul7
Member
 
Registered: Aug 2005
Location: Thailand
Distribution: Suse 10.2 / Win XP Home
Posts: 172

Original Poster
Rep: Reputation: 30
Hello,
can I do following?
start the rescue-system
then
mount -t reiserfs /dev/hdb2 /mnt
hdb2 is my linux
hdb1 is swap
chroot /mnt
grub-install /dev/hdb or maybe /dev/hda
what is right ?
Can this work?
Thank you
Paul
 
Old 08-19-2005, 12:33 PM   #5
Paul7
Member
 
Registered: Aug 2005
Location: Thailand
Distribution: Suse 10.2 / Win XP Home
Posts: 172

Original Poster
Rep: Reputation: 30
Hello, I think I find a solution !

boot the system from CD1
start the rescue mode

mount the linux-filesystem like I have

for sample
mount -t reiserfs /dev/hdb2 /mnt (check fstype and partition)

chroot /mnt

check /boot/grub/menu.lst (sure corrupted)

edit it to a useful form - because there are many duplicates inside
after that try
grub-install /dev/hda
if this works type
reboot

if not try
grub
root (hd1,1)
# message about fs if it is correct
setup (hd0)
# grub will check more informations
# after you see succeeded
quit # left grub
# Now you can reboot the system


Maybe you can use the installation disk too
after loading ..
you can make decision between install or update and some lines down you can see
others. if you select this:
install a new bootloader
but part I don't checked, because I run to my next problem. The mouse doesn't work any more and beautiful high-res too
Paul
 
Old 09-20-2005, 09:34 AM   #6
Paul7
Member
 
Registered: Aug 2005
Location: Thailand
Distribution: Suse 10.2 / Win XP Home
Posts: 172

Original Poster
Rep: Reputation: 30
I made an upgrade to 10.0 beta4 and the same trouble comes again. The ./grub.menu.lst was corrupted and I get
a grub-error. I do the same as write before.
Than the system is coming up.
Paul
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
GRUB Upgrade to 2.0? brokenflea Slackware 10 02-22-2005 06:43 AM
should I upgrade to GRUB e1000 Slackware 6 12-12-2003 03:11 AM
kernel upgrade/boot error with grub c_gebers Linux - Software 2 07-09-2003 05:42 AM
After upgrade grub shows 3 entry xred Linux - Newbie 5 03-13-2003 10:43 PM
Redhat 7.2 upgrade to 2.4.14 with GRUB Infinity Linux - Software 6 11-27-2001 09:54 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 09:54 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration