LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-04-2013, 06:13 AM   #1
the212degree
Member
 
Registered: Jun 2009
Posts: 43

Rep: Reputation: 0
Talking upgrade from 6.1 to 6.4 cent OS


i have cent OS 6.1 final. can i update to 6.4 ? If yes, then what is the command to be given in terminal
 
Old 11-04-2013, 07:05 AM   #2
colucix
LQ Guru
 
Registered: Sep 2003
Location: Bologna
Distribution: CentOS 6.5 OpenSuSE 12.3
Posts: 10,509

Rep: Reputation: 1978Reputation: 1978Reputation: 1978Reputation: 1978Reputation: 1978Reputation: 1978Reputation: 1978Reputation: 1978Reputation: 1978Reputation: 1978Reputation: 1978
Yes. As root just type
Code:
yum update
 
Old 11-06-2013, 02:53 AM   #3
the212degree
Member
 
Registered: Jun 2009
Posts: 43

Original Poster
Rep: Reputation: 0
as per the above advise, i have given the command yum update in the terminal.. the following result are there. i dont know what is updated and what not. will any1 explain and the solution for it



Processing Dependency: libqpidclient.so.5()(64bit) for package: matahari-net-0.4.0-5.el6.x86_64
--> Processing Dependency: libqpidcommon.so.5()(64bit) for package: matahari-net-0.4.0-5.el6.x86_64
---> Package redhat-lsb-compat.x86_64 0:4.0-7.el6.centos will be installed
---> Package redhat-lsb-core.x86_64 0:4.0-7.el6.centos will be installed
---> Package samba-winbind.x86_64 0:3.6.9-151.el6_4.1 will be installed
---> Package system-config-keyboard-base.x86_64 0:1.3.1-4.el6 will be installed
---> Package xorg-x11-drv-modesetting.x86_64 0:0.5.0-1.el6 will be installed
--> Running transaction check
---> Package libreport-compat.x86_64 0:2.0.9-15.el6.centos.1 will be installed
---> Package libwacom-data.noarch 0:0.5-4.el6 will be installed
---> Package matahari-agent-lib.x86_64 0:0.4.0-5.el6 will be obsoleted
--> Processing Dependency: libmqmfagent.so.0.0.1()(64bit) for package: matahari-net-0.4.0-5.el6.x86_64
--> Processing Dependency: matahari-agent-lib = 0.4.0-5.el6 for package: matahari-net-0.4.0-5.el6.x86_64
---> Package matahari-lib.x86_64 0:0.4.0-5.el6 will be obsoleted
--> Processing Dependency: libmcommon.so.0.0.1()(64bit) for package: matahari-net-0.4.0-5.el6.x86_64
--> Processing Dependency: libmnet.so.0.0.1()(64bit) for package: matahari-net-0.4.0-5.el6.x86_64
--> Processing Dependency: matahari-lib = 0.4.0-5.el6 for package: matahari-net-0.4.0-5.el6.x86_64
---> Package qpid-cpp-client.x86_64 0:0.10-3.el6 will be updated
--> Processing Dependency: libqpidclient.so.5()(64bit) for package: matahari-net-0.4.0-5.el6.x86_64
--> Processing Dependency: libqpidcommon.so.5()(64bit) for package: matahari-net-0.4.0-5.el6.x86_64
--> Finished Dependency Resolution
Error: Package: matahari-net-0.4.0-5.el6.x86_64 (@anaconda-CentOS-201111250358.x86_64/6.1)
Requires: matahari-agent-lib = 0.4.0-5.el6
Removing: matahari-agent-lib-0.4.0-5.el6.x86_64 (@anaconda-CentOS-201111250358.x86_64/6.1)
matahari-agent-lib = 0.4.0-5.el6
Obsoleted By: matahari-0.6.0-19.el6.x86_64 (base)
Not found
Error: Package: matahari-net-0.4.0-5.el6.x86_64 (@anaconda-CentOS-201111250358.x86_64/6.1)
Requires: libmcommon.so.0.0.1()(64bit)
Removing: matahari-lib-0.4.0-5.el6.x86_64 (@anaconda-CentOS-201111250358.x86_64/6.1)
libmcommon.so.0.0.1()(64bit)
Obsoleted By: matahari-0.6.0-19.el6.x86_64 (base)
Not found
Error: Package: matahari-net-0.4.0-5.el6.x86_64 (@anaconda-CentOS-201111250358.x86_64/6.1)
Requires: libmnet.so.0.0.1()(64bit)
Removing: matahari-lib-0.4.0-5.el6.x86_64 (@anaconda-CentOS-201111250358.x86_64/6.1)
libmnet.so.0.0.1()(64bit)
Obsoleted By: matahari-0.6.0-19.el6.x86_64 (base)
Not found
Error: Package: matahari-net-0.4.0-5.el6.x86_64 (@anaconda-CentOS-201111250358.x86_64/6.1)
Requires: libqpidclient.so.5()(64bit)
Removing: qpid-cpp-client-0.10-3.el6.x86_64 (@anaconda-CentOS-201111250358.x86_64/6.1)
libqpidclient.so.5()(64bit)
Updated By: qpid-cpp-client-0.14-22.el6_3.x86_64 (base)
Not found
Error: Package: matahari-net-0.4.0-5.el6.x86_64 (@anaconda-CentOS-201111250358.x86_64/6.1)
Requires: libqpidcommon.so.5()(64bit)
Removing: qpid-cpp-client-0.10-3.el6.x86_64 (@anaconda-CentOS-201111250358.x86_64/6.1)
libqpidcommon.so.5()(64bit)
Updated By: qpid-cpp-client-0.14-22.el6_3.x86_64 (base)
Not found
Error: Package: matahari-net-0.4.0-5.el6.x86_64 (@anaconda-CentOS-201111250358.x86_64/6.1)
Requires: matahari-lib = 0.4.0-5.el6
Removing: matahari-lib-0.4.0-5.el6.x86_64 (@anaconda-CentOS-201111250358.x86_64/6.1)
matahari-lib = 0.4.0-5.el6
Obsoleted By: matahari-0.6.0-19.el6.x86_64 (base)
Not found
Error: Package: matahari-net-0.4.0-5.el6.x86_64 (@anaconda-CentOS-201111250358.x86_64/6.1)
Requires: libmqmfagent.so.0.0.1()(64bit)
Removing: matahari-agent-lib-0.4.0-5.el6.x86_64 (@anaconda-CentOS-201111250358.x86_64/6.1)
libmqmfagent.so.0.0.1()(64bit)
Obsoleted By: matahari-0.6.0-19.el6.x86_64 (base)
Not found
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest
[root@ProjectTeam Desktop]# ^C
[root@ProjectTeam Desktop]# rpm -Va --nofiles --nodigest
[root@ProjectTeam Desktop]# --skip-broken
bash: --skip-broken: command not found
[root@ProjectTeam Desktop]# -skip-broken
bash: -skip-broken: command not found
[root@ProjectTeam Desktop]# --skip -broken
bash: --skip: command not found
 
Old 11-06-2013, 03:17 AM   #4
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,229

Rep: Reputation: 2522Reputation: 2522Reputation: 2522Reputation: 2522Reputation: 2522Reputation: 2522Reputation: 2522Reputation: 2522Reputation: 2522Reputation: 2522Reputation: 2522
not all third party repos are compatible
and you are using the install dvd AS a repo
" anaconda-CentOS-201111250358.x86_64/6.1 "
( from using kickstart)

if you are trying to use the old 6.1 install dvd as a source you will not be able to upgrade to 6.4

remove that repo file

it should be in
etc/yum.repos.d/

can you post the output of this:
Code:
yum repolist all

also if your base and update repos are coded to use 6.1( and not the 6 or 6.x )then you will need to specify the version to upgrade
Code:
su -
yum --releasever=6.4 upgrade 
reboot
or run
Code:
su -
yum update
yum clean all 
yum --releasever=6.4 update centos-release 
yum update 
yum clean all
reboot

the "--skip-broken" program is in the yum-utils rpm
it is not installed by default
Code:
su -
yum install yum-utils

Last edited by John VV; 11-06-2013 at 03:21 AM.
 
1 members found this post helpful.
Old 11-07-2013, 06:39 AM   #5
the212degree
Member
 
Registered: Jun 2009
Posts: 43

Original Poster
Rep: Reputation: 0
the following files are found in etc/yum.repos.d/

centOS-base.repo
centOS-debuginfo.repo
centOS-media.repo
epel.repo
epel-testing.repo
remi.repo

Question No.1 which repo file i should delete.

later i proceed with the command list in the above reply and the result is here

[root@ProjectTeam Desktop]# yum repolist all
Loaded plugins: fastestmirror, refresh-packagekit
Determining fastest mirrors
epel/metalink | 6.0 kB 00:00
* base: ftp.iitm.ac.in
* epel: mirrors.vinahost.vn
* extras: ftp.iitm.ac.in
* updates: ftp.iitm.ac.in
base | 3.7 kB 00:00
base/primary_db | 4.4 MB 00:14
epel | 4.2 kB 00:00
epel/primary_db | 5.6 MB 00:26
extras | 3.4 kB 00:00
extras/primary_db | 18 kB 00:00
updates | 3.4 kB 00:00
updates/primary_db | 5.1 MB 00:21
repo id repo name status
C6.0-base CentOS-6.0 - Base disabled
C6.0-centosplus CentOS-6.0 - CentOSPlus disabled
C6.0-contrib CentOS-6.0 - Contrib disabled
C6.0-extras CentOS-6.0 - Extras disabled
C6.0-updates CentOS-6.0 - Updates disabled
C6.1-base CentOS-6.1 - Base disabled
C6.1-centosplus CentOS-6.1 - CentOSPlus disabled
C6.1-contrib CentOS-6.1 - Contrib disabled
C6.1-extras CentOS-6.1 - Extras disabled
C6.1-updates CentOS-6.1 - Updates disabled
C6.2-base CentOS-6.2 - Base disabled
C6.2-centosplus CentOS-6.2 - CentOSPlus disabled
C6.2-contrib CentOS-6.2 - Contrib disabled
C6.2-extras CentOS-6.2 - Extras disabled
C6.2-updates CentOS-6.2 - Updates disabled
C6.3-base CentOS-6.3 - Base disabled
C6.3-centosplus CentOS-6.3 - CentOSPlus disabled
C6.3-contrib CentOS-6.3 - Contrib disabled
C6.3-extras CentOS-6.3 - Extras disabled
C6.3-updates CentOS-6.3 - Updates disabled
base CentOS-6 - Base enabled: 6,381
c6-media CentOS-6 - Media disabled
centosplus CentOS-6 - Plus disabled
contrib CentOS-6 - Contrib disabled
debug CentOS-6 - Debuginfo disabled
epel Extra Packages for Enterprise Linux 6 - x8 enabled: 9,908
epel-debuginfo Extra Packages for Enterprise Linux 6 - x8 disabled
epel-source Extra Packages for Enterprise Linux 6 - x8 disabled
epel-testing Extra Packages for Enterprise Linux 6 - Te disabled
epel-testing-debuginfo Extra Packages for Enterprise Linux 6 - Te disabled
epel-testing-source Extra Packages for Enterprise Linux 6 - Te disabled
extras CentOS-6 - Extras enabled: 13
remi Les RPM de remi pour Enterprise Linux 6 - disabled
remi-debuginfo Les RPM de remi pour Enterprise Linux 6 - disabled
remi-php55 Les RPM de remi de PHP 5.5 pour Enterprise disabled
remi-php55-debuginfo Les RPM de remi de PHP 5.5 pour Enterprise disabled
remi-test Les RPM de remi en test pour Enterprise Li disabled
remi-test-debuginfo Les RPM de remi en test pour Enterprise Li disabled
updates CentOS-6 - Updates enabled: 1,521
repolist: 17,823
[root@ProjectTeam Desktop]#
[root@ProjectTeam Desktop]# yum install yum-utils
Loaded plugins: fastestmirror, refresh-packagekit
Determining fastest mirrors
epel/metalink | 6.0 kB 00:00
* base: mirror.leapswitch.com
* epel: ftp.riken.jp
* extras: mirror.leapswitch.com
* updates: mirror.leapswitch.com
base | 3.7 kB 00:00
base/primary_db | 4.4 MB 00:11
epel | 4.2 kB 00:00
epel/primary_db | 5.6 MB 00:19
extras | 3.4 kB 00:00
extras/primary_db | 18 kB 00:00
updates | 3.4 kB 00:00
updates/primary_db | 5.1 MB 00:12
Setting up Install Process
Package yum-utils-1.1.30-14.el6.noarch already installed and latest version
Nothing to do
[root@ProjectTeam Desktop]#


Question no.2 is my OS updated to 6.4?
 
Old 11-07-2013, 02:38 PM   #6
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,229

Rep: Reputation: 2522Reputation: 2522Reputation: 2522Reputation: 2522Reputation: 2522Reputation: 2522Reputation: 2522Reputation: 2522Reputation: 2522Reputation: 2522Reputation: 2522
Quote:
Question no.2 is my OS updated to 6.4?
from the above
no you never upgraded it

to see the version you are running run this
Code:
cat /etc/redhat-release

did you ever install anything from the REMI repo
( i think there was a updated firefox there ? maybe ?)
and you have a php repo from remi that is disabled
-- did you replace the cent default php with a different version ?

if not well ALL of those repos are disabled
you might want to uninstall that software repo

Code:
su -
rpm -qa | grep remi
then in that list should be the remi repo.
Code:
yum uninstall NameOfTheProgram
 
Old 11-11-2013, 08:36 AM   #7
the212degree
Member
 
Registered: Jun 2009
Posts: 43

Original Poster
Rep: Reputation: 0
you have said that my cent OS 6.1 not upgraded to 6.4 but when i put the command as indicated, it says iam in 6.4 final.
IS it correct?

and before updating to 6.4, i upgraded my firefox to 24.0
should i remove this repo?

i hope i have settled with 6.4 final. am I?

[ProjectTeam@ProjectTeam Desktop]$ cat /etc/redhat-release
CentOS release 6.4 (Final)
[ProjectTeam@ProjectTeam Desktop]$ su
Password:
[root@ProjectTeam Desktop]# rpm -qa | grep remi
remi-release-6.4-1.el6.remi.noarch
firefox-24.0-1.el6.remi.x86_64
xulrunner-last-24.0-1.el6.remi.x86_64
[root@ProjectTeam Desktop]#
 
Old 11-12-2013, 02:59 AM   #8
chrism01
LQ Guru
 
Registered: Aug 2004
Location: Sydney
Distribution: Centos 6.9, Centos 7.3
Posts: 17,417

Rep: Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397
Following on from JohnVV's remarks, this
Code:
remi Les RPM de remi pour Enterprise Linux 6 - disabled
remi-debuginfo Les RPM de remi pour Enterprise Linux 6 - disabled
remi-php55 Les RPM de remi de PHP 5.5 pour Enterprise disabled
remi-php55-debuginfo Les RPM de remi de PHP 5.5 pour Enterprise disabled
remi-test Les RPM de remi en test pour Enterprise Li disabled
remi-test-debuginfo Les RPM de remi en test pour Enterprise Li disabled
says all your remi repos are disabled, BUT this
Code:
[root@ProjectTeam Desktop]# rpm -qa | grep remi
remi-release-6.4-1.el6.remi.noarch
firefox-24.0-1.el6.remi.x86_64
xulrunner-last-24.0-1.el6.remi.x86_64
says that you DID enable them at some point (unless you downloaded that stuff and installed it all manually).

In any case, if you want to use ANY repos other than Centos (this warning applies to EPEL also), then install/setup yum priorities
http://wiki.centos.org/PackageManagement/Yum/Priorities
 
Old 11-15-2013, 02:58 AM   #9
the212degree
Member
 
Registered: Jun 2009
Posts: 43

Original Poster
Rep: Reputation: 0
i have windows xp in one system and cent OS in another PC. both are connected through 16 port switch. samsung ML 2240 printer is installed in xp. i want to take print in cent OS pc through network printer. help me for the installation of network printer.

so far no one has replied. anything difficult

Last edited by the212degree; 11-18-2013 at 07:30 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
how to upgrade cent os 5.4 32 bit to cent os 5.8 64 bit h.dilshad Linux - Newbie 15 03-20-2013 04:27 PM
[SOLVED] Upgrade from Cent OS 6.0 to 6.1 crashes on IBM x3850 ThomasRonshof Red Hat 3 12-22-2011 08:02 AM
Cent OS help aggrishabh Linux - Newbie 1 03-29-2011 05:24 AM
Cent 4.7 does not see all CPU after CPU upgrade agallant Linux - Hardware 10 06-10-2009 06:58 PM
How to upgrade from fedora 9 to Cent os 5.2 sachin_shetty Linux - Server 1 02-27-2009 02:39 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 08:39 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration