LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   unusual Sound on enlightenment (https://www.linuxquestions.org/questions/linux-newbie-8/unusual-sound-on-enlightenment-185899/)

mifan 05-25-2004 10:25 PM

unusual Sound on enlightenment
 
Hi,

I have a sound prob with enlightenment, seems when i try to use kopete, the sound effects in that program end up being horribly garbled noise.

some other programs that use sound like totem seem ok...

I don't know how to find the problem or how to fix it... anyone able to help?

motub 05-26-2004 04:36 AM

Kopete is a KDE program (fairly obvious, as almost all KDE programs start with a "K" to indicate their relationship to KDE). Totem, on the other hand, is either a "free" or a GNOME program (not sure which).

Anyway, the point is that most KDE programs need the KDE sound server (aRTs) to play sounds, because KDE is heavily integrated with itself. GNOME or "free" programs can use the GNOME sound server (esd, for Enlightened Sound Daemon, aka eSound) if available, but generally don't need any sound server running to work properly. So the most likely problem is that Kopete can't find artsd (the aRTs Daemon, analagous to a Service under Windows 2000 and XP), because KDE is not running (artsd is normally started at KDE startup).

You can start aRTs manually by typing artsd & in a terminal (you may have to su to root first; don't remember). If Enlightenment has session management, you may be able to set artsd to start with E using that, but as I don't use Enlightenment, I have no idea how you'd do so. You might also check the KDE Control Panel, when logged into KDE, and see if in the Sound and Multimedia section the "enable sound server on startup" is checked, but I'm not clear on whether that refers to KDE startup, or system startup, so if the former, not a helpful solution :( . The last alternative is to set artsd to run as one of the services of your default runlevel (runlevel 5, graphical login, I would assume), which iirc can be done through a tool somewhere in the Mandrake Control Center, but you'll have to trawl for that, as I didn't use that tool much even when I was using Mandrake, so I really don't remember where it is. I'm quite sure, though, that Mandrake also installs linuxconf by default, and I know that there's a runlevel tool in that utility. However, linuxconf will only run if you are logged in as root. You could try running it from a terminal that has gained root access using the su - command (not just su; that will not work; I tried that myself ;) , but that was before I knew about su -, so I never tried that instead). The difference between su and su - is that su gives a user root access; su - behaves as if you have logged in as root, so you might be able to run linuxconf that way without logging out and back in.

Hope this helps.


All times are GMT -5. The time now is 04:19 AM.