LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-27-2004, 05:56 AM   #1
tyddynonn
LQ Newbie
 
Registered: Feb 2004
Distribution: Mandrake 9.2
Posts: 3

Rep: Reputation: 0
Unresolved Symbols with Intel Ham & Mandrake 9.2


I'm setting up Mandrake 9.2 on my Winmodem-equipped box (yes, I know...!). Kernel is 2.4.2-10mdk

The modem reports Manfactured 0x1813, Device 0x4000, and I downloaded the Intel-v92Ham-453.tgz driver package.

Two problems:

The 'Make Install' step gives

'Cannot remove /dev/ham: Operation not permited'

and

depmod -e shows

depmod: *** Unresolved symbols in /lib/modules/2.4.22-10mdk/kernel/drivers/char/ham.o
depmod: schedule_timeout
depmod: __wake_up
depmod: tty_unregister_driver
depmod: __generic_copy_from_user
depmod: tty_std_termios
depmod: __release_region
depmod: tq_immediate
depmod: tty_register_driver
depmod: pci_enable_device
depmod: vfree
depmod: pcibios_present
depmod: free_irq
depmod: free_pages
depmod: __ioremap
depmod: bh_task_vec
depmod: request_irq
depmod: tty_flip_buffer_push
depmod: pci_find_device
depmod: __tasklet_hi_schedule
depmod: jiffies
depmod: printk
depmod: ioport_resource
depmod: get_zeroed_page
depmod: *** Unresolved symbols in /lib/modules/2.4.22-10mdk/kernel/drivers/char/hamcore.o
depmod: enable_irq
depmod: schedule_timeout
depmod: __wake_up
depmod: schedule
depmod: __udelay
depmod: create_proc_entry
depmod: interruptible_sleep_on_timeout
depmod: del_timer
depmod: interruptible_sleep_on
depmod: disable_irq
depmod: remove_proc_entry
depmod: schedule_task
depmod: proc_root
depmod: jiffies
depmod: printk
depmod: add_timer
depmod: __const_udelay


Things I have already checked/done

- I am doing eveything as root
- I installed the Kernel Source package RPM
- I used scanModem and did all the ModemDriverCompiling.txt stuff, including tweaking the the EXTRAVERSION info in version.h, copying /boot/config, make mrproper, make dep, etc etc.

The hamcore.o & ham.o moduels load (with a tainted kernel warning), and /dev/modem links to /dev/ham.

I'm out of ideas - any suggestions anyone? This Winmodem is **supposed** to be supported under 2.4 kernels....
 
Old 02-29-2004, 10:17 PM   #2
Tiyogi
Member
 
Registered: Nov 2003
Location: Hyde Park, Ny
Distribution: Ubunta
Posts: 117

Rep: Reputation: 15
tyddynonn, is seem like we have the same problem.
The difference is it seem like you know what you are doing where as I am just start off to use linux. By the way I am :
-------------- System information ------------------------
redhat Red Hat Linux release 8.0 (Psyche)
on System with processor: i686
supported by kernel: 2.4.18-14
assembled with compiler: 3.2



I also get the warning abour the
Unresolved symbols in /lib/modules/2.4.22-10mdk/kernel/drivers/char/ham.o

I tryed running the command you used

depmod -e shows

But I did not get the same kind of output. Where did you run the command from I am in root user now.

Is your copy of the drivers the one from the intel site, which is :
http://downloadfinder.intel.com/scri...r_results.asp?
strOSs=39&strTypes=DRV&ProductID=1057&OSFullName=&submit=Go%21

There are two other version of this driver package. I have tryed them all with no success.

http://linmodems.technion.ac.il/packages/Intel/ham/

Also you have to know which chip version you might have. Version A B or C.
Sorry I could not help you . But I will be watching to see if you can get yours going.
 
Old 03-04-2004, 03:21 AM   #3
tyddynonn
LQ Newbie
 
Registered: Feb 2004
Distribution: Mandrake 9.2
Posts: 3

Original Poster
Rep: Reputation: 0
Hi Ed,

Gave up in the end and bought a new Lucent-chipset modem. This works fine.
Seems that Linux still really hasn't got the hang of plug and play....
 
Old 03-04-2004, 04:43 PM   #4
Salamandra
LQ Newbie
 
Registered: Mar 2004
Location: Lima-PERU
Distribution: Mandrake 9.2
Posts: 11

Rep: Reputation: 0
If you speak spanish

If you speak Spanish, here is a link for installing an Intel HAM modem in Mandrake 9.2

http://www.geocities.com/alfredomandrake

Hope it helps you.

Last edited by Salamandra; 03-04-2004 at 04:47 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
unresolved symbols? CletusJones Debian 3 08-16-2005 02:45 PM
unresolved symbols g.ramkumar Programming 0 11-04-2004 10:46 AM
unresolved symbols lord_clarence Red Hat 1 10-23-2003 10:54 PM
***Unresolved Symbols*** red8user Linux - Networking 2 09-12-2003 07:34 AM
unresolved symbols acid_kewpie Linux - General 7 04-19-2002 06:30 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 09:55 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration