LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-10-2017, 05:11 AM   #16
descendant_command
Senior Member
 
Registered: Mar 2012
Posts: 1,716

Rep: Reputation: 554Reputation: 554Reputation: 554Reputation: 554Reputation: 554Reputation: 554

Code:
apt-cache policy kodi kodi-bin kodi-data
will show you which versions are available in which repo (and the 'priority' of each).
 
Old 04-10-2017, 05:31 AM   #17
roanantelope
LQ Newbie
 
Registered: May 2016
Posts: 13

Original Poster
Rep: Reputation: Disabled
Thank you for your persistence it is really appreciated.

bryan@dave-X200:~$ apt-cache policy kodi kodi-bin kodi-data
kodi:
Installed: (none)
Candidate: 2:16.1~git20160425.1001-final-0xenial
Version table:
2:17.1~git20170320.2031-final-0xenial 0
100 /var/lib/dpkg/status
2:16.1~git20160425.1001-final-0xenial 500
500 http://ppa.launchpad.net/team-xbmc/kodi-old/ubuntu xenial/main i386 Packages
15.2+dfsg1-3ubuntu1 500
500 http://ubuntu.mirror.neology.co.za/ubuntu xenial/universe i386 Packages
kodi-bin:
Installed: (none)
Candidate: 2:16.1~git20160425.1001-final-0xenial
Version table:
2:16.1~git20160425.1001-final-0xenial 500
500 http://ppa.launchpad.net/team-xbmc/kodi-old/ubuntu xenial/main i386 Packages
15.2+dfsg1-3ubuntu1 500
500 http://ubuntu.mirror.neology.co.za/ubuntu xenial/universe i386 Packages
kodi-data:
Installed: (none)
Candidate: 15.2+dfsg1-3ubuntu1
Version table:
15.2+dfsg1-3ubuntu1 500
500 http://ubuntu.mirror.neology.co.za/ubuntu xenial/universe i386 Pack

This is the result. What is my next move please?
 
Old 04-10-2017, 05:58 AM   #18
descendant_command
Senior Member
 
Registered: Mar 2012
Posts: 1,716

Rep: Reputation: 554Reputation: 554Reputation: 554Reputation: 554Reputation: 554Reputation: 554
Not sure sorry
Not familiar with buntu repo's, and ppa's make me itch - do you know who built the packages in that repo?

I think there is further info missing.

Quote:
The following packages have unmet dependencies.
kodi : Depends: kodi-bin (>= 2:16.1~git20160425.1001-final-0xenial) but it is not going to be installed
Depends: kodi-bin (< 2:16.1~git20160425.1001-final-0xenial.1~) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
this appears to say the kodi package requires conflicting versions of the same kodi-bin package.


Quote:
Version table:
2:17.1~git20170320.2031-final-0xenial 0
100 /var/lib/dpkg/status
where does this version come from?
It doesn't appear in the active repo's - have you previously installed it (or attempted to) from somewhere else?

What does this say?
Code:
apt-cache show kodi
 
Old 04-10-2017, 07:10 AM   #19
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen DK
Distribution: PCLinuxOS2020 CentOS6.10 CentOS7.7 + 50+ other Linux OS, for test only.
Posts: 17,328

Rep: Reputation: 3583Reputation: 3583Reputation: 3583Reputation: 3583Reputation: 3583Reputation: 3583Reputation: 3583Reputation: 3583Reputation: 3583Reputation: 3583Reputation: 3583
Please use one of the official URLīs in /etc/apt/sources.list

Examples
http://mirror.pacific.net.au/linux/ubuntu/
http://es.archive.ubuntu.com/ubuntu/
http://se.archive.ubuntu.com/ubuntu/

And delete the "ppa", if it's a separate file ( in /etc/apt/sources.list.d/ ).


-

Last edited by knudfl; 04-10-2017 at 07:18 AM.
 
Old 04-10-2017, 07:44 AM   #20
roanantelope
LQ Newbie
 
Registered: May 2016
Posts: 13

Original Poster
Rep: Reputation: Disabled
Hi gentlemen,

Apt-cache show kodi
bryan@dave-X200:~$ apt-cache show kodi
Package: kodi
Status: deinstall ok config-files
Priority: optional
Section: video
Installed-Size: 36212
Maintainer: wsnipex <wsnipex@xbmc.org>
Architecture: all
Version: 2:17.1~git20170320.2031-final-0xenial
Config-Version: 2:17.1~git20170320.2031-final-0xenial
Replaces: xbmc (<< 2:14.0~git20141019), xbmc-data, xbmc-standalone
Provides: kodi-data, kodi-skin-estuary, kodi-standalone, xbmc, xbmc-data, xbmc-standalone
Depends: kodi-bin (>= 2:17.1~git20170320.2031-final-0xenial), kodi-bin (<< 2:17.1~git20170320.2031-final-0xenial.1~), curl, libcurl3, mesa-utils, x11-utils, fonts-liberation | ttf-liberation, fonts-dejavu-core | ttf-dejavu-core, python-bluez | python-lightblue, python-imaging, python-simplejson, libmad0, libass5 | libass4, libgif5 | libgif7, libssh-4 | libssh2-1, libnfs8 | libnfs4 | libnfs1, libbluray1, libshairplay0, libvorbisfile3, libaacs0, libcec4, librtmp1 | librtmp0, libgnutls30 | libgnutls-deb0-28 | libgnutls28 | libgnutls26, libxslt1.1, libyajl2
Recommends: libvdpau1, libva-intel-vaapi-driver, libva1
Suggests: kodi-pvr-mythtv, kodi-pvr-vuplus, kodi-pvr-vdr-vnsi, kodi-pvr-njoy, kodi-pvr-nextpvr, kodi-pvr-mediaportal-tvserver, kodi-pvr-tvheadend-hts, kodi-pvr-dvbviewer, kodi-pvr-argustv, kodi-pvr-iptvsimple, kodi-audioencoder-vorbis, kodi-audioencoder-flac, kodi-audioencoder-lame
Breaks: xbmc (<< 2:14.0~git20141019), xbmc-data, xbmc-standalone
Description-en: Kodi Media Center (arch-independent data package)
Kodi, formerly known as XBMC Media Center, is an award winning free and
open source software media-player and entertainment hub for all your digital
media. Kodi is available for Linux, Mac OS X (Leopard, Tiger and Apple TV)
and Microsoft Windows, as well as the original Xbox game console. Created in
2003 by a group of like minded programmers, Kodi is a non-profit project run
and developed by volunteers located around the world. More than 50 software
developers have contributed to Kodi, and 100-plus translators have worked to
expand its reach, making it available in more than 30 languages.
.
While Kodi functions very well as a standard media player application for
your computer, it has been designed to be the perfect companion for your
HTPC. Supporting an almost endless range of remote controls, and combined
with its beautiful interface and powerful skinning engine, Kodi feels very
natural to use from the couch and is the ideal solution for your home
theater. Once installed, your computer will become a fully functional
multimedia jukebox.
.
This package contains all the architecture independent data needed to have a
working Kodi.
Description-md5: 0e7e4c0691603796de3f6b71e9bd4d9d
Homepage: http://kodi.tv/

Package: kodi
Priority: optional
Section: video
Installed-Size: 26407
Maintainer: wsnipex <wsnipex@xbmc.org>
Architecture: all
Version: 2:16.1~git20160425.1001-final-0xenial
Recommends: libvdpau1, libva-intel-vaapi-driver | i965-va-driver, libva1
Replaces: xbmc (<< 2:14.0~git20141019), xbmc-data, xbmc-skin-confluence, xbmc-standalone
Suggests: kodi-pvr-mythtv, kodi-pvr-vuplus, kodi-pvr-vdr-vnsi, kodi-pvr-njoy, kodi-pvr-nextpvr, kodi-pvr-mediaportal-tvserver, kodi-pvr-tvheadend-hts, kodi-pvr-dvbviewer, kodi-pvr-argustv, kodi-pvr-iptvsimple, kodi-audioencoder-vorbis, kodi-audioencoder-flac, kodi-audioencoder-lame
Provides: kodi-data, kodi-skin-confluence, kodi-standalone, xbmc, xbmc-data, xbmc-skin-confluence, xbmc-standalone
Depends: kodi-bin (>= 2:16.1~git20160425.1001-final-0xenial), kodi-bin (<< 2:16.1~git20160425.1001-final-0xenial.1~), curl, libcurl3, mesa-utils, x11-utils, fonts-liberation | ttf-liberation, fonts-dejavu-core | ttf-dejavu-core, python-bluez | python-lightblue, python-imaging, python-simplejson, libmad0, libass5 | libass4, libgif7 | libgif5, libssh-4 | libssh2-1, libnfs8 | libnfs4 | libnfs1, libbluray1, libshairplay0, libvorbisfile3, libaacs0, libcec3, librtmp1 | librtmp0, libgnutls30 | libgnutls-deb0-28 | libgnutls28 | libgnutls26, libxslt1.1, libyajl2
Breaks: xbmc (<< 2:14.0~git20141019), xbmc-data, xbmc-skin-confluence, xbmc-standalone
Filename: pool/main/k/kodi/kodi_16.1~git20160425.1001-final-0xenial_all.deb
Size: 13687250
MD5sum: cdb9a006aeb22ce201d99c159f7af2da
SHA1: 650c847faaadd3043d934968d818e18dc63fed60
SHA256: 5ca9288520859f0fe10f180de5cb7711820383a97e3fd02894984026369b0e84
Description-en: Kodi Media Center (arch-independent data package)
Kodi, formerly known as XBMC Media Center, is an award winning free and
open source software media-player and entertainment hub for all your digital
media. Kodi is available for Linux, Mac OS X (Leopard, Tiger and Apple TV)
and Microsoft Windows, as well as the original Xbox game console. Created in
2003 by a group of like minded programmers, Kodi is a non-profit project run
and developed by volunteers located around the world. More than 50 software
developers have contributed to Kodi, and 100-plus translators have worked to
expand its reach, making it available in more than 30 languages.
.
While Kodi functions very well as a standard media player application for
your computer, it has been designed to be the perfect companion for your
HTPC. Supporting an almost endless range of remote controls, and combined
with its beautiful interface and powerful skinning engine, Kodi feels very
natural to use from the couch and is the ideal solution for your home
theater. Once installed, your computer will become a fully functional
multimedia jukebox.
.
This package contains all the architecture independent data needed to have a
working Kodi.
Description-md5: 0e7e4c0691603796de3f6b71e9bd4d9d

Package: kodi
Priority: optional
Section: universe/video
Installed-Size: 71
Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Original-Maintainer: Debian Multimedia Maintainers <pkg-multimedia-maintainers@lists.alioth.debian.org>
Architecture: i386
Version: 15.2+dfsg1-3ubuntu1
Replaces: xbmc (<< 2:13.2+dfsg1-5~)
Depends: kodi-bin (>= 15.2+dfsg1-3ubuntu1), kodi-bin (<< 15.2+dfsg1-3ubuntu1.1~), kodi-data
Breaks: xbmc (<< 2:13.2+dfsg1-5~)
Filename: pool/universe/k/kodi/kodi_15.2+dfsg1-3ubuntu1_i386.deb
Size: 13978
MD5sum: 91e5e7f6aa38e88740df1f2ccb17343f
SHA1: f0e3ac2f85e22708ff00e72cacefb57eb377f255
SHA256: d9e907c323b0aa5fd82998b031344044d4fa4be7912b21864680493d18d74ffb
Description-en: Open Source Home Theatre (executable binaries)
Kodi, formerly known as XBMC is an award winning free and
open source software media-player and entertainment hub for all your digital
media. Kodi is available for Linux, Mac OS X (Leopard, Tiger and Apple TV)
and Microsoft Windows, as well as the original Xbox game console. Created in
2003 by a group of like minded programmers, Kodi is a non-profit project run
and developed by volunteers located around the world. More than 50 software
developers have contributed to Kodi, and 100-plus translators have worked to
expand its reach, making it available in more than 30 languages.
.
While Kodi functions very well as a standard media player application for
your computer, it has been designed to be the perfect companion for your
HTPC. Supporting an almost endless range of remote controls, and combined
with its beautiful interface and powerful skinning engine, Kodi feels very
natural to use from the couch and is the ideal solution for your home
theater. Once installed, your computer will become a fully functional
multimedia jukebox.
.
This package contains the kodi binaries.
Description-md5: 8cbb7a58aa8f70442021b6474bb4487a
Homepage: http://kodi.tv/
Bugs: https://bugs.launchpad.net/ubuntu/+filebug
Origin: Ubuntu

Not sure how to execute last message.

Last edited by roanantelope; 04-10-2017 at 07:59 AM. Reason: To give more information
 
Old 04-10-2017, 08:15 AM   #21
roanantelope
LQ Newbie
 
Registered: May 2016
Posts: 13

Original Poster
Rep: Reputation: Disabled
just to refresh everyone's mind this problem started when while updating from kodi 16. to kodi 17 krypton. This when something went wrong. I ended up with kodi 18 alpha.
I then used "sudo apt-get remove kodi"
I then used "sudo apt-get remove --auto-remove kodi"
"sudo apt-get update" "sudo apt install kodi"
The ver 18 krypton is a "nightly" I have since learned. I am not aware of any commands I gave to install this version.
Is this the possible problem and if it is how do I purge it?
 
Old 04-10-2017, 11:42 AM   #22
ondoho
LQ Addict
 
Registered: Dec 2013
Posts: 13,422
Blog Entries: 9

Rep: Reputation: 3669Reputation: 3669Reputation: 3669Reputation: 3669Reputation: 3669Reputation: 3669Reputation: 3669Reputation: 3669Reputation: 3669Reputation: 3669Reputation: 3669
^ and we are back to what i asked in post #7:
Quote:
Originally Posted by ondoho View Post
let me re-iterate:
1) you installed kodi with apt (software center or command line, doesn't matter)
2) you were unhappy with the version provided by ubuntu and force-fumbled your way to a higher version
3) things started falling apart

i think you can see from my choice of words that point 2) was probably wrong.
to assess the situation we need a lot more information about this point 2).
(relevant parts highlighted)

edit:
ok, i just noticed you wrote
Quote:
I am not aware of any commands I gave to install this version.
- very unfortunate.

let me rephrase:
i think you need to
- completely uninstall kodi and all related packages
- move all .list files in /etc/apt and subdirectories away to a safe location (i'd say "delete", but let's better not do that just yet)
- revert your sources to ubuntu's default sources, this can help: https://repogen.simplylinux.ch/
- update your system, resolve conflicts (that's the trickiest bit, don't rush it!)

Last edited by ondoho; 04-10-2017 at 11:48 AM.
 
1 members found this post helpful.
Old 04-11-2017, 02:15 AM   #23
roanantelope
LQ Newbie
 
Registered: May 2016
Posts: 13

Original Poster
Rep: Reputation: Disabled
Hi Ondoho,
You are obviously a very knowledgeable person on Linux, And I agree with what you are saying. Unfortunately when it comes to Ubuntu and kodi I have just learnt very slowly but I seem to know more than I did a week ago.
I am taking a day off work tomorrow so that I can concentrate uninterrupted.
To completely uninstall kodi i will need a little more prompting on the process please.
I am not sure where in/etc/apt and subdirectories are to be found. Could you elaborate on this please?
updating my system and resolve conflicts I will do my best.

Maybe after all of this I may be able to help other people in some small way?
Many Thanks.
 
Old 04-11-2017, 02:37 AM   #24
ondoho
LQ Addict
 
Registered: Dec 2013
Posts: 13,422
Blog Entries: 9

Rep: Reputation: 3669Reputation: 3669Reputation: 3669Reputation: 3669Reputation: 3669Reputation: 3669Reputation: 3669Reputation: 3669Reputation: 3669Reputation: 3669Reputation: 3669
please, FIRST provide info (as per my last post), THEN we will figure it out.

you can't have suffered total amnesia?
 
Old 04-11-2017, 07:49 AM   #25
rtmistler
Moderator
 
Registered: Mar 2011
Location: USA
Distribution: MINT Debian, Angstrom, SUSE, Ubuntu, Debian
Posts: 8,451
Blog Entries: 13

Rep: Reputation: 3763Reputation: 3763Reputation: 3763Reputation: 3763Reputation: 3763Reputation: 3763Reputation: 3763Reputation: 3763Reputation: 3763Reputation: 3763Reputation: 3763
Quote:
Originally Posted by roanantelope View Post
The command Mukumw4nj1 was my password. I should have started the installation at that stage.
From the command prompt, please type "passwd" and CHANGE YOUR PASSWORD. Use nothing similar to this. And recommend you do not post any password you have in the future. Editing your post showing it at this point will do nothing since this information has already been out there on the web.

There are a few problems here, but all starting with broken packages. Ardvark71's links from post #3 are worth a look, and to add to that, I've had a similar problem with packages and Ubuntu and searched a lot for a solution. Eventually I found a guide showing all of the extended, force, fix, auto-fix forms of command for aptitude, which I can't find now.

That ultimately worked to fix my packages.

I was never successful at installing the software package that got me started with all that. I tried 2-3 times, once I learned how to forcibly auto-fix my packages. It never worked.

That whole process took days and my take-away from it was that I was better off not having wasted that time. Also I became concerned with the amount of effort and special actions I had to put into it, what good it would do me if sometime in the future I needed to fix it again due to some upgrade in my system.

Therefore I also agree with ondoho's earlier points that there is a version of Kodi in Ubuntu and likely it is best to leave that version in place, given the experience you're having. What you do to get it back at this point seems to be a full re-install of Ubuntu 16.04. Maybe there is a painful option, which you're living through now, but my experiences are that these experiences in adversity do not make you a stronger, better person, and in my case would make me wonder endlessly whether or not something else is now messed up on my system with all the changes done and undone.
 
Old 04-11-2017, 08:40 AM   #26
Shadow_7
Senior Member
 
Registered: Feb 2003
Distribution: debian
Posts: 4,004
Blog Entries: 1

Rep: Reputation: 847Reputation: 847Reputation: 847Reputation: 847Reputation: 847Reputation: 847Reputation: 847
Do you have the {flavour}-updates entry for your /etc/apt/sources.list ?

Code:
deb http://archive.ubuntu.com/ubuntu trusty main restricted universe
deb http://archive.ubuntu.com/ubuntu trusty-updates main restricted universe
deb http://archive.ubuntu.com/ubuntu trusty-security main restricted universe
Change trusty (14.04) to xenial (16.04) or whatever applies.

$ sudo apt-get update
$ sudo apt-get -f install

Without the -updates entry I couldn't install a particular game which only has a 14.04 package. Lamely, the only way to get the .deb file to install in another distro. If you do a minimal install your sources.list likely only contains the first line without restricted or universe.
 
1 members found this post helpful.
Old 04-12-2017, 10:44 AM   #27
roanantelope
LQ Newbie
 
Registered: May 2016
Posts: 13

Original Poster
Rep: Reputation: Disabled
Good day Shadow 7 and all the other kind members who tried to help me solve my problem.
A kind member from Kodi provided me with this solution,

sudo add-apt-repository -y -r ppa:team-xbmc/kodi-old
sudo apt remove -y kodi*
sudo add-apt-repository -y ppa:team-xbmc/ppa
sudo apt update
sudo apt full-upgrade
sudo apt install kodi

This solved my problem. Hope it will help others who encounter this problem.

Thanks to everyone.
Kind regards,
roanantelope
 
1 members found this post helpful.
Old 04-12-2017, 11:07 PM   #28
ardvark71
LQ Veteran
 
Registered: Feb 2015
Location: Oregon, USA
Distribution: Lubuntu 14.04, Windows Vista
Posts: 6,277
Blog Entries: 3

Rep: Reputation: 841Reputation: 841Reputation: 841Reputation: 841Reputation: 841Reputation: 841Reputation: 841
Quote:
Originally Posted by roanantelope View Post
This solved my problem. Hope it will help others who encounter this problem.
Hi...

I'm glad you got it fixed. If you would, please mark this thread as "SOLVED" by clicking on "Thread Tools" directly above your initial post. Thanks!

Regards...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] unmet dependencies lazza1329 Ubuntu 4 03-14-2015 01:31 PM
unmet dependencies OneDreamCloser Linux - Software 8 05-09-2012 03:32 PM
unmet dependencies mbvo Linux - Software 10 02-16-2012 11:18 PM
Unmet dependencies. maikie Debian 7 09-04-2007 06:30 PM
unmet dependencies Josephus Ross Linux - General 10 08-21-2007 01:49 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 07:01 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration