Download your favorite Linux distribution at LQ ISO.
Go Back > Forums > Linux Forums > Linux - Newbie
User Name
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!


  Search this Thread
Old 02-17-2009, 10:13 AM   #1
Registered: Dec 2008
Posts: 44

Rep: Reputation: 15


I'm running RHEL 5 and trying to setup a Connection between my Business Objects Server and a remote MySQL 5.1 database.

After downloading the unixODBC-2.2.14.tar.gz,

I created a dirtectory in which to install it

mkdir /tmp/unixODBC

and then run this line

#./configure -- prefix=/tmp/unixODBC --enable-gui=No

it runs somewhat then stop at (see append). any way around this? If I remove the "--enable-gui" option it'll run OK.

Can anyone tell me what will be the effect of omitting this option? I've been trying to get this unixODBC to work for ages and am reluctant to in any way deviate from the prescribed instructions.

Thanks for your assistance.

[root@mulligan unixODBC-2.2.14]# ./configure --prefix=/tmp/unixODBC --enable-gui=No
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for gawk... gawk
... . .
checking whether make sets $(MAKE)... (cached) yes
configure: error: bad value No for --enable-gui
Old 02-17-2009, 11:25 AM   #2
Registered: Aug 2006
Location: Michigan
Distribution: Ubuntu
Posts: 240

Rep: Reputation: 30
It looks like that is an argument that is not supported. If you take the argument out you will have a gui. (presumably)
Old 02-17-2009, 11:46 AM   #3
LQ 5k Club
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016 CentOS6.9 CentOS7.3 + 50+ other Linux OS, for test only.
Posts: 16,706

Rep: Reputation: 3294Reputation: 3294Reputation: 3294Reputation: 3294Reputation: 3294Reputation: 3294Reputation: 3294Reputation: 3294Reputation: 3294Reputation: 3294Reputation: 3294
The useable option :

'./configure --without-gui'

To compile with GUI, qt-devel or qt4-devel is required.

With both qt3 and qt4 present, qt4 will be used.

The word 'No' is never used in configure. 'no' : sometimes.

Last edited by knudfl; 02-17-2009 at 11:55 AM.
Old 02-18-2009, 03:35 AM   #4
Registered: Dec 2008
Posts: 44

Original Poster
Rep: Reputation: 15

Yeah the SAP BO documentation is

./configure --prefix=/tmp/unixODBC --enable-gui=No
make install

which gave me the error.

Thanks knudfl - it was the simplest of things to fix

./configure --prefix=/tmp/unixODBC --enable-gui=no

actually worked.

In the previous install I went with the other option which was to enable the GUI and then I had to install Trolltech Qt libraries.

I'll send the typo to Bus Obj's os they can update their documentation.

Thanks for the pointers.

Cheers, Ed



Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
myODBC and unixODBC LandRoverMan Programming 2 04-21-2009 06:14 AM
unixODBC configure nedzer Linux - Enterprise 4 12-12-2008 06:17 AM
unixODBC lord-fu *BSD 1 12-20-2006 08:54 PM
unixODBC - Error amorzaria Debian 0 07-12-2005 04:01 PM
unixODBC ottavio78 Linux - Software 1 12-15-2003 07:26 AM > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 04:09 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration