-   Linux - Newbie (
-   -   Unbelievable X-frustrations (

NOT_Skeletor 04-12-2003 11:18 AM

Unbelievable X-frustrations
I am now about one step away from putting my fist through my monitor trying to get things to work.
Running RH 8, I wanted GL support for my AGP All-In-Wonder. I tried the DRI project, but kept getting module ABI mismatches. I could not get rid of enough stuff that DRI had put on to get X-working again, so I installed XFree 4.3
I then got GL support working (a minor victory), but could only get twm working as a windows manager. I tried GNOME, and that went with twm. So, I got AfterStep, and got that working, but not togeether. Gnome used to run MetaCity, but it no longer loads a windows manager. I edited the gnome-wm file to point to afterstep, and modified my .xinitrc to reflect this as well.
Then I would run afterstep alone to see how that went, and it kept loading Gnome and opening about a zillion panles (with the messages "error: I have detcted a panel already open" and continuing on its merry way opening another thousand of them. I tried editing the .xinitrc to use only afterstep, but it too will continually load Gnome and the million panels. I've even tried killall commands, and the panel windows continue to regenerate. I have looked everywhere for the config file for Gnome to get it to stop loading all these panles. I can also not get Gnome to load afterstep as its window manager. Even from an X-term, the gnome-control-center says it cannot find the default preferences file, and does nothing.
Where is the Gnome config file to edit the window manager, and how do I get it to stop loading control panels?
I would also be happy to never use Gnome again and simply use afterstep, as it seems fairly robust for what I want. But, how do I stop loading Gnome when afterstep loads?
Any help would be appreciated.

DavidPhillips 04-12-2003 04:05 PM

try removing all of the files that start with .gnome from your home folder.

this will reset your wm settings for gnome

rm -rf ~/.gnom*

all previous settings, files contained there and such will be lost

rnturn 04-12-2003 10:05 PM


Originally posted by DavidPhillips
try removing all of the files that start with .gnome from your home folder.

this will reset your wm settings for gnome

Surely there is a better way! I've had to resort to doing what you've suggested on a coworker's Gnome config when she gets all these panels popping up. Actually, I've had to do it twice. I sure wish it'd screw up when I'm watching as I've never been able to tell whether it was Gnome scribbling on its own config files or whether it's a ``user-clicking-things-at-random'' problem.

DavidPhillips 04-12-2003 10:26 PM

The problem should be solved that way. However if you find another way to fix it please post the solution.

rnturn 04-13-2003 12:04 AM


Originally posted by DavidPhillips
The problem should be solved that way. However if you find another way to fix it please post the solution.
Well, what I've tried isn't so much a ``solution'' but a shortcut to recovering the last ``good'' window manager configuration: tar up Gnome-related subdirectories after you've have a good working setup. The theory is that when things get good and fouled up, all you have to do is delete the Gnome subdirectories, and untar the last good set. The trouble is that I'm not sure that's capturing all of the desktop settings. Partly because it's not clear just where all of the settings might be stored. Making, say, a panel change and then logging out -- and saving setup -- doesn't seem to alter any files under the Gnome subdirectories that you'd think might contain those changes. There are changed files under ~/.gconf but I'm not sure how they're tied to .gnome*. For now

tar cf .Gnome_Settings.tar .gnome*/* .gconf/*

is what I'm banking on as a snapshot of the last known-to-be-working desktop. It's untested at this point. I'll post results the next time my coworker calls to tell me she's got panels all over her desktop. :-)

NOT_Skeletor 04-13-2003 04:38 PM

Thanks for the suggestions. I tried nuking all the little .gnom* thingers in my home directory, and that did indeed work. Whew.
I would still like to use a different window manager, however.
I'll try mucking with the gnome-wm file and see if I can get that to point to it. ITs too bad gnome-control-center has somehow decided to lose the default preference files, as that would be by far the easiest way of fixing the problem.
I have also tar'd up my known working config. Thanks again, and if you have any suggestions on how to use a different manager (I like afterstep) in Gnome, those suggestions too would be muchly appreciated.

DavidPhillips 04-13-2003 05:09 PM

It is very simple to set the window manager

the xinitrc file is where you would set it up

most people use a link to the one of choice and just change the link to use a different one

david@zeus:/etc/X11/xinit$ ls -l
total 40
-rw-r--r-- 1 root root 321 Mar 16 15:36 README.Xmodmap
lrwxrwxrwx 1 root root 13 Mar 29 13:57 xinitrc -> xinitrc.gnome
-rwxr-xr-x 1 root root 556 Mar 16 16:59 xinitrc.blackbox
-rwxr-xr-x 1 root root 555 Mar 16 17:46 xinitrc.fluxbox
-rwxr-xr-x 1 root root 559 Feb 14 01:03 xinitrc.fvwm2
-rwxr-xr-x 1 root root 539 Feb 21 2002 xinitrc.fvwm95
-rwxr-xr-x 1 root root 630 Feb 5 00:44 xinitrc.gnome
-rwxr-xr-x 1 root root 536 Mar 15 21:54 xinitrc.kde
-r--r--r-- 1 root root 664 Mar 2 01:48 xinitrc.twm
-rwxr-xr-x 1 root root 788 Feb 11 18:41 xinitrc.wmaker
-rwxr-xr-x 1 root root 1487 Feb 14 00:22 xinitrc.xfce

note my link to xinitrc.gnome
the line at the bottum starts the window manager

david@zeus:/etc/X11/xinit$ cat xinitrc
# $XConsortium: xinitrc.cpp,v 1.4 91/08/22 11:41:34 rws Exp $


# merge in defaults and keymaps

if [ -f $sysresources ]; then
xrdb -merge $sysresources

if [ -f $sysmodmap ]; then
xmodmap $sysmodmap

if [ -f $userresources ]; then
xrdb -merge $userresources

if [ -f $usermodmap ]; then
xmodmap $usermodmap

# This nag screen isn't going to save anybody.

# Start the window manager:
exec gnome-session

DavidPhillips 04-13-2003 05:13 PM

you can overide the system default by having the .xinitrc file in the users home folder

All times are GMT -5. The time now is 01:30 PM.