LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-13-2016, 04:11 AM   #1
fanoflq
Member
 
Registered: Nov 2015
Posts: 397

Rep: Reputation: Disabled
Unable to update python version


I tried this:

$ sudo apt-get install python2.7.11
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package python2.7.11
E: Couldn't find any package by regex 'python2.7.11'

But there is a python2.7.11 online. Why this error?

Then I do this:
$ sudo apt-get install python2.7.9

and the install seems to work.
Meaning no errors.

But when I checked, I have this python:

$ python
Python 2.7.6 (default, Jun 22 2015, 17:58:13)
[GCC 4.8.2] on linux2
Type "help", "copyright", "credits" or "license" for more information.

Why am I not able to upgrade to python2.7.9 ?

I also tried to uninstall python2.7.6, but stopped when it shows me a long list of dependencies it will have to remove!

Is it a good idea to uninstall python?

Thanks.

Last edited by fanoflq; 03-13-2016 at 04:14 AM.
 
Old 03-13-2016, 04:22 AM   #2
pan64
LQ Guru
 
Registered: Mar 2012
Location: Hungary
Distribution: debian/ubuntu/suse ...
Posts: 9,797

Rep: Reputation: 2888Reputation: 2888Reputation: 2888Reputation: 2888Reputation: 2888Reputation: 2888Reputation: 2888Reputation: 2888Reputation: 2888Reputation: 2888Reputation: 2888
apt-get install python=version
see man page
 
Old 03-13-2016, 04:27 AM   #3
fanoflq
Member
 
Registered: Nov 2015
Posts: 397

Original Poster
Rep: Reputation: Disabled
$ sudo apt-get install python=2.7.11
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Version '2.7.11' for 'python' was not found
$ sudo apt-get install python=2.7.9
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Version '2.7.9' for 'python' was not found
 
Old 03-13-2016, 06:50 AM   #4
pan64
LQ Guru
 
Registered: Mar 2012
Location: Hungary
Distribution: debian/ubuntu/suse ...
Posts: 9,797

Rep: Reputation: 2888Reputation: 2888Reputation: 2888Reputation: 2888Reputation: 2888Reputation: 2888Reputation: 2888Reputation: 2888Reputation: 2888Reputation: 2888Reputation: 2888
http://superuser.com/questions/39368...install-on-apt
probably you need an apt-get update
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Unable to access CentOS setup Network Configuration after attempting Python update crmpicco Linux - Networking 1 06-28-2014 03:25 AM
python update - Unable to load GTK2 Python bindings: No module named gtk itpedersen Linux - Software 2 10-03-2008 04:44 AM
python: can you update the current shell from python? BrianK Programming 4 01-31-2008 01:18 AM
python unable to update in FC4 invincible_king Linux - General 1 10-10-2006 07:46 PM
python problem - compiled from source - python -V still showing old version txm123 Linux - Newbie 1 02-15-2006 12:05 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 11:34 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration