LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-17-2008, 01:24 PM   #1
Jaxukfr
LQ Newbie
 
Registered: Dec 2008
Posts: 4

Rep: Reputation: 0
Question Unable to Update fc9


Following an update to fc9 a few days ago; I have not been able to update since. I keep getting the following messages;-

A security policy in place prevents this sender from sending this message to this recipient, see message bus configuration file (rejected message had interface "org.freedesktop.PackageKit.Transaction" member "GetUpdates" error name "(unset)" destination "org.freedesktop.PackageKit")

I also get similar message trying to do a 'Refresh Package list' in 'Add/Remove Software'.

Could anyone tell me how to resolve the error; or what to reload to rectify?
Many thanks
 
Old 12-17-2008, 04:43 PM   #2
unSpawn
Moderator
 
Registered: May 2001
Posts: 29,359
Blog Entries: 55

Rep: Reputation: 3546Reputation: 3546Reputation: 3546Reputation: 3546Reputation: 3546Reputation: 3546Reputation: 3546Reputation: 3546Reputation: 3546Reputation: 3546Reputation: 3546
I don't know how to fix that, but maybe in the meanwhile you could open up a terminal window and type 'yum check-update'?
 
Old 12-17-2008, 09:05 PM   #3
ncsuapex
Member
 
Registered: Dec 2004
Location: Raleigh, NC
Distribution: CentOS 2.6.18-53.1.4.el5
Posts: 770

Rep: Reputation: 43
Could it be a selinux issue?

whats the output of:
/usr/sbin/sestatus
 
Old 12-18-2008, 03:20 AM   #4
Jaxukfr
LQ Newbie
 
Registered: Dec 2008
Posts: 4

Original Poster
Rep: Reputation: 0
Many thanks for your replies - I have managed to do a full update in terminal using 'yum update'; but now I get the following message when trying to update;-
failed to get a TID: Method "SetLocale" with signature "s" on interface "org.freedesktop.PackageKit.Transaction" doesn't exist
(0)
And also Add/Remove Software does not work (appears to not be fully loaded - some menus missing).
/usr/sbin/sestatus does not work - as no application installed for this type of file.

Looks as though I might have to reload whole system (unless anyone can think of alternative.
 
Old 12-18-2008, 04:58 AM   #5
Jaxukfr
LQ Newbie
 
Registered: Dec 2008
Posts: 4

Original Poster
Rep: Reputation: 0
Hi again - Following the 'yum update'; I rebooted the pc and was then able to update and refresh the packages in Add/Remove Software. The only error I had was on boot-up when NFS failed. As NFS appears to be for servers, I removed in Add/Remove Software, rebooted again and the whole system appears to be fully operating OK. Thanks again all for your help
 
Old 12-18-2008, 12:07 PM   #6
unSpawn
Moderator
 
Registered: May 2001
Posts: 29,359
Blog Entries: 55

Rep: Reputation: 3546Reputation: 3546Reputation: 3546Reputation: 3546Reputation: 3546Reputation: 3546Reputation: 3546Reputation: 3546Reputation: 3546Reputation: 3546Reputation: 3546
Hmm. I'd rather have seen some diagnostics instead of rebooting to "fix" things but since it works for you, OK, cool...
 
Old 12-19-2008, 01:38 AM   #7
Jaxukfr
LQ Newbie
 
Registered: Dec 2008
Posts: 4

Original Poster
Rep: Reputation: 0
Hi. Well if there had been diagnostics; the chances are I would not have understood them well enough to have been able to know exactly what to do. So, maybe I was lucky on this ocassion as all seems to be working OK still. My knowledge of fc9 is a bit limited as I am relatively new to the operating system. Thanks again, regards
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
yum not working after update in FC9 boomboom47 Linux - Software 7 11-04-2008 04:22 AM
libcrypto.so.6 error after FC9 update priceey Linux - Software 1 09-23-2008 04:16 PM
FC9 nvidia yum update conflict JohnLocke Linux - Newbie 6 08-13-2008 04:33 PM
KDE won't load in FC9 after yum update diggs Fedora 1 07-13-2008 09:40 PM
Update from 2.6.25.4-30 to 2.6.25.6-55.fc9.x86_64 causes kernel panic on x61 thorsten becker Fedora 5 06-19-2008 04:52 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 05:00 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration