-   Linux - Newbie (
-   -   unable to setup Remote DISPLAY using ssh (

mmateen 08-07-2009 05:09 PM

unable to setup Remote DISPLAY using ssh
I am working on a MAC OS and logging into an X11 machine. I am able to log in and access the machine however I cannot access remote DISPLAY. I need to open up an image using ds9 and am unable to do so.

I have tried: ssh -X

but then when I type ds9 at the prompt I get the following error msg.

connect port 6000: Connection refused
X connection to localhost:11.0 broken (explicit kill or server shutdown).

Could someone please tell me how to setup remote display?


bgoodr 08-08-2009 09:47 AM


Originally Posted by mmateen (Post 3635195)
I am working on a MAC OS and logging into an X11 machine.

For reference, here is the fragment of the ssh man page from Debian Linux (and might or might not match the command-line syntax of your MAC OS ssh client):

-X Enables X11 forwarding. This can also be specified on a per-host basis in a configuration file.

X11 forwarding should be enabled with caution. Users with the ability to bypass file permissions on the remote host (for
the userís X authorization database) can access the local X11 display through the forwarded connection. An attacker may
then be able to perform activities such as keystroke monitoring.

For this reason, X11 forwarding is subjected to X11 SECURITY extension restrictions by default. Please refer to the ssh -Y
option and the ForwardX11Trusted directive in ssh_config(5) for more information.

-Y Enables trusted X11 forwarding. Trusted X11 forwardings are not subjected to the X11 SECURITY extension controls.
And later on:

ssh(1) obtains configuration data from the following sources in the following order:

1. command-line options
2. userís configuration file (~/.ssh/config)
3. system-wide configuration file (/etc/ssh/ssh_config)
Try the following:
  1. Try adding the -Y switch when you invoke ssh on the local machine (see above).
  2. Your ssh client may or may not use a local (local to your HOME directory on the local machine) configuration file that may or may not override command-line directives. Check to see that it is correct.
  3. Ditto #2 above for the global setting.
  4. Check to see what the network configuration is of the remote machine. Are some ports, such as 6000, blocked for some reason? If so, talk to their admins to get it corrected, since there should not be any reason to block those ports.
Good luck,

mmateen 08-09-2009 12:02 PM

Thanks for your reply. Using the following command worked:

ssh -Y -l username remote_hostname

All times are GMT -5. The time now is 05:47 AM.