LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Unable to run 'Software Update' after upgrade to rhel 6.1 (https://www.linuxquestions.org/questions/linux-newbie-8/unable-to-run-software-update-after-upgrade-to-rhel-6-1-a-886366/)

susja 06-14-2011 06:10 PM

Unable to run 'Software Update' after upgrade to rhel 6.1
 
Hello,
I was using RHAT 6.0 Open Client for a couple months and didn't have any issues. Recently my company released version 6.1 of Open Client and recommended to upgrade it. Upgrade went smoothly and I didn't notice any problems until at some point it failed to run 'Software Update' application. Someone from my company forum recommended to do the following:
sudo pgrep -f packagekit| xargs kill -9
sudo rm -rf /var/cache/yum/* /var/cache/PackageKit/*
reboot
After that I have a problem. If I try to start 'Software Update' app from menu I have the error: "An internal system error has occurred":
Error Type: <type 'exceptions.TypeError'>
Error Value: refresh_cache() takes exactly 2 arguments (1 given)
File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 3270, in <module>
main()
File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 3266, in main
backend = PackageKitYumBackend('',
lock=True)
File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 243, in __init__
self.refresh_cache()
**
If I run yum update I have this error:
Updating:
google-talkplugin x86_64 2.1.6.0-1 google-talkplugin 7.3 M
perl x86_64 4:5.10.1-119.el6 RHEL-61-x86_64 10 M
perl-libs x86_64 4:5.10.1-119.el6 RHEL-61-x86_64 577 k

Transaction Summary
================================================================================
Upgrade 3 Package(s)

Total size: 18 M
Is this ok [y/N]: y
Downloading Packages:
Running Transaction Check
Traceback (most recent call last):
File "/usr/bin/yum", line 29, in <module>
yummain.user_main(sys.argv[1:], exit_code=True)
File "/usr/share/yum-cli/yummain.py", line 274, in user_main
errcode = main(args)
File "/usr/share/yum-cli/yummain.py", line 211, in main
return_code = base.doTransaction()
File "/usr/share/yum-cli/cli.py", line 526, in doTransaction
msgs = self._run_rpm_check()
AttributeError: 'YumBaseCli' object has no attribute '_run_rpm_check'

How could I fix it?
Thanks

susja 06-16-2011 10:09 PM

Please ignore.
I fixed it.

andrewthomas 06-16-2011 10:20 PM

When you solve your problem, it is best to explain how your problem was resolved, in order to help others that come across this thread in a search.

susja 06-17-2011 06:51 AM

I agree with andrewthomas. In my case I didn't fixed it myself :) ... someone from my colleague realized that in my system /usr/local/ is a symbolic link with the wrong target. After he removed the link my problem disappeared.


All times are GMT -5. The time now is 06:02 PM.