LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-03-2004, 01:58 PM   #1
Aaron Bynum
LQ Newbie
 
Registered: Mar 2004
Location: Planet Earth
Distribution: Red Hat Shrike
Posts: 1

Rep: Reputation: 0
Question Unable to run 2.4.20-31.9 after upgrading from 2.4.20-8 under Redhat 9.0


I installed Redhat 9.0 with kernel 2.4.20-8. Using apt, I downloaded and updated the kernel to 2.4.20-31.9. I tried to install the NTFS rpm for 2.4.20-31.9, but it kept telling me that it required 2.4.20-31.9. I receive a message saying that it is installed but is not currently in use. First of all, where did it get installed? It's not in the ./boot directory. Second, how do I update grub.conf to allow booting from the new kernel?

I have since downloaded and installed the 2.4.20-8 NTFS rpm which works great. I would like to be running the updated system though.

Is there a better way to update my kernel than through apt?
 
Old 05-04-2004, 03:05 AM   #2
srichand
Member
 
Registered: May 2004
Location: Bangalore, India
Distribution: Fedora Core 2 (modified), Debian
Posts: 34

Rep: Reputation: 15
Best way to install a new kernel, is to downoad its sources, and compile it yourself.
google around, and you should find lots of manuals on the internet to help you compile the kernel.

goto http://kernel.org and download the sources. i would recommend 2.6 instead of the 2.4 series for better ntfs support.

the grub configuration file is in /boot/grub/grub.conf .
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Cannot run xf86config after upgrading to 4.5.0 on Slackware 9.0 1337_penguin Linux - Software 2 07-18-2005 03:49 PM
Unable to launch Kontact after upgrading to KDE 3.3.1 PaleViper SUSE / openSUSE 1 10-24-2004 03:17 AM
Unable to configure new packages when upgrading. cirofren Linux - Newbie 0 10-27-2003 03:36 PM
Unable to login in redhat9 after upgrading from Redhat7.3 sridharcdac Linux - General 6 09-22-2003 12:57 PM
Volume control is unable to run correctly. Unable to open audio device '/dev/mixer'. sevenreams Slackware 1 05-16-2003 07:29 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 10:06 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration