LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Unable to open the web browser as root user (https://www.linuxquestions.org/questions/linux-newbie-8/unable-to-open-the-web-browser-as-root-user-4175417960/)

abhishekgit 07-21-2012 09:08 AM

Unable to open the web browser as root user
 
Hi everyone,
I am a newbie and i am unable to run my default web browser chromium as root. I use sabayon 8 linux. As i open the browser this pops up.
Code:

Please run chromium as normal user, To run as root you must specify an alternate --user-data-dir for storage of profile information.
What does this mean, and what is to be done. Kindly help. Thank you.



Regards...

snowday 07-21-2012 09:13 AM

It means that running your web browser as root is arguably the worst thing you could possibly do from a security standpoint. Explain why you want to give the entire internet root access to your system?

273 07-21-2012 09:26 AM

I would suggest that if you don't know what the error message means you probably don't know enough to make the decision to run your web browser as root. It suggests to me you just have to specify a directory into which user data will be stored, since you're running the browser with a user it wasn't designed to be run as.

abhishekgit 07-21-2012 11:24 AM

@snowpine I am studying how to configure apache web server 1.3.X under linux. In the book they mention all httpd operations are to be run as super user. As i log in to root, I wont be able to access internet for any help because i don't have a web browser.

snowday 07-21-2012 11:34 AM

I think you need a new book. :) The current Apache version is 2.2. Apache 1.3 dates to the 1990s and is now "end of life." Your book's suggestion to browse the web as root is, to be blunt, terrible advice.

Have you seen the documentation here?
http://httpd.apache.org/docs/

273 07-21-2012 11:38 AM

abhishekgit, there is no need to log in as root. You should log in as your usual user account then either open a "root terminal" if your distro provides it or open a terminal and su to root in the terminal. That way you can perform root commands in the terminal and open your browser as your normal user account.

abhishekgit 07-21-2012 12:25 PM

@all
I never tried it logging in as normal user and using su. Never occurred to me. Thank you all for your time. :-)

273 07-21-2012 12:27 PM

You're welcome. Please set the thread solved if it works :).

chrism01 07-22-2012 09:11 PM

note that
Code:

# this gives your root user, but orig user's env
su

# this gives you root user & root env
su -



All times are GMT -5. The time now is 08:39 PM.