Share your knowledge at the LQ Wiki.
Go Back > Forums > Linux Forums > Linux - Newbie
User Name
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!


  Search this Thread
Old 11-02-2007, 01:21 AM   #1
Irene Chan
LQ Newbie
Registered: Oct 2007
Posts: 4

Rep: Reputation: 0
Question Unable to mount USB external hard drive

What is the simplest way to mount any usb devices, I have installed Ubuntu 6.2 and then upgraded to Ubuntu 7.10, when I plug in the usb hard drive and click computer, it is actually showing the drive, but then it popped up with a message that said it is unable to mount the volume. I have several external hard drives and usb pen, is there a way for it to be just plug and play?
Old 11-02-2007, 07:29 AM   #2
LQ Newbie
Registered: Feb 2007
Location: Shanghai, China
Distribution: Fedora&&openSUSE&&Ubuntu
Posts: 13

Rep: Reputation: 0
Is it possible that your USB hard drive didn't get enough power?
Try plug in both the power cable and data cable.
Old 11-02-2007, 07:46 AM   #3
Irene Chan
LQ Newbie
Registered: Oct 2007
Posts: 4

Original Poster
Rep: Reputation: 0
Unfortunately that is not the case, the power is plugged in. It is not mounting any of my external hard drive or usb pen. I have enable ntfs in the config, still no difference.
Old 11-02-2007, 07:58 AM   #4
LQ Newbie
Registered: Feb 2007
Location: Shanghai, China
Distribution: Fedora&&openSUSE&&Ubuntu
Posts: 13

Rep: Reputation: 0
1. Try another USB port. Or do you have another OS ?
2. If your OS won't mount your USB drive, you can mount it yourself.
Plug in the USB pen.
In terminal type: # fdisk -l (so that you will see the device such as: /dev/sda1)
Mount it: # mount /dev/sda1 /mnt/temp (you have to make sure /mnt/temp exists)

You shall have to be root to run the above commands. Good luck.
P.S.: I never have this problem on my Ubuntu 7.10 and Fedora 7

Last edited by neilengineer; 11-02-2007 at 08:00 AM.
Old 11-02-2007, 06:07 PM   #5
Registered: Oct 2007
Location: Sydney, Australia
Distribution: Debian
Posts: 63

Rep: Reputation: 15
try this: howto mount USB drive under Linux guide. If this does not work lets us know on what step did you fail to continue.

Last edited by LlNUX; 12-10-2007 at 05:55 AM.
Old 11-02-2007, 06:16 PM   #6
LQ Guru
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 678Reputation: 678Reputation: 678Reputation: 678Reputation: 678Reputation: 678
What is the filesystem that the drive uses? Is it ntfs? Do you have ntfs support enabled. Either you want the "NTFS" kernel module loaded, if it isn't already, or if you use ntfs-3g, you need the "fuse" kernel module loaded. I don't use Ubuntu, so I don't know if it sets up ntfs support by default. There may also be a group you need to make yourself a member of. Different distro's do this in different ways, so an Ubuntu user may be able to supply you with more concise informaton.
Old 11-02-2007, 08:12 PM   #7
Senior Member
Registered: Feb 2007
Location: Chilliwack,BC.Canada
Distribution: Slackware64 -current
Posts: 2,079

Rep: Reputation: 58
It should be plug-in play, thats how it is in ubuntu, you most likely screwed something up by doing the upgrade
Old 11-04-2007, 06:56 PM   #8
Irene Chan
LQ Newbie
Registered: Oct 2007
Posts: 4

Original Poster
Rep: Reputation: 0
I agree with AceofSpades19, it was probably a bad upgrade. I downloaded Ubuntu 7.10 on the weekend, re-installed in 20 min and now everything is as sweet as honey, PERFECTO!!!! Thank you everyone.
Old 11-05-2007, 01:24 AM   #9
Registered: Jul 2007
Posts: 36
Blog Entries: 1

Rep: Reputation: 15
find the name of the usb device, it may be /dev/sda1, verify the same

# mkdir /mnt/usb1

# mount -t vfat /dev/sda1 /mnt/usb1

***** if the file type in usb device is fat file system, means created in windown environment
otherwise provide appropriate file type after -t
Old 07-04-2008, 08:20 AM   #10
LQ Newbie
Registered: Sep 2007
Posts: 2

Rep: Reputation: 0
How I fixed the "Unable to Mount Drive"

Use the NTFSFIX program.

sudo apt-get install ntfsprogs

sudo ntfsfix /dev/sdb1
(sdb1 or whatever drive the error message indicates)

Your Done.
Old 12-06-2009, 08:27 PM   #11
LQ Newbie
Registered: Dec 2009
Posts: 3

Rep: Reputation: 0

This worked for me after an invalid disconnect with external USB drive.
Old 03-13-2010, 01:02 PM   #12
LQ Newbie
Registered: Mar 2010
Posts: 1

Rep: Reputation: 0
Problem Solved: this is how I did it

1. I tried NTFSFIX but that did not work
2. I checked again the dialog I was getting, and it suggested trying dmesg | tail
3. The output of that mentioned "Unable to identify CD-ROM" so I searched for that in Google
4. This Ubuntu bug page was the first hit:
5. In the many replies there was mention that the installer could have made an invalid entry in the /etc/fstab file:

This bug seems to be due to the installer creating an entry in /etc/fstab for a CD-ROM drive when it shouldn't:
/dev/sdb1 /media/cdrom0 udf,iso9660 user,noauto,exec,utf8 0 0

6. Indeed when I edited the file (sudo gedit /etc/fstab) I saw there was an entry for a CD-ROM (my laptop is an X32, no CD).


device, linux, mount, usb

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
manual mount - External usb hard drive (in ubuntu) tripled2006 Ubuntu 10 10-10-2011 03:36 PM
Unable to mount iStore USB External Hard Drive LupisYonderboy Linux - Newbie 3 10-20-2007 09:12 AM
how do I mount an external USB hard drive hykhoshn Linux - Hardware 1 06-01-2006 10:14 AM
New to RH9 please help me to mount? a external usb hard drive ginda Linux - Newbie 7 05-29-2006 07:11 PM
How to mount external USB hard drive? zyzyis Linux - Newbie 6 02-01-2006 09:37 PM > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 12:58 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration