-   Linux - Newbie (
-   -   Unable to mount USB external hard drive (

Irene Chan 11-02-2007 02:21 AM

Unable to mount USB external hard drive
What is the simplest way to mount any usb devices, I have installed Ubuntu 6.2 and then upgraded to Ubuntu 7.10, when I plug in the usb hard drive and click computer, it is actually showing the drive, but then it popped up with a message that said it is unable to mount the volume. I have several external hard drives and usb pen, is there a way for it to be just plug and play?

neilengineer 11-02-2007 08:29 AM

Is it possible that your USB hard drive didn't get enough power?
Try plug in both the power cable and data cable.

Irene Chan 11-02-2007 08:46 AM

Unfortunately that is not the case, the power is plugged in. It is not mounting any of my external hard drive or usb pen. I have enable ntfs in the config, still no difference.

neilengineer 11-02-2007 08:58 AM

1. Try another USB port. Or do you have another OS ?
2. If your OS won't mount your USB drive, you can mount it yourself.
Plug in the USB pen.
In terminal type: # fdisk -l (so that you will see the device such as: /dev/sda1)
Mount it: # mount /dev/sda1 /mnt/temp (you have to make sure /mnt/temp exists)

You shall have to be root to run the above commands. Good luck.
P.S.: I never have this problem on my Ubuntu 7.10 and Fedora 7

LlNUX 11-02-2007 07:07 PM

try this: howto mount USB drive under Linux guide. If this does not work lets us know on what step did you fail to continue.

jschiwal 11-02-2007 07:16 PM

What is the filesystem that the drive uses? Is it ntfs? Do you have ntfs support enabled. Either you want the "NTFS" kernel module loaded, if it isn't already, or if you use ntfs-3g, you need the "fuse" kernel module loaded. I don't use Ubuntu, so I don't know if it sets up ntfs support by default. There may also be a group you need to make yourself a member of. Different distro's do this in different ways, so an Ubuntu user may be able to supply you with more concise informaton.

AceofSpades19 11-02-2007 09:12 PM

It should be plug-in play, thats how it is in ubuntu, you most likely screwed something up by doing the upgrade

Irene Chan 11-04-2007 07:56 PM

I agree with AceofSpades19, it was probably a bad upgrade. I downloaded Ubuntu 7.10 on the weekend, re-installed in 20 min and now everything is as sweet as honey, PERFECTO!!!! Thank you everyone.

kumar_bst 11-05-2007 02:24 AM

find the name of the usb device, it may be /dev/sda1, verify the same

# mkdir /mnt/usb1

# mount -t vfat /dev/sda1 /mnt/usb1

***** if the file type in usb device is fat file system, means created in windown environment
otherwise provide appropriate file type after -t

ron11311 07-04-2008 09:20 AM

How I fixed the "Unable to Mount Drive"
Use the NTFSFIX program.

sudo apt-get install ntfsprogs

sudo ntfsfix /dev/sdb1
(sdb1 or whatever drive the error message indicates)

Your Done.

DutchieAms 12-06-2009 09:27 PM

This worked for me after an invalid disconnect with external USB drive.

zot3000 03-13-2010 02:02 PM

Problem Solved: this is how I did it

1. I tried NTFSFIX but that did not work
2. I checked again the dialog I was getting, and it suggested trying dmesg | tail
3. The output of that mentioned "Unable to identify CD-ROM" so I searched for that in Google
4. This Ubuntu bug page was the first hit:
5. In the many replies there was mention that the installer could have made an invalid entry in the /etc/fstab file:

This bug seems to be due to the installer creating an entry in /etc/fstab for a CD-ROM drive when it shouldn't:
/dev/sdb1 /media/cdrom0 udf,iso9660 user,noauto,exec,utf8 0 0

6. Indeed when I edited the file (sudo gedit /etc/fstab) I saw there was an entry for a CD-ROM (my laptop is an X32, no CD).

All times are GMT -5. The time now is 01:03 PM.