LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Unable to mount root via NFS (https://www.linuxquestions.org/questions/linux-newbie-8/unable-to-mount-root-via-nfs-790836/)

devaras 02-22-2010 01:21 PM

Unable to mount root via NFS
 
Hi

I am trying to mount my embedded linux target(ARM9 with Uboot) via NFS on my host m/c and have been running into multiple issues. My host machine runs Fedora 12. The initial problem I ran into was the following:


bootserver=255.255.255.255, rootserver=192.207.1.2, rootpath=
Looking up port of RPC 100003/2 on 192.207.1.2
Looking up port of RPC 100005/1 on 192.207.1.2
VFS: Mounted root (nfs filesystem).
Freeing init memory: 120K
Warning: unable to open an initial console.
Kernel panic - not syncing: No init found. Try passing init= option to kernel.

This indicated that it is unable to find the init file under the targetfs(links to the actual buildroot dirs and busybox) /sbin and /bin. I realized that the username I was logged in as did not have permissions setup. So I went ahead and did
chmod 777 (on all files/folders in the targetfs/bin and targetfs/sbin).

Now it no longer complains about the init however it has gone backwards and now gives me the following:

VFS: Unable to mount root fs via NFS, trying floppy.
VFS: Cannot open root device "nfs" or unknown-block(2,0)
Please append a correct "root=" boot option; here are the available partitions:
1f00 262144 mtdblock0 (driver?)
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(2,0)

I also used chown to change the owner of these files/exes to my login just in case, but I still get the same error. I do notice that the root= option in the bootargs for Uboot is not set, I do not know if it even matters? I did restart NFS services also.

Any help on how to troubleshoot and fix this would be very much appreciated, I have been grappling with this for a whole week and read several posts but haven't found anything yet to make the problem go away.

Thank you!
Deva

devaras 02-23-2010 09:16 PM

So..
I tried several things based on web/LQ posts/threads no luck. So I started re-installing my target s/w from scratch and I got this error:


[root@localhost /]# chmod 777 /tftpboot
chmod: cannot access `/tftpboot': No such file or directory


Does this relate to the fact that I am unable to boot the kernel on the target? How do I fix this?

This is my build:

Linux localhost.localdomain 2.6.31.12-174.2.22.fc12.i686.PAE #1 SMP Fri Feb 19 19:10:04 UTC 2010 i686 i686 i386 GNU/Linux

Help sincerely appreciated!
Deva.


All times are GMT -5. The time now is 02:30 PM.