LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   unable to mount root fs on unknown block (https://www.linuxquestions.org/questions/linux-newbie-8/unable-to-mount-root-fs-on-unknown-block-4175657071/)

jazzo 07-08-2019 05:17 PM

unable to mount root fs on unknown block
 
hi guys, I have a laptop (Asus ZenBook UX305) running ubuntu 14.04. Everything was absolutely fine up until this evening when I was asked to run some updates (the usual update manager) i did that and towards the end I had a boot password window coming up asking me to choose a password which I did. The I rebooted the machine and now it's essentially unusable. I get the grub menu - which I didn't get before with 3 options: Ubuntu, Advanced options for Ubuntu and System setup.
If I choose the first one I get the below https://i.postimg.cc/dtkywZ84/IMG-20190708-220728.jpg
The second option is more interesting.
There are a umber of recoveries there: if I select the first one in the list - which doesn't have RECOVERY written next to it, i get the same option, if I then skip the first labelled as recovery and move to the next one with no recovery label i actually do manage to log in and everything seems to be working OK, but when I reboot I get into the same thing again, grub menu and 3 options to choose from.
So I have no idea how I managed to get into this mess, absolutely no clue, does anybody know how I can get back to "normal" and have a fully functional version of ubuntu without loosing all the data?
The third option seems to be taking me to the BIOS.

syg00 07-08-2019 07:52 PM

Nice kit - we had one (or similar) for a while. That's a pretty old Ubuntu - even the LTS should be newer by now.
That screenshot is, as it says, a kernel panic. Things don't get a lot worse than that. When you say " i actually do manage to log in and everything seems to be working OK" - does that mean you get a fully functioning GUI ?.
Post /boot/grub/grub.cfg when you are logged in - it's full of junk, so just attach it.

jazzo 07-09-2019 04:01 AM

Thanks. Yes I managed to get a fully functioning GUI.
That's realy frustrating as I absolutely need the laptop this week, I'm glad I managed to get it to a position where it works, lol, I don't think I will be switching it off for a little while!
Anyway, here is a pastebin of the file https://pastebin.com/UsKPKuDs. The grub menu also wasn't there, it only appeared last night together with the problem

syg00 07-09-2019 05:16 AM

Looking at that, it seems the update screwed up - the cfg isn't built properly. If it were me, I'd simply rebuild it (it'll ask for your password)
Code:

sudo update-grub

jazzo 07-09-2019 05:23 AM

Thanks for getting back to me.
Can i ask you (i know it's a tricky question) would the rebuild cause any issue at all? Considering that at the moment i only have one laptop and that i need it to do some important work this week and probably the next as well, would you recommend I wait till I'm done with the work or you think i can go ahead an do it? A backup this time won't help anyway i don't think
Ah and one more thing, would the grub option disappear on boot or would it still be there?
Cheers

syg00 07-09-2019 05:51 AM

Excellent questions.
I did toy with telling you to backup the cfg, but you'd need to recover it before a reboot would work if the update-grub failed. Do it anyway
Code:

sudo cp /boot/grub/grub.cfg /boot/grub/grub.cfg.bkp
Stick with the work-around you have - it is exactly what you "should" be booting if everything had worked. You are missing nothing, and would gain nothing except satisfaction by running the update. Soon a update manager update will run it for you anyway.

jazzo 07-09-2019 07:17 AM

ah Ok, it's just that everytime I need to switch the laptop on i have to go through all that, which I'd like to avoid. In any case, yes, for now I will stick to the workaround I have as you suggested and create a backup of the cfc (which I will save on a usb stick as well). A few things:


Quote:

Soon a update manager update will run it for you anyway.
Sorry, just so I'm sure I understand, does it mean that the next update is likely to fix everything - well, the grub issue and remove the grub menu too?
Quote:

Stick with the work-around you have...You are missing nothing, and would gain nothing except satisfaction by running the update
So you reckon that even if I run the grub update things won't chance and won't be fixed? IS that what you mean?



I was also thinking to upgrade to 16.04 at some point soon, but I'd imagine that everything has to be in fully working order before I do it.

hazel 07-09-2019 07:42 AM

No, what he means is that some updates run the update-grub script even if you don't ever run it yourself explicitly.

Normally this is a completely safe script to run, but even so, you should back things up first. That's just good policy; it doesn't mean that things are expected to go wrong. However, if you have time constraints (as you do) and have found a safe workaround (as you clearly have), inaction might be the best policy for the time being. You can run update-grub when you don't any longer have a deadline to meet.

jazzo 07-09-2019 03:08 PM

OK, thanks a lot guys for the help. I will probably come back to this thread later on then, when I run the update if I get stuck.


All times are GMT -5. The time now is 04:58 PM.