LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   unable to mount network drive, fstab (https://www.linuxquestions.org/questions/linux-newbie-8/unable-to-mount-network-drive-fstab-4175650108/)

zopte 03-13-2019 11:48 AM

unable to mount network drive, fstab
 
attached to the local network is a R-Pi 3 with an SSD that i want to mount on a manjaro (18.x) laptop

i can SSH and SSHFS into the Pi from a terminal, no problem, however i cannot get this to work when using fstab and i've tried a myrid of different things and combinations

example:

Code:

root@kodi.lan:/ /home/atom/kodi  fuse.sshfs _netdev,identityfile=/home/atom/.ssh/LibreELEC_root_id_rsa,allow_other,default_permissions 0 0
results in:

Code:

# systemctl status home-atom-kodi.mount
● home-atom-kodi.mount - /home/atom/kodi
  Loaded: loaded (/etc/fstab; generated)
  Active: active (mounted) (Result: exit-code) since Wed 2019-03-13 12:44:01 EDT; 2s ago
    Where: /home/atom/kodi
    What: root@kodi.lan:/
    Docs: man:fstab(5)
          man:systemd-fstab-generator(8)
    Tasks: 0 (limit: 4915)
  Memory: 408.0K
  CGroup: /system.slice/home-atom-kodi.mount

Mar 13 12:44:01 atom-pc systemd[1]: Mounting /home/atom/kodi...
Mar 13 12:44:01 atom-pc mount[10918]: read: Connection reset by peer
Mar 13 12:44:01 atom-pc systemd[1]: home-atom-kodi.mount: Mount process exited, code=exited, status=1/FAILURE
Mar 13 12:44:01 atom-pc systemd[1]: Mounted /home/atom/kodi.

using the IP makes no difference - the error is the same

this has been frustrating me for over a month!

michaelk 03-13-2019 09:15 PM

Connection reset by peer is a ssh problem with not an obvious solution but I would of expected the same error when using the sshfs command.

I installed Manjaro in a VM to check systemd automount and while I could manually mount the sshfs share it would never automount by just cd /mnt/test.
Code:

user@host:/home/usr /mnt/test fuse.sshfs users,idmap=user,noauto,x-systemd.automout,IdentityFile=/home/user/.ssh/id_rsa 0 0
There might be a systemd bug and you might want to contact the Manjaro developers to verify. I was successful in installing autofs and being able to automount using sshfs.

https://wiki.archlinux.org/index.php...SSH_(with_FUSE)

zopte 03-14-2019 01:09 PM

thanks for the help, but i have no idea how to use autofs - the Arch wiki doc doesn't conform to what i'm seeing in the /etc/autofs directory and there's multiple files, etc. - way over my head

i also don't know how or where to open a bug issue with Manjaro and at this point i'm just disgusted with all of this - f-it

michaelk 03-14-2019 01:31 PM

Somewhere within the /etc/autofs/auto.master file add the line
Code:

/home/atom/kodi        /etc/autofs/auto.ssh        --timeout=60 --ghost
Now create a /etc/autofs/auto.ssh with the contents.

Code:

kodi    -fstype=fuse,rw,allow_other,IdentityFile=/home/atom/.ssh/LibreELEC_root_id_rsa :sshfs\#root@kodi.lan\:/
Not start autofs service and hopefully when you cd to /home/atom/kodi it will mount the Pi.

It depends on how you access the share but you also should also be able to access the Pi using ssh/sftp from the file browser although I have not tried with Manjaro. Typically it is a virtual file system so access from the command line is not always straight forward or sometimes possible.


All times are GMT -5. The time now is 11:34 PM.