LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Unable to install SPECIFIC libraries gtkmm 1.2.10 and libsigc++ 1.0.4 in debian (https://www.linuxquestions.org/questions/linux-newbie-8/unable-to-install-specific-libraries-gtkmm-1-2-10-and-libsigc-1-0-4-in-debian-4175414816/)

geperezg 07-04-2012 03:46 AM

Unable to install SPECIFIC libraries gtkmm 1.2.10 and libsigc++ 1.0.4 in debian
 
I'm trying to get this old PCMICIA network card (Cisco Aironet 350)and I need the specific libraries listed in the title to get the installing script to run...

I have already tried
"apt-get install libsigc++" and
"apt-get libgtkmm-2.4-dev"
(both of these commands ran ok)

The driver installation script does recognize libsigc++ as present, but it doesn't recognize "gtkmm" as installed. The script does return a warning requesting specific versions:
gtkmm 1.2.10 and libsigc++ 1.0.4

I'm running debian 2.6.32-5-486. Any suggestions are greatly appreciated.
Thanks

knudfl 07-04-2012 05:29 AM

Welcome to LQ.

"libgtkmm1.2-0c21" : version 1.2.10, Debian Etch ..
http://archive.debian.net/search?sea...words=libgtkmm
>> http://archive.debian.net/etch/libgtkmm1.2-0c2a >> i386 >
> http://archive.debian.org/debian/poo....10-8_i386.deb
>> libgtkmm1.2-0c2a_1.2.10-8_i386.deb

The required libgtkmm-dev (1.2.10-8..)
http://archive.debian.net/etch/libgtkmm-dev >> i386 >
> http://archive.debian.org/debian/poo....10-8_i386.deb
>> libgtkmm-dev_1.2.10-8_i386.deb


"libsigc++0c2" : version 1.0.4, Debian Etch ..
http://archive.debian.net/search?sea...ywords=libsigc
>> http://archive.debian.net/etch/libsigc++0c2 >> i386 >
> http://archive.debian.org/debian/poo...4-9.1_i386.deb
>> libsigc++0c2_1.0.4-9.1_i386.deb

Required libsigc++-dev ( 1.0.4-9.1..)
http://archive.debian.net/etch/libsigc++-dev >> i386 >
> http://archive.debian.org/debian/poo...4-9.1_i386.deb
>> libsigc++-dev_1.0.4-9.1_i386.deb

.

geperezg 07-04-2012 03:56 PM

still having issues with libgtkmm
 
I downloaded the links you posted, and I now have the right version of libsigc++ on my system,
but I can't get the libgtkmm to install. I downloaded the links you mentioned, but as I checked through the links, there are dependencies, and dependencies on the dependencies, etc..
Is there a way to refer apt-get install to where this older version of the library is?
when I try apt-get install libgtkmm, I get the 2.4 version.
Any help is greatly appreciated.

knudfl 07-04-2012 05:51 PM

I guess, you can add 'etch' to /etc/apt/sources.list :
sudo gedit /etc/apt/sources.list
.. and then add this line :

deb http://archive.debian.org/debian-archive/debian/ etch main contrib

Next : sudo apt-get update &&
sudo apt-get install libsigc++-dev libgtkmm-dev

.

geperezg 07-04-2012 07:45 PM

that did it
 
Thanks. That gave me the versions I needed.
The whole operation of getting these drivers to work seems to be way out of my scope, but at least i got to learn something.
Thanks


All times are GMT -5. The time now is 11:03 AM.