LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-02-2019, 06:32 AM   #1
grumpy_nl
LQ Newbie
 
Registered: Jun 2019
Posts: 7

Rep: Reputation: Disabled
Unable to install nodejs on a fresh installation


Nothing else is installed yet, this the fourth installation im trying in 6 days.

Installation amd64 from usb is no problem, all install well.
Start terminal
su

then, keep getting keyring errors
+ curl -sLf -o /dev/null 'https://deb.nodesource.com/node_12.x/dists/stretch/Release'

## Adding the NodeSource signing key to your keyring...

+ curl -s https://deb.nodesource.com/gpgkey/nodesource.gpg.key | apt-key add -
gpg: [don't know]: invalid packet (ctb=0a)
gpg: keydb_get_keyblock failed: Value not found
gpg: [don't know]: invalid packet (ctb=0a)
gpg: /tmp/apt-key-gpghome.dF3IXWpkgB/pubring.gpg: copy to '/tmp/apt-key-gpghome.dF3IXWpkgB/pubring.gpg.tmp' failed: Invalid packet
gpg: error writing keyring '/tmp/apt-key-gpghome.dF3IXWpkgB/pubring.gpg': Invalid packet
gpg: [don't know]: invalid packet (ctb=0a)
gpg: error reading '-': Invalid packet
gpg: import from '-' failed: Invalid packet
Error executing command, exiting

What to do, 6 days spending on a install is a bit much, not one time yet running without problems.

Last edited by grumpy_nl; 06-02-2019 at 06:32 AM. Reason: typo
 
Old 06-02-2019, 07:33 AM   #2
hydrurga
LQ Guru
 
Registered: Nov 2008
Location: Pictland
Distribution: Linux Mint 20 MATE
Posts: 8,048
Blog Entries: 5

Rep: Reputation: 2909Reputation: 2909Reputation: 2909Reputation: 2909Reputation: 2909Reputation: 2909Reputation: 2909Reputation: 2909Reputation: 2909Reputation: 2909Reputation: 2909
Hi grumpy_nl, and welcome to LQ.

Which distro (and version) are you running?
 
Old 06-02-2019, 08:07 AM   #3
smallpond
Senior Member
 
Registered: Feb 2011
Location: Massachusetts, USA
Distribution: CentOS 6 & 7
Posts: 3,426

Rep: Reputation: 918Reputation: 918Reputation: 918Reputation: 918Reputation: 918Reputation: 918Reputation: 918Reputation: 918
Did you configure GPG?

https://wooledge.org/~greg/crypto/node41.html
 
Old 06-02-2019, 12:07 PM   #4
grumpy_nl
LQ Newbie
 
Registered: Jun 2019
Posts: 7

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by hydrurga View Post
Hi grumpy_nl, and welcome to LQ.

Which distro (and version) are you running?

https://cdimage.debian.org/debian-cd...64-netinst.iso
 
Old 06-02-2019, 12:11 PM   #5
grumpy_nl
LQ Newbie
 
Registered: Jun 2019
Posts: 7

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by smallpond View Post
Trying this now.
 
Old 06-02-2019, 12:22 PM   #6
grumpy_nl
LQ Newbie
 
Registered: Jun 2019
Posts: 7

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by grumpy_nl View Post
Trying this now.

Same result after that installation
sudo apt-get update
sudo apt-get -y install curl dirmngr apt-transport-https lsb-release ca-certificates vim
curl -sL https://deb.nodesource.com/setup_12.x | sudo -E bash -




+ curl -sLf -o /dev/null 'https://deb.nodesource.com/node_12.x/dists/stretch/Release'

## Adding the NodeSource signing key to your keyring...

+ curl -s https://deb.nodesource.com/gpgkey/nodesource.gpg.key | apt-key add -
gpg: [don't know]: invalid packet (ctb=0a)
gpg: keydb_get_keyblock failed: Value not found
gpg: [don't know]: invalid packet (ctb=0a)
gpg: /tmp/apt-key-gpghome.5lrwTh1rhc/pubring.gpg: copy to '/tmp/apt-key-gpghome.5lrwTh1rhc/pubring.gpg.tmp' failed: Invalid packet
gpg: error writing keyring '/tmp/apt-key-gpghome.5lrwTh1rhc/pubring.gpg': Invalid packet
gpg: [don't know]: invalid packet (ctb=0a)
gpg: error reading '-': Invalid packet
gpg: import from '-' failed: Invalid packet
Error executing command, exiting
 
Old 06-02-2019, 12:36 PM   #7
Contrapak
Member
 
Registered: May 2019
Location: /home/
Distribution: Arch Linux
Posts: 165

Rep: Reputation: 61
Why don't you install Node using the distro's package manager?
 
Old 06-02-2019, 12:46 PM   #8
grumpy_nl
LQ Newbie
 
Registered: Jun 2019
Posts: 7

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Contrapak View Post
Why don't you install Node using the distro's package manager?
Because everyweher i look and google it says
# Using Debian, as root
curl -sL https://deb.nodesource.com/setup_12.x | bash -
apt-get install -y nodejs

Furthermore, i havn't installed anything else except for sudo and curl
 
Old 06-02-2019, 02:24 PM   #9
Contrapak
Member
 
Registered: May 2019
Location: /home/
Distribution: Arch Linux
Posts: 165

Rep: Reputation: 61
Maybe this video might help.
 
Old 06-02-2019, 02:42 PM   #10
grumpy_nl
LQ Newbie
 
Registered: Jun 2019
Posts: 7

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Contrapak View Post
Maybe this video might help.
Followed it and same keyring problem.
 
Old 06-02-2019, 04:33 PM   #11
grumpy_nl
LQ Newbie
 
Registered: Jun 2019
Posts: 7

Original Poster
Rep: Reputation: Disabled
This solved it

cd /etc/apt
sudo mv trusted.gpg trusted.gpg.bak

Now i have node11 installed
 
1 members found this post helpful.
Old 06-02-2019, 04:56 PM   #12
hydrurga
LQ Guru
 
Registered: Nov 2008
Location: Pictland
Distribution: Linux Mint 20 MATE
Posts: 8,048
Blog Entries: 5

Rep: Reputation: 2909Reputation: 2909Reputation: 2909Reputation: 2909Reputation: 2909Reputation: 2909Reputation: 2909Reputation: 2909Reputation: 2909Reputation: 2909Reputation: 2909
Great to hear. If you want, you can mark the thread as "Solved" (see "Thread Tools" at the top of the thread).
 
Old 06-02-2019, 06:38 PM   #13
Contrapak
Member
 
Registered: May 2019
Location: /home/
Distribution: Arch Linux
Posts: 165

Rep: Reputation: 61
Quote:
Originally Posted by grumpy_nl View Post
cd /etc/apt
sudo mv trusted.gpg trusted.gpg.bak

Now i have node11 installed
Hah! The simplest solutions are the best.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: How to install NodeJS, Bower and Gulp on Debian 8 LXer Syndicated Linux News 0 12-28-2015 09:23 AM
LXer: How to install NodeJS, Bower and Gulp on a CentOS 7 VPS LXer Syndicated Linux News 0 08-22-2014 03:04 AM
[SOLVED] nodejs installation error yashfire007 Linux - Newbie 4 05-15-2013 09:37 AM
[SOLVED] nodejs, nodejs-dev incompatibility in Ubintu? mjbradakis Linux - Software 1 03-24-2013 11:50 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 01:05 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration