LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-05-2018, 02:54 AM   #1
purnish_dave
LQ Newbie
 
Registered: Jan 2014
Location: India
Distribution: Slackware 14.2
Posts: 18

Rep: Reputation: Disabled
Unable to connect to wifi on Linux Slackware 14.2


Here's the relevant part of my /etc/rc.d/rc.inet1.conf file

Code:
## Example config information for wlan0.  Uncomment the lines you need and fill
## in your info.  (You may not need all of these for your wireless network)
IFNAME[4]="wlan0"
IPADDR[4]=""
NETMASK[4]=""
USE_DHCP[4]="yes"
#DHCP_HOSTNAME[4]="icculus-wireless"
#DHCP_KEEPRESOLV[4]="yes"
#DHCP_KEEPNTP[4]="yes"
#DHCP_KEEPGW[4]="yes"
#DHCP_IPADDR[4]=""
WLAN_ESSID[4]=SPECTRANET1
#WLAN_MODE[4]=Managed
##WLAN_RATE[4]="54M auto"
##WLAN_CHANNEL[4]="auto"
WLAN_KEY[4]="bf244519cce428111072bff11e4f70affa9e0fb08a8b400e1392d8b5663a71bf"
##WLAN_IWPRIV[4]="set AuthMode=WPAPSK | set EncrypType=TKIP | set WPAPSK=96389dc66eaf7e6efd5b5523ae43c7925ff4df2f8b7099495192d44a774fda16"
WLAN_WPA[4]="wpa_supplicant"
#WLAN_WPADRIVER[4]="ndiswrapper"
Here's my /etc/wpa_supplicant.conf file

Code:
# /etc/wpa_supplicant.conf
# ========================
# This line enables the use of wpa_cli which is used by rc.wireless
# if possible (to check for successful association)
ctrl_interface=/var/run/wpa_supplicant
# By default, only root (group 0) may use wpa_cli
ctrl_interface_group=0
eapol_version=1
ap_scan=1
fast_reauth=1
#country=US

# WPA protected network, supply your own ESSID and WPAPSK here:
network={
        ssid="myessid"
        #psk="passphrase"
        psk=blaskdjflskdjflsakdjf.. etc..
}

I cannot connect manually either.

I am entering the following commands.

Code:
iwconfig wlan0 essid myessid
ifconfig wlan0 192.168.1.5 netmask 255.255.255.0
route add -net default gw 192.168.1.1
wpa_supplicant -iwlan0 -c/etc/wpa_supplicant.conf
On this final command I get

Code:
wlan0: SME: Trying to authenticate with 48:ee:0c:45:28:aa (SSID='SPECTRANET1' freq=2457 MHz)
wlan0: Trying to associate with 48:ee:0c:45:28:aa (SSID='SPECTRANET1' freq=2457 MHz)
wlan0: Associated with 48:ee:0c:45:28:aa
wlan0: WPA: Key negotiation completed with 48:ee:0c:45:28:aa [PTK=CCMP GTK=TKIP]
wlan0: CTRL-EVENT-CONNECTED - Connection to 48:ee:0c:45:28:aa completed [id=0 id_str=]
and then it just gives no further output and doesn't return to the prompt.

Can someone diagnose this.Thanks.

Last edited by purnish_dave; 03-05-2018 at 02:56 AM.
 
Old 03-05-2018, 07:58 PM   #2
frankbell
LQ Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Ubuntu MATE, Mageia, and whatever VMs I happen to be playing with
Posts: 15,440
Blog Entries: 25

Rep: Reputation: 4441Reputation: 4441Reputation: 4441Reputation: 4441Reputation: 4441Reputation: 4441Reputation: 4441Reputation: 4441Reputation: 4441Reputation: 4441Reputation: 4441
What is the make/model of the computer and what wireless chipset is installed? The command lspci issued in a terminal should reveal that information; you may have to issue the command as root.

Please surround the output of any commands with "code" tags, which become available when you click the "Go Advanced" button beneath the compose post window.
 
Old 03-05-2018, 09:45 PM   #3
X-LFS-2010
Member
 
Registered: Apr 2016
Posts: 423

Rep: Reputation: Disabled
i can't check my setup right at the moment but ...

# WPA protected network

make sure your card and the wifi hub support (and agree) on the authentication method your attempting to use (ie, pks)

log into your modem (ie, 192.100.0.1) and make sure you have your codes right, and do wonder if they are enabled and if they are "case sensitive". try a simple network name without spaces so you don't have such issues.

my issue, after reading directions, ended up just being syntax of my labels
 
Old 03-05-2018, 10:45 PM   #4
AwesomeMachine
LQ Guru
 
Registered: Jan 2005
Location: USA and Italy
Distribution: Debian testing/sid; OpenSuSE; Fedora; Mint
Posts: 5,513

Rep: Reputation: 1004Reputation: 1004Reputation: 1004Reputation: 1004Reputation: 1004Reputation: 1004Reputation: 1004Reputation: 1004
I always use network-manager to configure wifi. You adapter may not be configured at all. Try 'rfkill list' or so to check.
 
Old 03-07-2018, 11:41 PM   #5
purnish_dave
LQ Newbie
 
Registered: Jan 2014
Location: India
Distribution: Slackware 14.2
Posts: 18

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by frankbell View Post
What is the make/model of the computer and what wireless chipset is installed? The command lspci issued in a terminal should reveal that information; you may have to issue the command as root.

Please surround the output of any commands with "code" tags, which become available when you click the "Go Advanced" button beneath the compose post window.
Well, the relevant part of output of lspci is the following.

Code:
02:00.0 Network controller: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter (rev 01)
I believe the driver is also installed. In my KDE environment I can also see the nearby networks but I am unable to connect to them.
 
Old 03-08-2018, 01:43 AM   #6
purnish_dave
LQ Newbie
 
Registered: Jan 2014
Location: India
Distribution: Slackware 14.2
Posts: 18

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by AwesomeMachine View Post
I always use network-manager to configure wifi. You adapter may not be configured at all. Try 'rfkill list' or so to check.
Awesome machine,

output of

Code:
rfkill list
is

Code:
0: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: no
1: hci0: Bluetooth
        Soft blocked: no
        Hard blocked: no
 
Old 03-08-2018, 06:12 PM   #7
keefaz
LQ Guru
 
Registered: Mar 2004
Distribution: Slackware
Posts: 6,230

Rep: Reputation: 724Reputation: 724Reputation: 724Reputation: 724Reputation: 724Reputation: 724Reputation: 724
How do you test your connection? Maybe it's dns issue, what do you have in /etc/resolv.conf?

If you want to try Network manager, the easy way is to run ' netconfig ' as root and choose NetworkManager at CONFIGURATION TYPE page
 
Old 03-08-2018, 06:57 PM   #8
purnish_dave
LQ Newbie
 
Registered: Jan 2014
Location: India
Distribution: Slackware 14.2
Posts: 18

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by keefaz View Post
How do you test your connection? Maybe it's dns issue, what do you have in /etc/resolv.conf?

If you want to try Network manager, the easy way is to run ' netconfig ' as root and choose NetworkManager at CONFIGURATION TYPE page
Thanks.

My resolv.conf is the following

Code:
# Generated by dhcpcd from wlan0.dhcp
# /etc/resolv.conf.head can replace this line
nameserver 192.168.0.1
# /etc/resolv.conf.tail can replace this line
However, I finally managed to get my wifi running with wicd. It's a workaround I know.
 
  


Reply

Tags
slackware, wifi problem


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
wifi can't connect: unable to obtain IP somethingtohide Linux - Wireless Networking 13 10-24-2015 03:44 AM
Unable to connect to the wifi in Linux Mint 15 (XFCE) CWood Linux - Networking 3 09-24-2013 10:30 AM
unable to connect wifi with 802.11 b/g sevymt Linux - Newbie 12 07-23-2010 09:01 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 01:40 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration