LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Unable to connect to the internet wirelessly (https://www.linuxquestions.org/questions/linux-newbie-8/unable-to-connect-to-the-internet-wirelessly-653167/)

karthickannamalai 07-02-2008 04:18 PM

Unable to connect to the internet wirelessly
 
Hi,

I have the following set-up:

Laptop(linux) -> Wireless Router -> PC(linux) -> Dial-up Modem -> Internet

First I tried connecting the laptop to the router wirelessly and it worked. I was able to ping the router from my Laptop. I was also able to ping the PC and the modem which were all connected wired to each other. So my connection worked till

Laptop -> (wireless) Router -> (wired) PC -> (wired) Modem

But I was not able to get to the internet..

When I tried with wired connection between my laptop and Router.. I was able to ping each other as well as the PC and Modem.. Mainly I was also able to get onto the internet.. I dont know what's the problem when I connect wirelessly..

I'm sure the problem is not with the modem as it is able to connect to the internet when laptop is directly connected to the router (Wired) and as well as I'm able to access internet from the PC which is connected to the modem.. Only when it is wireless between Laptop and Router that I am not able to connect to the internet.

I guess the problem might be with the router.. Can anyone help me out with this?? If anybody has encountered this kind of situation before or if some has experience solving wireless connectivity problems please do post your replies here. It will be of great help to me.

Cheers!!

K.Karthick Annamalai

Amuro-Ray2020 07-02-2008 07:08 PM

Distro in use
 
Hello,

First let me ask, what distribution of Linux are you running on your laptop?

Second, just to clarify, you said that your laptop connects to your wireless router just fine, and that you can ping other devices on your network with the wireless laptop, but you cannot reach the internet, correct?

If this is accurate, it sounds like it may be a DNS issue. If you want to test if it is a DNS issue, try pinging a public address on the internet from your wireless laptop (For example, google's address at 64.233.167.99) If this works, you have a DNS related issue. However, if it doesn't work, it is a routing issue.

jschiwal 07-02-2008 07:24 PM

Check with "/sbin/route" and see if you have a default gateway. It should be the address of the router. The /etc/resolv.conf file should contain entries for your ISPs DNS servers. Also check if you have some sort of filtering setup on the router. The MAC address for the wireless device will differ from that of the NIC device, and some routers can have MAC filtering set up.


All times are GMT -5. The time now is 10:13 AM.