LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-10-2011, 04:28 AM   #1
kkumaresan.p
LQ Newbie
 
Registered: Jun 2011
Posts: 1

Rep: Reputation: Disabled
Unable to Connect to the Internet in Linux.


Hi,

I have installed Linux 5.6 in my home PC, i tired to use internet connection its failed to connect. Whereas i am able to work in windows XP.

In Linux:-

i am not able to ping any sites.

i am using BSNL Broadband connection.

i have enable the option DHCP (IN DNS Configuration) to obtain an IP automatically from the ISP.

/etc/resolv.conf file looks like

search localhost
nameserver 192.168.1.1

Please help me to resolve this issue.

Thanks in Advance.
 
Old 06-10-2011, 04:55 AM   #2
ButterflyMelissa
Senior Member
 
Registered: Nov 2007
Location: Somewhere on my hard drive...
Distribution: Manjaro
Posts: 2,699
Blog Entries: 23

Rep: Reputation: 405Reputation: 405Reputation: 405Reputation: 405Reputation: 405
Quote:
nameserver 192.168.1.1
Hi, is'nt that the IP of your gateway? I guess the IP of the DNS server of your ISP goes there.

Try pinging your own box:

Quote:
ping 127.0.0.1
Check what the settings are

Quote:
ifconfig -a
Are there valid settings? IP address, gateway, netmask? Are netmask of your gateway (modem?) and your box the same? Is your box set to use DHCP? If so, try a static IP address instead, maybe DHCP is not available on your setup - your modem has to have a DHCP sever available....if not, you cannot get an IP address.

I'll keep this thread in view to see where else I could help...

Thor
 
Old 06-10-2011, 05:17 AM   #3
16pide
Member
 
Registered: Jan 2010
Posts: 418

Rep: Reputation: 83
to help us help you, please post the output of the following terminal commands:
Code:
ifconfig
ifconfig -a
route
grep hosts /etc/nsswitch.conf
ping 192.168.1.1
ping 8.8.8.8

Last edited by 16pide; 06-10-2011 at 05:20 AM.
 
Old 06-10-2011, 06:06 AM   #4
saivnoba
Member
 
Registered: Aug 2010
Distribution: Debian Sid, openSUSE, Gentoo, Slackware64
Posts: 68

Rep: Reputation: 2
Quote:
Originally Posted by kkumaresan.p View Post
Hi,
I have installed Linux 5.6 in my home PC, i tired to use internet connection its failed to connect. Whereas i am able to work in windows XP.

In Linux:-
i am not able to ping any sites.

i am using BSNL Broadband connection.

i have enable the option DHCP (IN DNS Configuration) to obtain an IP automatically from the ISP.

/etc/resolv.conf file looks like

search localhost
nameserver 192.168.1.1
You have not mentioned which distro you are using. By 5.6, I guess it is either RHEL or CentOS. Please post the output of
Code:
uname -a
Also, are you trying wired connection or wireless. On my CentOS box I tried a lot to get wireless working. But no success.

In your resolv.conf file, line starting from nameserver is correct. But I'm not sure about the first line. I don't have it in my box. Try after removing the line 'search localhost'.

Also, can you ping 192.168.1.1? But not websites like www.google.com? Check for firewall settings in your modem.
 
Old 06-10-2011, 06:19 AM   #5
ButterflyMelissa
Senior Member
 
Registered: Nov 2007
Location: Somewhere on my hard drive...
Distribution: Manjaro
Posts: 2,699
Blog Entries: 23

Rep: Reputation: 405Reputation: 405Reputation: 405Reputation: 405Reputation: 405
Quote:
Also, can you ping 192.168.1.1? But not websites like www.google.com? Check for firewall settings in your modem.
If that's the case, I bet the DNS is not set properly/at all. If that's the only itch, he'd be able to ping google directly using the IP address 74.125.79.147 ... How about trying:

Quote:
ping 74.125.79.147
and see what gives? If it's a clean install, google will not be in the block list...
 
Old 06-10-2011, 06:40 AM   #6
divyashree
Senior Member
 
Registered: Apr 2007
Location: bbsr,orissa,India
Distribution: RHEL5 ,RHEL4,CENT OS5,FEDORA,UBUNTU
Posts: 1,363

Rep: Reputation: 135Reputation: 135
Quote:
Originally Posted by kkumaresan.p View Post
Hi,

I have installed Linux 5.6 in my home PC, i tired to use internet connection its failed to connect. Whereas i am able to work in windows XP.

In Linux:-

i am not able to ping any sites.

i am using BSNL Broadband connection.

i have enable the option DHCP (IN DNS Configuration) to obtain an IP automatically from the ISP.

/etc/resolv.conf file looks like

search localhost
nameserver 192.168.1.1

Please help me to resolve this issue.

Thanks in Advance.
The IP in your resolv.conf, have you entered this manually or it took automatically ?

You can do one thing, if internet works in windows, in windows go to cmd, run the ipconfig /all and collect the dns server adresses and put them in the resolv.conf .

Now check whether it works or not.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Unable to Connect to Internet using Linux Mint. MexDeath Linux - Networking 8 08-13-2009 12:04 AM
Able to connect to default Gateway, Unable to connect to internet Dumb.Coder Linux - Newbie 11 04-14-2009 05:22 AM
unable to connect to my linux router from internet using ssh shkkhanhyd Linux - Security 3 03-31-2004 10:44 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 07:32 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration