-   Linux - Newbie (
-   -   Unable to connect to Internet (

v8skittles 09-09-2009 09:29 PM

Unable to connect to Internet
Ok, today I installed Slackware 13.0 on my Dell Latitude C640. I have previously installed KUbuntu around 2 years ago, and could successfully connect to the internet. However after installing Slackware I have discovered I could not connect to the Internet.

Router: Linksys WRT54GS v2

I have tried running netconfig and entering all the necessary info, and editing rc.inet1 and entering the IP info but that also did not work. Ive also tried going into Network settings but it will say "Could not parse XML". Any thoughts?

karlatLQ 09-09-2009 09:41 PM

start here
Start here:

v8skittles 09-09-2009 09:43 PM

I have but I couldn't get anything to work, and I'm pretty sure I didn't change anything incorrectly :(.

GrapefruiTgirl 09-09-2009 10:14 PM

Well, if Kubuntu worked 2 years ago, Slack13 will most certainly work today.

We need to know what network device (the NIC) you are using first. You can identify this by the command:

shell# lspci -vv

and posting for us the part about the NIC. Or if it's a USB device (which it may be, since that looks like a wireless router and the USB thingies are popular), do the following:

shell# lsusb

and show us that output.

Next, provide the output of the command:

shell# lsmod.

Since you say that all was well with Kubuntu, I'm suspecting that providing the above info will be helpful to know, but the problem actually lies in your rc.inet1 file.

As for the "Network Settings" thing, I haven't a clue about the XML error, but I've never got the GUI tools to work for configuring my network (and to be fair, I haven't tried them on Slack13 yet). Did you try using Wicd? That apparently works a charm.

Also, are you using DHCP to get your IP address, and if so, have you got it enabled in rc.inet1.conf? Why not post for us the rc.inet1 file too. More info is better than less :) and also, check your /etc/resolv.conf file and see what's in there; there should be at least two nameserver addresses.


v8skittles 09-09-2009 11:40 PM

NIC: 3Com Corporation 3c905C- TX/TX-M

Ill try to get wicd tomorrow, for I am too tired to search tonight.

v8skittles 09-10-2009 05:16 PM

My friend who also has Slackware, and who recommended Slackware told me that there is something called Wpa_Supplicant already setup. How do I access it?

karlatLQ 09-10-2009 05:34 PM

Explain how you are trying to connect to the internet. Note that Slackware is considered a bit more of an advanced distribution than Ubuntu. You said that you were able to connect to the internet with Ubuntu. Were you using the exact same computer?

For wpa supplicant, here is a web page from a Google search: WPA It is not Slackware specific, but can give you some ideas about what to do.

Can you explain what is the hardware on your computer that you are using to try to connect to the internet? That will allow you to get better help on the forum.

What type of internet access do you have?

v8skittles 09-10-2009 05:47 PM

P4 2.0 GHZ Processor
Ati Mobility Radeon 7500 32mb
NIC: 3Com Corporation 3c905C- TX/TX-M

I am using a wired connection that goes through my router. I forgot to mention that when I ran kubuntu I was on a wireless connection if that helps.

karlatLQ 09-10-2009 06:13 PM

What you want to find out if your NIC card is supported by Slackware, and then if you have it configured properly. Then, if your router and NIC are working right, and if your router is connected to the internet.

From the terminal or command line (bash), which has a shell prompt ">" usually.


> sudo lspci -vv
From this output, look for the part that says "network interface controller" or something like that. Then, look for the kernel module part. Post the answers to that. For example, "forcedeth"


> ifconfig
From this output, look to see if the ethernet interface is up. Post the answers. For example,


Link encap:Ethernet HWaddr 00:16:2B:E5:1D:43
inet addr: Bcast: Mask:
Also from that, see the loopback is there:

lo Link encap:Local Loopback
inet addr: Mask:
And, post the results from your file /etc/resolv.conf

And post the results from the command:

> sudo route

jschiwal 09-10-2009 06:54 PM

The results of the "lspci -vv" command will help determine the controller used in your wireless device.

Here is an example for my netbook:

04:00.0 Network controller: Atheros Communications Inc. Device 002b (rev 01)
        Subsystem: Foxconn International, Inc. Device e016
        Flags: bus master, fast devsel, latency 0, IRQ 18
        Memory at f0200000 (64-bit, non-prefetchable) [size=64K]
        Capabilities: <access denied>
        Kernel driver in use: ath9k
        Kernel modules: ath9k

When I went from Fedora 11 to openSuSE 11.1, wireless wouldn't work. This was because I needed a newer kernel version so ath9k would recognize the Atheros device my Gateway netbook uses. If you don't see the "Kernel modules:" line at the end, you may have the same situation.

karlatLQ 09-10-2009 07:44 PM


Originally Posted by jschiwal (Post 3677985)
The results of the "lspci -vv" command will help determine the controller used in your wireless device.

Good. But, v8skittles has a "wired connection".

I am using a wired connection that goes through my router.
So, it would help to find out about the NIC card.

v8skittles 09-11-2009 09:30 AM

I switched to a wireless connection yesterday. If necessary I can switch back, I used wired because I occasionally gamed on my laptop but I have been busy with school so I stopped, and it's one less cable going wireless.

I am using a Wireless-G Network Adapter Model. WPC54GS ver 2

For the Network Controller Kernel Module it says: ssb

Link encap: Ethernet HWaddr 00:02:2d;7e:bf:2a
inet6 addr: fe80::202:2dff:fe7e:bf2a/64 Scope:Link

For the resolv.conf it says: search

Results of sudo route:

Destination Gateway Genmask Flags Metric Ref Use Iface
loopback * U 0 0 0 lo

karlatLQ 09-11-2009 01:17 PM


Originally Posted by v8skittles (Post 3678752)
I switched to a wireless connection yesterday. ...I am using a Wireless-G Network Adapter Model. WPC54GS ver 2

Both should work in Linux unless there is hardware incompatibility. Read what the moderator said about wireless - jschiwal.

The troubleshooting that I was giving you was more for the wired network, but some will apply to the wireless as well. Information from your ISP could be helpful too as well as what type of internet connection you have from your ISP. Did you use the same ISP when you connected with Ubuntu and the same computer configuration and the same computer?

Changing comptuers, ISPs, or computer configurations in the middle of troubleshooting or problem solving on the forum makes it difficult to resolve the issues. There are a few forum posts on configuring connections to the internet for both wired and wireless connections.

For the wireless connection, try:


> iwconfig
or if root permission is needed then try


> sudo iwconfig
Then if you see an entry like "wlan0" then try this:


> sudo iwconfig wlan0 up
or its equivalent. Read the man page by trying this:


> man iwconfig
It looks like the next step could be configuring loopback and the default route, and then configuring route.conf with the nameservers for your ISP. Post your results from the iwconfig commands.

v8skittles 09-14-2009 07:58 PM

Everything was is exactly the same as the time I ran kubuntu

v8skittles 09-14-2009 09:24 PM

For > sudo iwconfig wlan0 up it says unknown command "up".
For > iwconfig it has

lo no wireless extensions.
eth0 no wireless extensions.
eth1 IEEE 802.11b ESSUD:"" Nickname:"darkstar"
Ill skip to Access point: None

wmaster0 no wireless extensions.

wlan0 IEEE 802.11bg ESSID:""
Access Point: Not-Associated

All times are GMT -5. The time now is 09:29 PM.