LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   unable to compile source files (https://www.linuxquestions.org/questions/linux-newbie-8/unable-to-compile-source-files-384591/)

Hallowedpoint 11-19-2005 06:41 AM

unable to compile source files
 
I'm running SuSE 10.0 OSS from the OpenSuSE project. I recently converted from Windows (I was running 98 simply because XP disgusted me) and am still trying to get everything sorted out and working smoothly. While searching for needed programs, lib files, and codecs, I tried several times to use the tar files and compile everything myself. I followed the install instructions after unzipping and untarring the file, but everytime I ran the ./configure command, it gave me a error saying that there was no C compiler in $PATH. What does this mean and how can I fix it? Thanks a whole lot!

masonm 11-19-2005 06:58 AM

You need to use YAST and install the development apps. These include compilers and lib files needed for compiling. You should also install the kernel source as well.

What exactly are you trying to install? Many commonly used app binaries are available as RPMs already configured for SuSE. Perhaps you need to become more familiar with YAST?

cs-cam 11-19-2005 06:59 AM

It means you don't have a compiler installed to build the software. Naturally this is a problem.

Never fear! Easy to fix, crack open Yast and use it to install all the software in the Development section. I've never used Suse to be able to give exact instructions but you'll at least need gcc installed but just grabbing all the dev tools is probably easier :)

fouldsy 11-19-2005 06:59 AM

At a guess, you need to go into YaST and install the "make" tools. I don't think they install by default depending on the version of SuSE. You should then be able to compile from source. Are there no pre-compiled packages for SuSE for the libraries + tools you're trying to install, or the main apps available by YaST to let the system install all the dependencies for you?

fouldsy 11-19-2005 07:00 AM

What's that about waiting for a bus and then 3 come along at once...

:D

masonm 11-19-2005 07:05 AM

LOL

Hallowedpoint 11-19-2005 08:02 AM

thanks
 
Actually, this happened to me multiple times... not just with any specific program. I've since found RPM files (that I couldn't find earlier.. because I'm a n00b lol) for what I needed, but it was really frustrating me not knowing what was wrong. I'll install all the development tools with YaST as suggested. I was assuming that they would install compilers and things of that nature automatically... and we all know what happens when you assume... Thanks a whole lot!


All times are GMT -5. The time now is 05:01 PM.