LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-19-2017, 10:01 PM   #1
nixtr
LQ Newbie
 
Registered: Mar 2017
Posts: 10

Rep: Reputation: Disabled
Unable to access iPhone -- Unhandled Lockdown error (-16) ??


Hi Again, Now trying to email pics and I get this error message, also when I try to load the phone's pics into my laptop. Tried googling it, but to newbish to make the returns i clicked on helpful. Many Thanks for any help offered here. Nixtr
 
Old 03-19-2017, 10:08 PM   #2
frankbell
LQ Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Debian, Mageia, and whatever VMs I happen to be playing with
Posts: 12,498
Blog Entries: 16

Rep: Reputation: 3210Reputation: 3210Reputation: 3210Reputation: 3210Reputation: 3210Reputation: 3210Reputation: 3210Reputation: 3210Reputation: 3210Reputation: 3210Reputation: 3210
Please provide more detail.

How are you trying to load the pics/connect the iPhone to the laptop?

What distro/version of Linux are you using? (Your user agent icon says "Ubuntu," but many Ubuntu derivatives report as Ubuntu.)

Note that Apple aggressively refuses to support Linux. There is, for example, no iTunes for Linux.

A web search for "iphone linux" will turn up a number of articles. I don't have any iJunk, so I have no way of testing any of them.

Oh, and welcome to Linux and to LQ.
 
1 members found this post helpful.
Old 03-19-2017, 10:32 PM   #3
nixtr
LQ Newbie
 
Registered: Mar 2017
Posts: 10

Original Poster
Rep: Reputation: Disabled
Please excuse my forgetting to add what's needed to help. My OS is Linux Mint 17.3 'Rosa' Xfce 32-bit. I was on gmail and clicked on the attachments: browse button to find the picture I wanted to send from my iphone I had USB-attached to my PC. Will do that search. Thanks Again, Nixtr
 
Old 03-19-2017, 10:49 PM   #4
nixtr
LQ Newbie
 
Registered: Mar 2017
Posts: 10

Original Poster
Rep: Reputation: Disabled
searched linux iphone and from http://geeknizer.com/sync-iphone-linux/ I tried this on the terminal: sudo add-apt-repository ppamcenery/ppa to this response:


-laptop ~ $ sudo add-apt-repository ppamcenery/ppa
[sudo] password for nick:
'This PPA does not support trusty'
Cannot add PPA: ''This PPA does not support trusty''.

Then thought I'd go for the updates with sudo apt-get update as a command. Will see if any effect takes, maybe. Nixtr
 
Old 03-20-2017, 12:17 AM   #5
nixtr
LQ Newbie
 
Registered: Mar 2017
Posts: 10

Original Poster
Rep: Reputation: Disabled
then I ran the command: idevicepair unpair && idevicepair pair and got: "ERROR: Device ba497bd6990c4a8b84cbbd91e34af811d86c53ce is not paired with this host" as a response from the terminal
 
Old 03-20-2017, 12:25 AM   #6
nixtr
LQ Newbie
 
Registered: Mar 2017
Posts: 10

Original Poster
Rep: Reputation: Disabled
the number has changed on my unhandled lockdown error to (-256) briefly, then went back to (-16) when checked again. Hmmph.
 
Old 03-20-2017, 05:29 PM   #7
nixtr
LQ Newbie
 
Registered: Mar 2017
Posts: 10

Original Poster
Rep: Reputation: Disabled
just to add, this thread is unresolved, but I believe there must be a way around and so is solvable, maybe. Thanks for any further contribution.
 
Old 03-21-2017, 06:13 PM   #8
nixtr
LQ Newbie
 
Registered: Mar 2017
Posts: 10

Original Poster
Rep: Reputation: Disabled
now tried to install libimobiledevice and my terminal responded with: laptop ~ $ sudo apt-get install libimobiledevice
[sudo] password for nick:
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package libimobiledevice

So is tht saying I dont already have it or the program cant find it online to install it? Thanks
 
Old 03-21-2017, 06:29 PM   #9
BW-userx
Senior Member
 
Registered: Sep 2013
Location: MID-SOUTH USA
Distribution: Void Linux / Slackware 14.2
Posts: 4,675

Rep: Reputation: 865Reputation: 865Reputation: 865Reputation: 865Reputation: 865Reputation: 865Reputation: 865
check to see if usbmuxd is installed -- thats what I do what ver ios is it? what version iPhone is it.

Run through the list of pkgs in here and make sure you got everything installed via your repo. \http://www.libimobiledevice.org/
 
Old 03-21-2017, 08:43 PM   #10
nixtr
LQ Newbie
 
Registered: Mar 2017
Posts: 10

Original Poster
Rep: Reputation: Disabled
Hi & Thanks for replying. I clicked on the libimob.... link you provided, but cannot recognize the list of packages. did you refer me to this:

Sources and Dependencies:

libimobiledevice-1.2.0.tar.bz2
ifuse-1.1.3.tar.bz2
libplist-1.12.tar.bz2
libusbmuxd-1.0.10.tar.bz2
usbmuxd-1.1.0.tar.bz2 (needs libusb >= 1.0.3)
ideviceinstaller-1.1.0.tar.bz2
libideviceactivation-1.0.0.tar.bz2
or this one that's labelled packages, but hard to discern which if any would apply, for newbie me, anyway: Packages:

openSUSE openSUSE or 1-Click Install (openSUSE 13.2)
Fedora Fedora (Packages in the official repositories)
Debian Debian
Ubuntu Ubuntu (Packages in the official repositories)

I woulda clicked on the 1st one but didn't say for linux mint nor call it the libimobiledevice. Sorry but dealing with newbies is like dealing with newbies. Thanks for trying, Nixtr
 
Old 03-21-2017, 09:36 PM   #11
rokytnji
LQ 5k Club
 
Registered: Mar 2008
Location: Waaaaay out West Texas
Distribution: AntiX 17 , ChromeOS
Posts: 5,117
Blog Entries: 20

Rep: Reputation: 2382Reputation: 2382Reputation: 2382Reputation: 2382Reputation: 2382Reputation: 2382Reputation: 2382Reputation: 2382Reputation: 2382Reputation: 2382Reputation: 2382
Ubuntu and Mint are the same thing. So go with the Ubuntu link and pick the 16.04 version of the deb or ppa/repo.
 
Old 03-22-2017, 08:12 AM   #12
BW-userx
Senior Member
 
Registered: Sep 2013
Location: MID-SOUTH USA
Distribution: Void Linux / Slackware 14.2
Posts: 4,675

Rep: Reputation: 865Reputation: 865Reputation: 865Reputation: 865Reputation: 865Reputation: 865Reputation: 865
yeah one does have to decipher through it to figure out everything iDevice related. Everything I need gets installed except libusbmuxd and usbmuxd - I just install them and my file manager thunar and pcmamfm picks up my iPhone np I just have to do that 'trust' thing.
 
Old 03-22-2017, 08:57 AM   #13
rokytnji
LQ 5k Club
 
Registered: Mar 2008
Location: Waaaaay out West Texas
Distribution: AntiX 17 , ChromeOS
Posts: 5,117
Blog Entries: 20

Rep: Reputation: 2382Reputation: 2382Reputation: 2382Reputation: 2382Reputation: 2382Reputation: 2382Reputation: 2382Reputation: 2382Reputation: 2382Reputation: 2382Reputation: 2382
Quote:
Originally Posted by BW-userx View Post
yeah one does have to decipher through it to figure out everything iDevice related. Everything I need gets installed except libusbmuxd and usbmuxd - I just install them and my file manager thunar and pcmamfm picks up my iPhone np I just have to do that 'trust' thing.
Yeah. Threads like these remind me why I sold my Iphone and bought a Samsung.

http://antix.freeforums.org/iphone-5...8-2-t5586.html

Always one IOS update away from breakage.

Last edited by rokytnji; 03-22-2017 at 08:59 AM.
 
Old 03-22-2017, 09:17 AM   #14
BW-userx
Senior Member
 
Registered: Sep 2013
Location: MID-SOUTH USA
Distribution: Void Linux / Slackware 14.2
Posts: 4,675

Rep: Reputation: 865Reputation: 865Reputation: 865Reputation: 865Reputation: 865Reputation: 865Reputation: 865
Quote:
Originally Posted by rokytnji View Post
Yeah. Threads like these remind me why I sold my Iphone and bought a Samsung.

http://antix.freeforums.org/iphone-5...8-2-t5586.html

Always one IOS update away from breakage.
yep - every time they update the ios Linux doesn't connect with it again. I just keep my iphone for music and games mostly. its like an ipod with a phone I do not use. very seldom do I ever use my file manager to get into it. I use my android instead.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
wine: Unhandled page fault on write access derstephen Linux - Games 3 11-08-2011 09:14 PM
[SOLVED] An unhandled error occured jamesubuntufan Linux - Desktop 15 03-27-2011 12:18 PM
LXer: Pessulus- A lockdown editor for Gnome to limit users functionality access LXer Syndicated Linux News 0 04-21-2010 05:30 AM
CD/DVD CREATOR - nautilus - unhandled error hectorDUQUE Fedora 2 07-02-2008 10:29 AM
Winecfg Error: wine: Unhandled page fault on read access... unreal128 Linux - Software 3 12-06-2006 08:51 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 09:22 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration