LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   ummm, I screwed up again (https://www.linuxquestions.org/questions/linux-newbie-8/ummm-i-screwed-up-again-150143/)

Jeff_G_1974 02-24-2004 08:30 PM

ummm, I screwed up again
 
Ok, I really know nothing about Linux and I'm in deep right now. I didn't know about the xkill command and my system had frozen up (well, that's not true, but applications were crashing left, right and center and I couldn't log out or shut down the machine). I ended up doing a reset on the PC and now when I boot into Linux, I won't let me boot into KDE, GNOME or even X for that matter. I'm stuck at a command prompt and I really don't know what to do from here on in. Am I looking at having to format my PC and reinstalling Linux again? Please advise.

frieza 02-24-2004 08:32 PM

what does the command prompt say? is it a login prompt or a command prompt?

frieza 02-24-2004 08:34 PM

just another thought, if it's a command prompt

[root@localhost root]#
then type runlevel.... and tell me what it says...

Jeff_G_1974 02-24-2004 09:01 PM

Ok, this is what happens. Linux goes through the boot process and it shows what all services are running. Then, instead of booting into GNOME, it goes to a command prompt screen asking me to login. Before I get the chance though, there is an error that comes up right away. The error is as follows......INIT: Id "x" respawning too fast: Disabled for five minutes. If you wait the five minutes, the same error message comes back. However, with that error message up, I was still able to login simply by typing my username and password. I did the runlevel check like you said and the runlevel check was N 5. I also checked out additional documentation and the documentation mentioned running fsck with the -y option. Seeing as to how it also mentioned that if this is done it can potentially corrupt and further damage the file system, I politely declined. Maybe Linux just isn't meant for an idiot like me........

Atmchicago 02-24-2004 09:23 PM

Dude, don't be so hard on yourself. Linux isn't all that hard to get after using it a week (or less).

What happens if you type:

telinit 5

or

gdm

or

startx?

And what do you mean when you said you reset your pc?

Jeff_G_1974 02-24-2004 11:14 PM

well, if I type in startx, I get errors saying that files are either corrupted or missing. I never tried gdm or telinit 5 because I didn't know about those commands. I did try something that someone suggested about trying to reinstall all the rpms that I had downloaded. That didn't work either as one of the rpms was corrupted too. Damn, I only wish that there was a rollback feature with Linux. The command I tried was rpm -U /var/spool/up2date/*.rpm. So, I'm finding things out about Linux which is a good thing, but I've got a funny feeling I'm going to have format the drive and I'll have to format the master boot record to get rid of the boot loader. This is going to be a lot of fun.......I'm still rather hopeful that I can undo what I did. And by resetting my PC, I mean I had to hit the reset button on my tower. That's how bad my PC froze in Linux.

SciYro 02-24-2004 11:33 PM

na sence in linux everything is a added on program, all you need to do at worst is delet your GUI and every file thats linked to the libs it uses, then reinstall, i get those respawn errors to but sence you cant start x with startx, then id recomoend a full reinstall of xfree86 (also be sure to delet xfree86 (the GUI) completly before installing, this include, (especialy) includes the libaries, dont be suprised if you ahve to reinstall the programs taht use the GUI to, but i doupt you will need to

frieza 02-25-2004 01:13 AM

ok, i think i see a solution.. ignore the error message for now and try logging as root in and typing
init 3
then run
redhat-config-xfree86 and give it the necessary information, it should test your settings for you then when done (when it works) type
init 5

Redeye2 02-25-2004 03:44 PM

By the way, check which processes are running. You might be wanting to start X when a faulty copy is running. Do so by typing ps. If you see anything that should not be running, look at the process id or pid (it's a 4 digit number) and then type kill pid where pid is the number.


All times are GMT -5. The time now is 08:18 AM.