LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Ugly fonts in open office and xine (https://www.linuxquestions.org/questions/linux-newbie-8/ugly-fonts-in-open-office-and-xine-89168/)

Phantomas 09-04-2003 08:58 AM

Ugly fonts in open office and xine
 
I've installed openoffice 1.1.0 onto my debian sid machine. All of the fonts ugly, and antialising isn't working. (Same goes with xine and a few other apps...)

I've done a bit of research and found that freetype has truetype font support turned off by default, due to patents held by apple.

I remember when i had mandrake installed OOo fonts looked nice, so i guess they turned it on. I'm guessing debian has it turned off in open office, being the careful people that they are.

I've got anti aliasing woking nicely in most of my other apps, notably moz firebird, which also uses freetype.

Is there an easy way to fix this problem? I'd really like to avoid having to recompile a new version of freetype for open office if at all possible, out of fear of breaking things and causing more problems than i started with...

Is there a way to make OO use firebird's freetype or something?

quatsch 09-04-2003 09:03 AM

go into the installation directory of OOo and then into the subdirectory named program. There is a
libfreetype.so.6
move it to somewhere else or rename it (just in case you need it back). Then create a symbolic link named
libfreetype.so.6
where the link target is
/usr/lib/libfreetype.so.6
(this is where the libfreetype.so.6 most applications use is installed on my system; it might be different for you. Just look for it)
This works for me.
cheers

Phantomas 09-04-2003 09:28 AM

I checked in /usr/lib/openoffice/program, but there was no libfreetype.so.6 there.

/usr/lib/libfreetype.so.6 is actually a link to /usr/lib/libfreetype.so.6.3.4 on my system, so i did:

ln -s /usr/lib/libfreetype.so.6.3.4 /usr/lib/openoffice/program/libfreetype.so.6

I've restarted OO but nothing's changed :(

quatsch 09-04-2003 09:51 AM

hm. I'm actually using the beta version of OOo1.1 and not the latest rc version so maybe things are a bit different.

But to make things sure. Is /usr/lib/openoffice the installation directory of OOo1.1? If you used the tar.gz version, the default intallation directory is, I think, /opt/OpenOffice1.1 or something like that.

Phantomas 09-04-2003 10:20 AM

OK, finally got it sorted. Found a good howto here: http://theregus.com/content/4/26770.html

I recompiled freetype with true type fonts enabled... Wasn't too painful.
Then i ran ./usr/lib/openoffice/spadmin And added all of my true type fonts from there.

Now i can actually change the font used in the OOo UI to a nice anti aliased one, and it looks good. Sweet.

Cheers

Phantomas 09-04-2003 10:27 AM

If anyone else needs to know in the future, to change the UI font in OOo you got to tools -> options -> OpenOffice.org -> fonts.

Tick 'Apply Replacement Table', then type in 'Andale Sans UI' in the 'Font' field (this is OOo's default gui font. It probably won't be in the drop down list, you'll have to type it in yourself), then pick a better font to replace it with in the 'Replace Font' field.

Press the tick button, check 'always' and 'screen' and you should be good to go :)


All times are GMT -5. The time now is 06:45 PM.