LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Ugh! - AKA The dreaded "udev changed my ethernet interface" issue. (https://www.linuxquestions.org/questions/linux-newbie-8/ugh-aka-the-dreaded-udev-changed-my-ethernet-interface-issue-4175599407/)

maschelsea 02-09-2017 07:24 PM

Ugh! - AKA The dreaded "udev changed my ethernet interface" issue.
 
As many of you know, after ten years of using Gentoo, I switched to Slackware last December. I feel like over the past couple of months, I've grown into Slackware. I've had a few issues here and there, but overall, I've always been able to resolve them. Like when I reboot Slack and my web browser loads and reports that I have Page Not Found errors in every open tab. This is relatively easy to fix: Just run /etc/rc.d/rc.inet1 start. Granted, I still think immediately of running /etc/init.d/net.eth0 restart. Eventually that will go away. For the meantime, though, my backup machine (bought in Sept, 2005 and still mostly functional) runs Gentoo updated to April, 2016, when I bought my current workstation. Because my backup machine runs Gentoo (granted, a somewhat dated Gentoo - kernel 4.0.5 in fact (and I KNOW that that kernel is vulnerable to Dirty Cow, but at least it works when I need it,)) I have created a USB with a recent install of Gentoo on it. The problem is that when I boot the USB drive, udev loads my ethernet interface on sit0. I desperately want it to be on eth0. On my old machine, I accomplished this by putting net.ifnames=0 in my /boot/grub/grub.conf. Of course, that was grub.0.97-r16 and my USB runs grub-2.02_beta3-r1:2/2.02_beta3-r1. I am asking this because I tend to have a rather short attention span. It used to be longer, but I'm dreadfully out of practice not having used it in about twenty years. I tend to freak out and completely lose my train of thought whenever I encounter something I don't understand. I have tried and tried and tried to make sense of the Gentoo forum people who have had this exact problem. I have put dummy files in /etc/udev/rules.d/ to override files in /lib/udev/rules.d/. Right now I have

Code:

caitlyn ~ # ls /etc/udev/rules.d/
70-network.rules  80-net-name-slot.rules  80-net-setup-link.rules

I am chrooted into my Gentoo USB drive because I have no network when I boot off my USB. I know that I could simply create file called copy my /etc/conf.d/net.eth0 file over to /etc/conf.d/net.sit0 and change the config.eth0 reference to config.sit0, but then I wouldn't learn how to step beyond this issue, and I'd really REALLY like to step beyond this issue. I know that my short attention span is an excuse and that I need to develop more patience, but for the time being, will anyone answer this for me?

r3sistance 02-09-2017 07:35 PM

I don't think the sit0 device will work even if you did switch the configuration to it as the sit0 device is for tunneling ipv6 traffic over ipv4 and not an actual network device, I believe... but don't quote me on that. I would suspect you are probably missing the relevant driver or module required for your specific network card and so it maybe not loading at all, not too familiar with slackware to advise tho.

maschelsea 02-09-2017 07:54 PM

The ethernet kernel module is r8169. I ran a working Gentoo system used everyday from the end of April 2016 until December. I based my kernel config off the previous Gentoo system's config. Before I wiped Gentoo off this workstation, I copied the entire system to a 2TB external drive I have and then copied back relevant parts (/etc, /home, etc etc). I spent a lot of time in April and May of 2015 getting my running kernel just right. The Gentoo system worked until one day I discovered that the kernel version I was running was no longer in portage. I tried emerging and building the newest stable kernel, but when I rebooted with it, I encountered this exact issue. Since I knew that I would probably not be able to get much help from the Gentoo forums (those people get offended VERY easily,) and I couldn't figure it out on my own in a timely manner, it might just be time to switch. I want a Linux system that JUST WORKS. Slackware seems to do that. Granted, I freaked out a little the first time I rebooted Slackware and networking didn't start, and there was no /etc/init.d/net.eth0 to restart. Fortunately, I calmed down quickly and booted my old workstation, which still worked. But now I have the command in a text file for when I need to reference it.

maschelsea 02-09-2017 10:34 PM

I think I've solved it for the moment. Problems like this always seem to come back. To me. I inserted

Code:

GRUB_CMDLINE_LINUX="net.ifnames=0"
into /etc/default/grub. And r3sistance was correct. It WAS a problem with the module. I copied over every kernel source I had from the external drive onto /usr/src on the Gentoo USB. My 4.7.10 kernel booted and acted as I wanted it to, but the 4.9.6-r1 kernel which is the kernel source recommended by portage wouldn't, even after I build it manually several times. For some strange reason, even though the driver was set to build a module in the 4.7.10 source and I ran make menuconfig before building the 4.9.6-r1 source, it didn't register that I wanted the r8169 module built. Like I said earlier, these things happen. To me. I'm just thankful it wasn't anything worse. My /usr/src/linux/.config files seem to disappear with some frequency. Thank you for your help!


All times are GMT -5. The time now is 08:15 PM.