LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Ubuntu, WoW - permission denied. (https://www.linuxquestions.org/questions/linux-newbie-8/ubuntu-wow-permission-denied-768225/)

ArminBeganovic 11-10-2009 01:51 PM

Ubuntu, WoW - permission denied.
 
Hi,

Been playing WoW in Ubuntu 9.10 under Wine for a while now, but last night a new patch came to WoW, and after installing the patch, I suddenly couldn't log on WoW.

I get the message:

Could not launch World of Warcraft

Failed to change to directory 'home/armin/dosdevices/c:/Program Files/World of Warcraft/' (Permission denied)

If I got to /Program Files, the WoW folder now has two wierd emblems on it, a lock and a X. This was not there before.

tom4everitt 11-10-2009 03:07 PM

To me it seems like the installation of the patch has caused some permission flag to be set wrongly.

First I would try to set full permission to (only) the folder home/armin/dosdevices/c:/Program Files/World of Warcraft/

This you do by running (in a terminal):

Code:


chmod 777 'home/armin/dosdevices/c:/Program Files/World of Warcraft/'

(just write me back if you don't know how to do this.)

If that doesn't work, I would try to give full permission also to everything inside the folder, by running (you might wanna do a backup of the folder before you go ahead with this, depending on how much you care about it):

Code:


chmod -R 777 'home/armin/dosdevices/c:/Program Files/World of Warcraft/'


ArminBeganovic 11-10-2009 03:31 PM

I went to the WoW folder, and then options. Here I gave myself permission to enter and use the containing files. However, when I went to applications, wine, and World of Warcraft, the options changes back... So I did it again, but this time I opened the folder and found WoW.exe and could launch the game this way.

tom4everitt 11-11-2009 03:43 PM

So it was only something wrong with the link/shortcut then. Excellent!

hplc 03-04-2010 10:35 AM

got same problem
 
every single time i try to start wow i get permission denied. If i set the correct rights with nautilus it still has changed back the next time i try to access it.

If i manually set chmod -R 777 and then enter the folder and right click "open with wine windows program loader" on wow.exe, it starts and enumerates the patch i previously has downloaded.

The harddrive seems to work some as if its installing the patch and restart the game (as it should), and after a while a window appear, it looks like a world of warcraft error message window, but its blank, theres no message in what to appears to be an error message, only a "ok" button. Hitting that "ok" button just shuts down everything as if i just accepted an error message i cant even see, what am i doing wrong?. Is that text missing because i dont have the fonts needed to show the text?

EDIT:

The Launcher.log contains:

15:04:28.9435 Launcher version 2.1.1.1374

15:04:29.1779 Reverting to old PSF patching system.

15:04:29.3278 Cannot find realmlist.wtf file at 'C:\Program Files\World of Warcraft\realmlist.wtf'.

15:04:29.3432 Fetch version information from eu.version.worldofwarcraft.com (http://80.239.232.126/update/PatchSequenceFile.txt).

15:04:29.4980 Received version information from http://80.239.232.126/update/PatchSequenceFile.txt.

15:04:29.4993 Unable to find current version of World of Warcraft in the patch sequence file.

15:04:29.4994 Unable to find current version of World of Warcraft in the patch sequence file.

15:04:29.4994 No update is required.

duble08 03-07-2010 03:11 AM

i have the same problem - it just started happening recently. i saw a recommended script to fix the problem which i guess works for some, but for me the folder keeps locking immediately after any WOW based application opens, such as Launcher.exe and wow.exe, or any file in the wow directory gets accessed, which in the end still makes this unplayable. the script i was given is as follows:

#!/bin/bash
clear
wine "/home/<user>/.wine/dosdevices/c:/Program Files/World of Warcraft/wow.exe";
chmod 755 "/home/<user>/.wine/dosdevices/c:/Program Files/World of Warcraft/" -R

of course you replace <user> with the user account WINE is configured under...

Whenever i run this script, one of two things always happens.

1. i get the same error as before: Failed to change to directory 'home/<user>/dosdevices/c:/Program Files/World of Warcraft/' (Permission denied) - I'm guessing I'm getting this error because the folder seems to lock each time a file is accessed in it

2. gnome (i think that's what the gui is called... I'm new to Linux) will restart - meaning it kicks everything out to the terminal, then automatically restarts gnome again, bringing me to the login screen.

I've even tried completely uninstalling wow and then reinstalling it in a different folder (eg. /home/<user>/.wine/dosdevices/c:/games/world of warcraft/) and it still does the same thing.

If you need specs on what I'm using, I'm running Ubuntu 9.1 with all the recent updates, I'm running WINE v 1.1.31, and my machine is a Compaq Presario laptop, model cq60-215dx. it has the nvidia 8200m graphics chipset, and I'm using the nvidia proprietary drivers release 185. I wouldn't imagine system specs would really come into play when it comes to folder and file privileges, but i figure it doesn't hurt to post them. Let me know if you need more info - I'd like to get this resolved, and hopefully help others fix the problem as well.

Thank you all for your time!!

duble08 03-08-2010 02:39 PM

ok... so i think i found the fix to this finally!! whenever i open launcher.exe, it still tries to lock the folder and files, but if i dive right into wow.exe, it seems to work now. I was having problems even with wow.exe until i realized that wow was missing a pretty important file, known as "config.wtf". I don't know why this file wasn't automaticly created, or why it didn't exist on my machine, but i found some info on it on codeweavers web site here:

http://www.codeweavers.com/compatibi...id=1185;tips=1

basicly, how to this is as follows:

find your WOW directory.. usually it is installed by default under "/home/<user>/.wine/dosdevices/c:/Program Files/World of Warcraft"

if you don't see your ".wine" folder, simply press "control + H" and it'll show your hidden folders

inside your World of Warcraft folder, you'll see another folder titled "WTF"

Inside that folder, i found on my machine that the only file that existed was "RunOnce.wtf.temp".

What i had to do was create another file inside this directory, which i titled "Config.wtf"

inside "Config.wtf" i placed this code:

SET readTOS "1"
SET readEULA "1"
SET readScanning "-1"
SET readContest "-1"
SET readTerminationWithoutNotice "-1"
SET installType "Retail"
SET locale "enUS"
SET expansionMovie "0"
SET movie "0"
SET showToolsUI "1"
SET realmList "us.logon.worldofwarcraft.com"
SET patchlist "us.version.worldofwarcraft.com"
SET coresDetected "2"
SET hwDetect "0"
SET gxMultisampleQuality "0.000000"
SET videoOptionsVersion "2"
SET Gamma "1.000000"
SET Sound_OutputDriverName "System Default"
SET Sound_MusicVolume "0.40000000596046"
SET Sound_AmbienceVolume "0.60000002384186"
SET farclip "727"
SET specular "1"
SET groundEffectDensity "24"
SET projectedTextures "1"
SET M2UseShaders "0"
SET Sound_SoundOutputSystem "1"
SET Sound_SoundBufferSize "150"
SET accountName "retsakeoj"
SET mouseSpeed "1"
SET accounttype "CL"
SET VoiceActivationSensitivity "0.39999997615814"
SET ChatMusicVolume "0.29999998211861"
SET ChatSoundVolume "0.39999997615814"
SET ChatAmbienceVolume "0.29999998211861"
SET realmName "Twisting Nether"
SET gameTip "2"
SET gxResolution "1680x1050"
SET gxTripleBuffer "1"
SET uiScale "0.83999997377396"
SET useUiScale "1"
SET componentTextureLevel "9"
SET ffxDeath "0"
SET ffxGlow "0"
SET gxRefresh "60"

I had to modify certain sections to be compatible with my machine, such as the line "SET gxResolution "1680x1050"

i simply changed the resolution line to where it stated 1366x768, which is my native widescreen resolution. you can also change the line of account name and realm name if you know what you're supposed to be configured for. otherwise, i'm sure you'll be able to change it when the game loads.

I haven't found a way to stop launcher.exe from locking up folder and file privilages yet, but i'm satisfied with my discovery so far. These settings were posted by someone that has an ATI graphics card, but i used them on my machine which is running an Nvidia 8200m, so i'd imagine it should work with both chipsets.

Good luck, and i hope this works for you guys too!!


All times are GMT -5. The time now is 06:33 AM.