-   Linux - Newbie (
-   -   Ubuntu(studio)8.04.2 - Stops loading at about 70% on progress bar (

siabost 03-30-2009 12:01 PM

Ubuntu(studio)8.04.2 - Stops loading at about 70% on progress bar
Packard Bell EasyNote Laptop F5280HR
Celleron 2.8Ghz
Video adapter is a SiSM661FX (SiS661FX on SiS website)
768Mb Memory Installed (64Mb of this used for graphics)

Managed to install Ubuntustudio 8.04.2 eventually by adding vga=771 to boot command.

On booting from hard disk loading freezes at about 70% and I don't get as far as a login or any desktop, for that matter.

It freezes as shown below (last 5 lines shown):

cat: /var/lib/acpi-support/system-manufacturer:No such file or directory
cat: /var/lib/acpi-support/system-product-name:No such file or directory
cat: /var/lib/acpi-support/system-product-version:No such file or directory
cat: /var/lib/acpi-support/bios-version:No such file or directory
* Saving VESA state...
I think I have a screen resolution problem.

After booting into "recovery" and dropping into shell...

The output of

sudo lshw -C

*-display UNCLAIMED
description: VGA compatible controller
product: 661/741/760 PCI/AGP or 662/761Gx PCIE VGA Display Adapter
vendor: Silicon Integrated Systems [SiS]
physical id: 0
bus info: pci@0000:01:00.0
version: 00
width 32 bits
clock: 66MHz
capabilities: pm agp agp-3.0 vga_controller cap_list
configuration: latency=0
Do I need to set the screen resolution from the command line? How do I do this & what should I set it to? 800x600?

Any help appreciated.

amani 03-30-2009 12:11 PM

Welcome to LQ!

Try the boot time kernel option


If that does not work

stay at the command line and

#apt-get update
#apt-get upgrade

(you may need a different kernel)

You can edit /etc/X11/xorg.conf

amani 03-30-2009 12:13 PM

modprobe agpgart-sis

siabost 03-30-2009 04:26 PM

Thank you for the welcome amani.
It is a pleasure to be involved in Linux - I have 3 desktops running one form of Linux or another.

To enable the "get upgrade" option you describe I presume I will have to activate network manager (or the network) from the command-line to get on-line. How do I do that?

The "pci=norom" didn't work - still freezes at "* saving VESA state..."


modprobe agpgart-sis
returned "module could not be found", but maybe I need to be on-line first & get updates?

First try - thanks for help so far.

amani 03-31-2009 09:57 AM

agpgart-sis is your driver module.

Then stick with vesa or the default... you can use 'fix xserver' in the trouble shooting mode.

For Network

How do you want to connect?

pppoe (type that at the terminal and hit the tab key twice)?


[ editing in vim /vi
press i to insert
esc to stop inserting
:wq to save and quit file]

siabost 04-02-2009 06:16 AM

Login Screen but still no Desktop
Hi amani,

I've got a bit further forward in that I can now get a Login Screen (complete with background picture) but no desktop.

The problem with the progress bar sticking at 70% was solved by using the solution described at
Once SAVE_VBE_STATE=true was changed to false in /etc/default/acpi-support that problem was solved & I got through to the Login Screen.

With an unmodified xorg.conf, after login & selecting Gnome (or Gnome-safe) session, I get a grey screen with the top left quarter white.

Driver "sis"
in the Device section of xorg.conf makes no difference. Adding

Driver "vesa"
makes things worse and I drop into a grey screen immediately.

I have updated & upgraded the system &

modprobe agpgart-sis

modprobe agp-sis
both return "module not found".

Is it possible a driver is not being loaded? Or am I just suffering a resolution problem?

I noticed there is a specific open-source driver for my SiS card at but I would have to download & install this from the command-line and I am a newbie!

Any ideas?

Many thanks.

amani 04-02-2009 12:25 PM

modprobe sisfb

use sisfb instead of sis in xorg.conf if no error is reported

Post output of lsmod

siabost 04-03-2009 04:17 PM

sisfb - module failed to load


modeprobe sisfb
did not return any error but when I entered:

Driver "sisfb"
in Device Section of xorg.conf I get the warning:

failed to load "sisfb" (module does not exist, 0)
BUT... when I tried modprobe sis-agp and didn't specify a driver in xorg.conf it worked & I got a desktop. Rebooted twice successfully.
***UPDATE - following day I'm back to no desktop! And repeating what I did above doesn't get me back to one! Very puzzled. (My laptop battery is pretty much useless - might that have something to do with it?)

When I did have a desktop I had no sound!

No sound applet is loaded in sys-tray but having checked alsamixer in terminal all the relevant channels seem to be unmuted and have plenty of level.

Running lshw in terminal gives:

description: Multimedia audio controller
product: AC'97 Sound Controller
vendor: Silicon Integrated Systems (SiS)
physical id: 2.7
bus info: pci@0000:00:02.7
version: a0
width: 32 bits
clock: 33Mhz
capabilities: bus_master cap_list
configuration: driver=Intel ICH latency=128 maxlatency=11 mingnt=52
The output of lsmod:

pci_hotplug 31776 1 shpchp
i2c_core 25392 1 i2c_sis96x
pcspkr 4224 0
ext3 137480 2
jbd 49044 1 ext3
sg 36696 0
sr_mod 18084 0
cdrom 37152 1 sr_mod
sd_mod 31152 4
pata_acpi 8320 0
pata_sis 15364 3
ehci_hcd 37644 0
ohci_hcd 26512 0
sis900 24448 0
ata_generic 8452 0
mii 6400 1 sis900
usbcore 147372 3 ehci_hcd,pata_sis,ata_generic
scsi_mod 153196 4 sg,sr_mod,sd_mod,libata
thermal 16924 0
processor 37256 1 thermal
fan 5636 0
fuse 51604 1
That's all I can see now but before I briefly had the desktop working I saw an entry:

agpgart sis_agp
But that's no longer in the list!

Thanks again

All times are GMT -5. The time now is 07:07 PM.