LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-15-2017, 01:29 PM   #1
stickyrice
LQ Newbie
 
Registered: Jun 2017
Posts: 2

Rep: Reputation: Disabled
Ubuntu IP issue


Hello all

I am currently running ubuntu 14.04.1 LTS which I installed today on my dell poweredge R210 for testing purposes. I configured both NIC cards, the first one on a static IP address and the second on DHCP. My problem is when I disconnect my ethernet cable from the static IP address it doesn't allow me to Ping from my other connection via DHCP. From what I know I should still be able to ping from the second interface. help pleaase.

A separate issue from this, why cant I set a static IP on ubuntu 16.04 without rebooting the machine???


This is my configuration:


Last login: Thu Jun 15 14:11:46 2017 from 192.168.5.167
bi@ubuntu:~$ cat /etc/network/interfaces
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
auto em1
iface em1 inet static
address 192.168.5.33
netmask 255.255.255.0
gateway 192.168.5.1

#The secondary network interface
auto em2
iface em2 inet dhcp
 
Old 06-15-2017, 03:40 PM   #2
Rickkkk
Senior Member
 
Registered: Dec 2014
Location: Montreal, Quebec, CANADA
Distribution: Arch
Posts: 1,113

Rep: Reputation: 419Reputation: 419Reputation: 419Reputation: 419Reputation: 419
Hi stickyrice ... A few questions to help us help you:

- Are both NICs wired ? ... or is the DHCP-configured (secondary) interface wireless ?

- Are you expecting both connections to be live simultaneously ? To me, this would be an unusual objective, unless you are connecting to 2 different networks, and even then, the setup would be quite particular.

- If you are NOT expecting both to be live simultaneously (most likely), when unplugging the ethernet cable from the primary interface, are you also instructing your system to set it DOWN ? For example:

Code:
# ip link set em1 down
would be the command I would use in Arch ... Are you then issuing a command to bring the secondary interface UP to obtain an IP address ?

- What network configuration system are you using ? I am afraid I'm not that familiar with Ubuntu.

Catch up with you once you get back to us ...

Last edited by Rickkkk; 06-15-2017 at 03:43 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
DMRAID Issue + TrueCrypt Issue - May Not Be Ubuntu Specific The00Dustin Ubuntu 3 07-01-2014 05:41 AM
Issue with Ubuntu 10.04? ajeetsinghraina Linux - Newbie 2 07-15-2010 04:27 AM
Another Ubuntu issue.... DAVE666 Linux - Newbie 1 01-20-2008 08:23 AM
Ubuntu issue.. Saurian Linux - Newbie 19 03-15-2006 10:44 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 01:37 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration