LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-23-2017, 12:28 AM   #1
ddenial
Member
 
Registered: Dec 2016
Distribution: CentOS, Fedora, Ubuntu
Posts: 193

Rep: Reputation: 35
Ubuntu - How to install package from older distro's ppa


Hello

The title says it all. I'm using Ubuntu 16.10 x86_64. I want to install package winconn, which will allow me to connect to remote app in Windows 7. But the problem is, the ppa is upto Ubuntu Quantal (12.10).

How can I install winconn package which is in Quantal (12.10) PPA into Ubuntu 16.10.


The ppa is:
Code:
sudo add-apt-repository ppa:realender/winconn
sudo apt-get update
sudo apt-get install winconn
I'm following these guides to achieve access to remote app in MS Windows.
How To - Create truly seamless Windows applications use on your Linux Desktop
HowTo Ubuntu and Windows RemoteApp Use Guide

Thanks

Last edited by ddenial; 01-23-2017 at 12:30 AM.
 
Old 01-23-2017, 12:43 AM   #2
TheEzekielProject
Member
 
Registered: Dec 2016
Distribution: Devuan+lxde
Posts: 656

Rep: Reputation: 190Reputation: 190
The only reason I could see it not working on a later edition is because of dependencies. You could easily test this by running a vm of Ubuntu 16.10, simply add that PPA and install. Try to run it and see where it fails.

Looking at its source on github, it doesn't look like this has been maintained for some time. You might want to look for something newer.

Well, there was a commit Dec 28 2015, but nothing since or for years before

Last edited by TheEzekielProject; 01-23-2017 at 12:53 AM.
 
1 members found this post helpful.
Old 01-23-2017, 12:56 AM   #3
ddenial
Member
 
Registered: Dec 2016
Distribution: CentOS, Fedora, Ubuntu
Posts: 193

Original Poster
Rep: Reputation: 35
Quote:
Originally Posted by TheEzekielProject View Post
The only reason I could see it not working on a later edition is because of dependencies. You could easily test this by running a vm of Ubuntu 16.10, simply add that PPA and install. Try to run it and see where it fails.
I'm a Linux noob. Here is the result:
Code:
$ sudo add-apt-repository ppa:realender/winconn
 WinConn RemoteApp connection manager
 More info: https://launchpad.net/~realender/+archive/ubuntu/winconn
Press [ENTER] to continue or ctrl-c to cancel adding it

gpg: keybox '/tmp/tmp8d_k94el/pubring.gpg' created
gpg: /tmp/tmp8d_k94el/trustdb.gpg: trustdb created
gpg: key 7E1BA2FC9CEE05AF: public key "Launchpad PPA for Alex Stanev" imported
gpg: Total number processed: 1
gpg:               imported: 1
OK
Code:
$ sudo apt-get update
Ign:1 http://dl.google.com/linux/chrome/deb stable InRelease
Hit:2 http://dl.google.com/linux/chrome/deb stable Release
Hit:5 http://ppa.launchpad.net/danielrichter2007/grub-customizer/ubuntu yakkety InRelease                                                                    
Get:6 http://security.ubuntu.com/ubuntu yakkety-security InRelease [102 kB]                                                                                  
Hit:7 http://in.archive.ubuntu.com/ubuntu yakkety InRelease                                            
Hit:8 http://ppa.launchpad.net/fossfreedom/indicator-sysmonitor/ubuntu yakkety InRelease                 
Get:9 http://in.archive.ubuntu.com/ubuntu yakkety-updates InRelease [102 kB]                              
Hit:10 http://ppa.launchpad.net/nathan-renniewaldock/flux/ubuntu yakkety InRelease                                
Hit:11 http://ppa.launchpad.net/nilarimogard/webupd8/ubuntu yakkety InRelease                                                                                
Hit:12 http://ppa.launchpad.net/qbittorrent-team/qbittorrent-stable/ubuntu yakkety InRelease                                                                              
Ign:13 http://ppa.launchpad.net/realender/winconn/ubuntu yakkety InRelease                                 
Hit:14 https://deb.opera.com/opera-stable stable InRelease          
Hit:4 http://screenshots.getdeb.net yakkety-getdeb InRelease                                    
Get:15 http://in.archive.ubuntu.com/ubuntu yakkety-backports InRelease [102 kB]                 
Hit:16 http://ppa.launchpad.net/rvm/smplayer/ubuntu yakkety InRelease             
Hit:17 http://ppa.launchpad.net/webupd8team/atom/ubuntu yakkety InRelease             
Hit:18 http://ppa.launchpad.net/webupd8team/java/ubuntu yakkety InRelease
Hit:19 http://ppa.launchpad.net/yannubuntu/boot-repair/ubuntu yakkety InRelease
Ign:20 http://ppa.launchpad.net/realender/winconn/ubuntu yakkety Release
Ign:21 http://ppa.launchpad.net/realender/winconn/ubuntu yakkety/main i386 Packages
Ign:22 http://ppa.launchpad.net/realender/winconn/ubuntu yakkety/main amd64 Packages
Ign:23 http://ppa.launchpad.net/realender/winconn/ubuntu yakkety/main all Packages
Ign:24 http://ppa.launchpad.net/realender/winconn/ubuntu yakkety/main Translation-en
Ign:25 http://ppa.launchpad.net/realender/winconn/ubuntu yakkety/main Translation-en_IN
Ign:26 http://ppa.launchpad.net/realender/winconn/ubuntu yakkety/main amd64 DEP-11 Metadata
Ign:27 http://ppa.launchpad.net/realender/winconn/ubuntu yakkety/main all DEP-11 Metadata
Ign:28 http://ppa.launchpad.net/realender/winconn/ubuntu yakkety/main DEP-11 64x64 Icons
Ign:21 http://ppa.launchpad.net/realender/winconn/ubuntu yakkety/main i386 Packages
Ign:22 http://ppa.launchpad.net/realender/winconn/ubuntu yakkety/main amd64 Packages                                                                                      
Ign:23 http://ppa.launchpad.net/realender/winconn/ubuntu yakkety/main all Packages                                                                                        
Ign:24 http://ppa.launchpad.net/realender/winconn/ubuntu yakkety/main Translation-en                                                                                      
Ign:25 http://ppa.launchpad.net/realender/winconn/ubuntu yakkety/main Translation-en_IN                                                                                   
Ign:26 http://ppa.launchpad.net/realender/winconn/ubuntu yakkety/main amd64 DEP-11 Metadata                                                                               
Ign:27 http://ppa.launchpad.net/realender/winconn/ubuntu yakkety/main all DEP-11 Metadata                                                                                 
Ign:28 http://ppa.launchpad.net/realender/winconn/ubuntu yakkety/main DEP-11 64x64 Icons                                                                                  
Ign:21 http://ppa.launchpad.net/realender/winconn/ubuntu yakkety/main i386 Packages                                                                                       
Ign:22 http://ppa.launchpad.net/realender/winconn/ubuntu yakkety/main amd64 Packages                                                                                      
Ign:23 http://ppa.launchpad.net/realender/winconn/ubuntu yakkety/main all Packages                                                                                        
Ign:24 http://ppa.launchpad.net/realender/winconn/ubuntu yakkety/main Translation-en                                                                                      
Ign:25 http://ppa.launchpad.net/realender/winconn/ubuntu yakkety/main Translation-en_IN                                                                                   
Ign:26 http://ppa.launchpad.net/realender/winconn/ubuntu yakkety/main amd64 DEP-11 Metadata                                                                               
Ign:27 http://ppa.launchpad.net/realender/winconn/ubuntu yakkety/main all DEP-11 Metadata                                                                                 
Ign:28 http://ppa.launchpad.net/realender/winconn/ubuntu yakkety/main DEP-11 64x64 Icons                                                                                  
Ign:21 http://ppa.launchpad.net/realender/winconn/ubuntu yakkety/main i386 Packages                                                                                       
Ign:22 http://ppa.launchpad.net/realender/winconn/ubuntu yakkety/main amd64 Packages                                                                                      
Ign:23 http://ppa.launchpad.net/realender/winconn/ubuntu yakkety/main all Packages                                                                                        
Ign:24 http://ppa.launchpad.net/realender/winconn/ubuntu yakkety/main Translation-en                                                                                      
Ign:25 http://ppa.launchpad.net/realender/winconn/ubuntu yakkety/main Translation-en_IN                                                                                   
Ign:26 http://ppa.launchpad.net/realender/winconn/ubuntu yakkety/main amd64 DEP-11 Metadata                                                                               
Ign:27 http://ppa.launchpad.net/realender/winconn/ubuntu yakkety/main all DEP-11 Metadata                                                                                 
Ign:28 http://ppa.launchpad.net/realender/winconn/ubuntu yakkety/main DEP-11 64x64 Icons                                                                                  
Ign:21 http://ppa.launchpad.net/realender/winconn/ubuntu yakkety/main i386 Packages                                                                                       
Ign:22 http://ppa.launchpad.net/realender/winconn/ubuntu yakkety/main amd64 Packages                                                                                      
Ign:23 http://ppa.launchpad.net/realender/winconn/ubuntu yakkety/main all Packages                                                                                        
Ign:24 http://ppa.launchpad.net/realender/winconn/ubuntu yakkety/main Translation-en                                                                                      
Ign:25 http://ppa.launchpad.net/realender/winconn/ubuntu yakkety/main Translation-en_IN                                                                                   
Ign:26 http://ppa.launchpad.net/realender/winconn/ubuntu yakkety/main amd64 DEP-11 Metadata
Ign:27 http://ppa.launchpad.net/realender/winconn/ubuntu yakkety/main all DEP-11 Metadata
Ign:28 http://ppa.launchpad.net/realender/winconn/ubuntu yakkety/main DEP-11 64x64 Icons
Err:21 http://ppa.launchpad.net/realender/winconn/ubuntu yakkety/main i386 Packages
  404  Not Found
Ign:22 http://ppa.launchpad.net/realender/winconn/ubuntu yakkety/main amd64 Packages
Ign:23 http://ppa.launchpad.net/realender/winconn/ubuntu yakkety/main all Packages
Ign:24 http://ppa.launchpad.net/realender/winconn/ubuntu yakkety/main Translation-en
Ign:25 http://ppa.launchpad.net/realender/winconn/ubuntu yakkety/main Translation-en_IN
Ign:26 http://ppa.launchpad.net/realender/winconn/ubuntu yakkety/main amd64 DEP-11 Metadata
Ign:27 http://ppa.launchpad.net/realender/winconn/ubuntu yakkety/main all DEP-11 Metadata
Ign:28 http://ppa.launchpad.net/realender/winconn/ubuntu yakkety/main DEP-11 64x64 Icons
Fetched 306 kB in 14s (20.6 kB/s)
Reading package lists... Done
W: The repository 'http://ppa.launchpad.net/realender/winconn/ubuntu yakkety Release' does not have a Release file.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: Failed to fetch http://ppa.launchpad.net/realender/winconn/ubuntu/dists/yakkety/main/binary-i386/Packages  404  Not Found
E: Some index files failed to download. They have been ignored, or old ones used instead.
Code:
$ sudo apt-get install winconn
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package winconn
 
Old 01-23-2017, 01:14 AM   #4
TheEzekielProject
Member
 
Registered: Dec 2016
Distribution: Devuan+lxde
Posts: 656

Rep: Reputation: 190Reputation: 190
It's failing to find the ppa files because it is looking for "yakkety", your current distro, and those files don't exist under that name.

You will want to edit your /etc/apt/sources.list, and remove that repository.

You might find this helpful
 
1 members found this post helpful.
Old 01-23-2017, 02:15 AM   #5
ddenial
Member
 
Registered: Dec 2016
Distribution: CentOS, Fedora, Ubuntu
Posts: 193

Original Poster
Rep: Reputation: 35
Quote:
Originally Posted by TheEzekielProject View Post
It's failing to find the ppa files because it is looking for "yakkety", your current distro, and those files don't exist under that name.

You will want to edit your /etc/apt/sources.list, and remove that repository.

You might find this helpful
OMG!!! It worked like a charm.

Thank you very much.
 
Old 01-23-2017, 02:19 AM   #6
TheEzekielProject
Member
 
Registered: Dec 2016
Distribution: Devuan+lxde
Posts: 656

Rep: Reputation: 190Reputation: 190
No problem! Glad it worked for you
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Easily manage your PPA in Ubuntu with Y PPA Manager LXer Syndicated Linux News 0 08-12-2012 07:10 PM
LXer: Y PPA Manager: One Stop Shop For All Your PPA Related Needs in Ubuntu Natty LXer Syndicated Linux News 0 05-14-2011 11:30 AM
LXer: How to install Libreoffice RC1 in Ubuntu, LinuxMint, Debian and Fedora |PPA Ubuntu LXer Syndicated Linux News 0 12-06-2010 07:30 AM
[SOLVED] install older package using rpm BlackCrowe Linux - Newbie 4 11-18-2010 05:45 AM
how to install an older version of a package... haora Linux - Newbie 1 05-27-2005 09:48 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 06:25 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration