LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Ubuntu and wireless NIC (https://www.linuxquestions.org/questions/linux-newbie-8/ubuntu-and-wireless-nic-931284/)

sgtzim 02-25-2012 04:11 PM

Ubuntu and wireless NIC
 
I have a dual-boot Ubuntu - desktop on one side, server 11.10 on the other.

My wireless works just fine on the desktop side, but not on the server.

The relevant part of the interfaces file:
auto wlan0
iface wlan0 inet static
address 192.168.1.6
netmask 255.255.255.0
gateway 192.168.1.1
network 192.168.1.0
broadcast 192.168.1.255
dns-nameservers 192.168.1.1
wpa-driver wext
wpa-ssid NETWORKNAME
wpa-ap-scan 1 (yeah, I'm broadcasting)
wpa-proto RSN (yeah, WAP is WPA2)
wpa-pairwise CCMP
wpa-group CCMP
wpa-key-mgmt WPA-PSK
wpa-psk PASSWORD

iwconfig produces:
wlan0 802.11b/g ESSID:"NETWORKNAME"
Mode: Managed Frequency=2.412 GHz Access Point: Not-Associated
Bit Rate: 11 Mb/s
Retry: on RTS: off Fragment thr: off
Encryption key: off
Link Quality=0/100 Signal level=0dBm Noise level=0 dBm
Rx invalid nwid: 0 Rx invalid crypt: 0 Rx invalid frag: 0
Tx excessive retries: 0 Invalid misc: 0 Missed beacon: 0

routing table is empty (duh)

iwlist scan produces:
wlan0 No scan results

when I run ifup -v wlan0, all of the wpa_supplicant checks come back "OK" on everything that I configured in "interfaces," but at the very end, I get the message "Failed to bring up wlan0" even though I had just run ifdown wlan0.

Am I missing some configuration setting, or is there some problem with Ubuntu 11.10 that doesn't exist with the desktop version?

On the wpa-psk, I've tried it as ASCII text and as the hex conversion of the ASCII, and neither of them work.

frankbell 02-25-2012 06:24 PM

The most likely cause is that you have a wireless chip that requires proprietary drivers, which are not in the standard software repository; instead they are in another repo that is easily enabled with about four mouse-clicks.

What kind of wireless chipset does your computer have? If you're not sure, you can run the command lspci in a terminal; the output should identify the wireless chip.

Post the relevant output here.

sgtzim 02-25-2012 06:32 PM

Realtek RTL8187SE Wireles LAN Controller (rev 22)

Like I said, the wireless NIC works just fine with the desktop side, it just isn't working with the server side.

So that makes me think it's something with boot up, or with a config file, or wpa_supplicant.

sgtzim 03-01-2012 08:45 AM

Well, I finally figured out the problem. I had a eth0 profile in my interfaces file, and all traffic was being routed to it. I deleted the eth0 portion of interfaces, and now everything works. Well, I imagine it was working before, but eth0 was acting as primary interface so everything was failing.

frankbell 03-01-2012 08:11 PM

Glad you're working. Sorry I missed your previous post but thanks for the rest of the story. It's likely to help some future visitor.

sgtzim 03-01-2012 11:27 PM

For someone that might be totally new to all of this, I meant to add that I do have two NICs...one is wireless and the other is ethernet. Both NICs have statically assigned IP addresses within the same subnet. When I had Cat-5 connected to the ethernet port, both the ethernet and the wireless NIC were visible on the network. When I disconnected the ethernet, obviously that IP address was going nowhere, but I also lacked connectivity on the wireless NIC even though all of the configuration settings for it were correct

eth0 was configured with 192.168.1.5
wlan0 was configured with 192.168.1.6

I didn't really pay attention at first, but I noticed that even when I had the ethernet unplugged, all PINGs sent from my server were being sent through the 192.168.1.5 NIC and kept returning "Destination host unreachable."

I'm certain there's a config file that would give the "first look" to the wireless NIC, or would make communication attempts with the wireless NIC if communications with the ethernet NIC failed.

There are a variety of reasons why you might want 2 or even more network cards on a server. I've not got this completely solved, but at least I know where to start looking now.

How can I force wlan0 to be the "primary" NIC, or at least have a config file set to iterate through all NICs on a given machine?


All times are GMT -5. The time now is 07:49 AM.