-   Linux - Newbie (
-   -   Ubuntu 9.10 nstallation insists my hard drives are raid... there not. (

bowbalitic 01-29-2010 07:17 PM

Ubuntu 9.10 nstallation insists my hard drives are raid... there not.
So windows wouldn't recognize my drives as a raid setup, so I disabled it and switched to IDE, now Ubuntu 9.10 installation will only recognize my drives as RAID. I have and ASUS M3A32-MVP Deluxe Series motherboard, it has 4 sata connectors and 2 marvel controlled sata connectors. In the 4 sata connectors I have my 2 wd 500gb hds, my dvd burner, and my external usb, esata slots. In the marvel controlled sata connector I have a wd 160gb hd.

Originally when I built the computer I wanted a raid setup with the 2 500 gb hds, but windows wouldn't recognize the raid set-up and wouldn't boot properly. So I said screw it and removed the raid and set all the drives to IDE. Then, when I tried to install Ubuntu 9.04 it would only recognize my 2 500 gb hds as raid. Gparted recognizes the drives as both raid and IDE. Eventually, after a day or two of praying and messing around the installer recognized both drives as raid and IDE.

A couple months later here I am trying to install Ultimate Edition 1.4 and I'm getting the same problem. Any ideas as to what's the problem??

michapma 01-30-2010 11:54 AM

I've no experience with RAID, but did you check all appropriate BIOS settings?

bowbalitic 01-30-2010 12:09 PM

Yes, and just about everything else...
Yes, I have checked, set to default, and tweaked just about every bios setting I can. I even set the drives to raid reformated them, and tried to do the install on a raid. It goes through the install everything looks fine, but when I restart I get a grub 22 error.

Also some things to note...
When I run the installer right after boot, it can only find the 160 gb drive. It isn't until I run Gedit that it recognizes the two 500 gb drives. When I run the installer after running Gedit the installer asumes the drives are a raid0 setup. Then when I run Gedit a second time after running the Installer a second time Gedit picks up the drives as a raid0. Once it does this I can not create any partitions using Gedit on and individual 500gb drive. Also, the disk utility is showing my 500 gb drives as seperate.

I never had this problem until Ubuntu 9.04, what did they change and how can I change it back?? Currently I have erased both my windows partitions, my ubuntu 9.04, partition, and all my storage partitions. I now have a unusable computer... all to try out Ultimate Edition Gamers Edition 64 bit. Any ideas would be greatly appriciated... Honestly, if I can I would prefer to have a Raid0 setup for increased speed.

r3sistance 01-30-2010 12:12 PM

I have seen issues similar to this with other vendor hardware,

My suggestion would be to find the marvell part number for the marvel raid controller and download the related driver for the storage controller and then install that into windows, that should allow it to hopefully run in raid.

bowbalitic 01-30-2010 12:24 PM

The drives that the installer is assuming to be raid are not pluged into the marvel connector, the 160 gb is. I have 6 sata connectors, 2 of which are controlled by marvel. The reason I do not have the 500 gb drives in the marvel is because Windows did not recognize the drives when pluged into marvel. Even when I used a floppy drive with the drivers on it.

Quakeboy02 01-30-2010 12:30 PM

Fakeraid/Motherboardraid uses a sector out near the end of the drive to designate the drive as part of an array. If you used the BIOS to remove all the arrays, that should have taken care of it. But, if the arrays persist, then it's likely that those sectors are still marked. You might look at the source code for dmraid. Somewhere in there, I think it's a .h file, the sector numbers are listed. You can look through your drives, find the markings. and zero the sectors. I believe that the sectors count backwards from the end of the drive, but it's been a few years since I looked into this. The control sector is not a part of any filesystem on the drive.

bowbalitic 01-30-2010 03:46 PM

Ok, so this is what I know know...
Apparently, the Ubuntu 9.10 team configured the live cd to come with all (most) of the packets necessary for a fakeraid installation. This is why the installer automatically assumes I have a raid. This would be fine if it actually worked properly... While searching, I found numerous threads where people where having trouble installing Ubuntu 9.10 on their raid setup, and even more who can't figure out how to make Ubuntu 9.10 to stop reading their drives as raid.

So far what I have been able to figure out is that if I uninstall dmraid and libdmraid1.0.0.rc15 I am able to view my two 500gb drives as separate drive on the installer. Unfortunately, I still see the raid setup. When I try to create partitions on the 500 gb drives it says I am unable to because they are in use by the filesystem.

I think it because there is something still trying to make the drives raid. With this said, I was wondering if it was dmsetup that was doing this. Unfortunately I can't remove it because Ubiquity (the installer) gets removed with it.

Does anyone know what packets were added to Ubuntu 9.10 that allows it to automatically read raid setups so I can remove them. Apparently 9.04 it was still a manual process where those looking to install on raid drives had install the packets themselves.

Thanks for all your help, I haven't been able to find solutions anywhere. On all the other sites I went to the solution was to switch to 9.04 and wait for the problems to be fixed.

JZL240I-U 02-01-2010 05:38 AM

Did you zero out the drives, as Quakeboy02 suggested and what was in the .h files?

bowbalitic 02-02-2010 09:39 AM

Thanks All!!
Sorry for not replying sooner, been busy...
No I did not 0 out the drives. But I did remove one of the 500 gb drive removed the dmraid packages, and was able to install 9.10 on the other 500 gb drive.

Thanks for all the help guys, it seems every time I try to do something in Linux I have errors. But this site has always been helpful, and without those errors I would be as clueless as most W$ users. :P Once again learning a lot, love Linux, love this site!

bowbalitic 02-06-2010 09:00 PM

Still have the problem...
I know that this thread is a weak old and I thought I had it fixed but I didn't. If you would rather me create a new thread let me know.

So as I mentioned last post, I removed one hd and I was able to install Ubuntu 9.10. All was well, I was enjoying my fresh Linux system when I decided that I wanted to play a game... So I plugged in my other hd, installed Windows, set the windows hd as boot and played my games. So now after a week of school I figure I want to use Ubuntu again and set the Ubuntu hd to boot. I get my grub menu, windows doesn't show up (as expected) and I wait for my system to boot. It gets stuck at a black screen so I hit enter and I get an error message saying that it couldn't locate my filesystem and puts me in a minimum bash. I tried using the Install dvd to repair grub 2 but I cant mount any of my partitions. fdisk recognizes the partitions. I tried to 0 out dmraid but I can not find any .h files (I did a search in the filesystem)

(Windows boots fine if I set it as default boot hd on motherboard)

I'm sorry to bother everyone again with this post, but I have no idea what's going wrong. Thanks again for your help and patients.

r3sistance 02-07-2010 11:52 AM

I have had a look around and if you are ok with reinstalling, I believe the answer may be found here

Fred Caro 02-07-2010 12:25 PM

Grub 1 and Grub2 are different. G2 is still experimental. The two do not seem to go together. Always put Windoze on first. Raid can be setup in different ways or not at all??


bowbalitic 02-07-2010 01:51 PM

Thanks for the reply, but...

To R3sistance I had already tried to install with dmraid removed, (I figured it was something raid related since the installer would only recognize raid but would not install to raid properly so I searched raid under synaptic and removed dmraid) but I was still unable to create partitions to the drive.

To Fred Caro, I removed the windows partition when I tried to install in raid as a last resort. But even when I had windows installed first the install cd insisted my drives were raid. Also, grub 2 is default on ubuntu 9.10.

As mentioned earlier, I installed Ubuntu on its own hd with the other hd removed. It worked fine, I then plugged in the other hd and installed window to it (and set it as the boot drive in bios) Windows worked fine. But when I set the Ubuntu drive to boot in the bios I get my grub window (without window) but when it tries to boot to Ubuntu 9.10 it says it can not locate filesystem.

So basically, I have a windows drive with its windows mbr, and I have a linux drive with grub2 that doesn't work. I am now working under ubuntu 9.04 live cd and trying to fix grub2 that way. I installed grub2 to the live cd (for session of course) and tried to run sudo update-grub2 but it cant find /. Any ideas for installing grub 2 this way will be helpful. Thanks all.

bowbalitic 02-07-2010 05:37 PM

well guys, I've given up...
There are too many bugs and to many experiments on Ubuntu 9.10 for me (grub2 and dmraid being my least favourite :P) I've just decided to stick 9.04 for now. its been working well enough. Thanks for all the help and sorry we couldn't find a solution for any other poor guy stuck in this position (assuming I'm not the only one who manages to find every bug out there, I should start my own collection mounting dmraid and grub2 next to the butterflies) Any way, thanks again.

Fred Caro 02-08-2010 06:32 AM

grub + booting
As a general point, windows will only boot windows. Grub1 will take over and boot owt if put on second. Grub2 is still experimental and obeys different commands than Grub1 so the two are in a way incompatible.Thus putting 2 versions of linux, with differing grubs, on the same disk will not work. I do object to being a lab rat for someone's grub experiment.


All times are GMT -5. The time now is 08:02 PM.